Results 1 to 6 of 6

Thread: Sound problem on MSI EX620

  1. #1
    Join Date
    Apr 2009
    Beans
    1

    Sound problem on MSI EX620

    Hi there!

    I have just installed Ubuntu 8.10 on my MSI EX620 laptop. I am completely new to Linux and ubuntu, and I have the following problem.

    I can play sound files, but there does not come any sound from the speakers. I've got a double boot, with windows vista on the second partition. When the computer is running in windows there is no problem with sounds. It was bought with vista pre-installed.

    I think the sound card is ATI HDMI Audio.

    Maybe someone carefully can give instructions on how to get the sound working when in Ubuntu?

  2. #2
    Join Date
    Jul 2009
    Beans
    1
    Distro
    Ubuntu Studio 9.04 Jaunty Jackalope

    Re: Sound problem on MSI EX620

    I know this is old, but I have the same machine except I am running 9.04. I think the steps may be the same. The sound was actually working on mine but only out of the jack on the side.
    To fix:
    add "options snd-hda-intel model=6stack-dig probe_mask=1"
    To the end of /etc/modprobe.d/alsa-base.conf
    reboot

    I actually found this on another forum, but I cant remember where that was now.

  3. #3
    Join Date
    Apr 2007
    Beans
    90

    Re: Sound problem on MSI EX620

    To fix:
    add "options snd-hda-intel model=targa-dig"
    To the end of /etc/modprobe.d/alsa-base.conf
    reboot

    This works better for me because when using the headphone the speakers disable automaticly. It also is advised for msi in /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz

  4. #4
    Join Date
    Jul 2012
    Beans
    2

    Re: Sound problem on MSI EX620

    Hi
    I have the same problem :/
    when I trayed to add "options snd-hda-intel model=targa-dig"
    To the end of /etc/modprobe.d/alsa-base.conf
    I got a message telling me that it's not possible to save that file .
    can you help me in this ?

  5. #5
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Sound problem on MSI EX620

    Change model= targa-dig

    to model=auto

  6. #6
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Sound problem on MSI EX620

    To edit/save the file run this in terminal
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Enter your password
    file will open
    Scroll to end of file
    Add line (try your original option first)
    Click save button (in file window)
    close/save in etc folder(click etc , click save , close)
    Restart pc/laptop for change to take effect
    Make sure volumes are not muted
    test sound

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •