Page 46 of 47 FirstFirst ... 3644454647 LastLast
Results 451 to 460 of 470

Thread: HOWTO: Installing Neverwinter Nights Platinum

  1. #451
    Join Date
    Feb 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    So, I've installed the game following the BioWare site tips and I was trying to "install" the movies, when I try to
    "3) Run the with './ /usr/lib/'", this problem happens:

    NOTICE: Examining sound configuration for some clues...
    NOTICE: Take this output with a grain of salt..

    NOTICE: It appears none of your PCM playback devices supports
    NOTICE: more than one simultaneous channel.
    NOTICE: You may need to look into software mixing, via dmix, or ESD/ARTSD.

    What should I do?

    Thank you.

    So, even with these problems, I continued to "install" the movies, apparently everything was apparently perfect. When I used the "./nwn" to run the game the Atari "movie" appeared (with no sound) then the screen went black and nothing happened after that, I tried to use "alt+tab" to switch the windows, but every window was black (The console window, the NWN window and the Bink Player window).

    So I deleted the ./lib of the nwn script and now the initial movies work, but when I try to see the campaign movies, the screen frozen and I hear the only sounds of the campaign movies but I can't see them :/
    What should I do?
    Last edited by The Big Head One; February 9th, 2011 at 03:18 AM.

  2. #452
    Join Date
    Jul 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum and Diamond Edition now with Movies

    "On Ubuntu, this will be /media/cdrom for the first drive."

    Okay, so I'm a total noob when it comes to Linux, and I pray that you all will forgive me. But I get to this step, and now I'm totally confuzzled (wife made up word, it means to be confused and puzzled at the same time).

    I get this error: INVALID DEVICE! Please check the device and try again

    Now, I've tried _DVD, dvd0, dvd1, cdrom, cdrom0, cdrom 1 and nothing works.


    Any help, thanks in advance!!


  3. #453
    Join Date
    Jul 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    Can any good soul update the installation process?

    Due the Bioware old foruns arent working, I cant reach any other help to install Neverwinter Nights on Ubuntu 11.04.

    Thnx in advance!

  4. #454
    Join Date
    Jul 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    Ok, just managed to install all files following a post from Fernando Scherer.

    My issue now is the hardware mouse...

  5. #455
    Join Date
    Nov 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    This is the best that I can do to help you guys, I found this after 6 hrs of searching. Anyways, hope it helps you as well as it did me.

    I couldnt post the actual link, but go to the social section and forums on bioware's official page. its not that hard to find
    Last edited by crunchy_chicken; November 29th, 2011 at 02:26 PM.

  6. #456
    Join Date
    Dec 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    It warms my heart to see that this thread is still active!

    So, I made the big switch from xp to Ubuntu Lucid a couple weeks ago and I couldn't be happier seeing my PC being productive for me instead of being productive for MS.

    My problem lies in the execution of the script:

    Previously I installed all the dependencies to run NWN and copied over from an existing xp install, then added the requisite nwclient129.tar.gz; nwresources129.tar.gz; and English_linuxclient169_xp2.tar.gz. Ran ./fixinstall and I actually had it running up to the choose ' single/lan/internet' game screen so I know that much is there. The game would crash/exit/do nothing when I tried to advance to the multiplayer selection.

    I removed /games/nwn/ to start again to see if I had a bad install and started from scratch.

    Running goes fine up untill it looks for the disks and no matter where I tell it to look, it comes back INVALID DEVICE. I've tried everything in /media/;/dev/; and hdd directories where both install data and data from the cds was copied to but still I get INVALID DEVICE.

    Could I be missing some dependency for the script to operate properly? Am I missing something obvious?


  7. #457
    Join Date
    Dec 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    here's my story how I made NWN work on linux.

    I've tried two methods of instaling NWN on linux, none of them worked. first method was from this site:
    I encountered some "no gui found" message and the game freezed. Second method is at the beginning of this thread. However I always got "invalid device" message, no matter what i did (i've got ISO image). so I tried something else. I installed my NWN (diamond edt) by wine. then copied game folder from .wine to where i wanted my linux-NWN to be installed. then I followed steps from Robot Butler's site. everything works fine, apart from movies, which are not being played at all (haven't tried to fix it yet). anyway I thought that native NWN would be faster than wine. It isn't, and the game works fine under wine.

  8. #458
    Join Date
    Dec 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    So, being completely new to Ubuntu, I hope I'm not asking a dead end question here. I recently installed Ubuntu, and shortly thereafter got the itch to play NWN. However, I don't have it on CD's, I have the downloadable version via Good Old Games. This version downloads as an .exe file, and two .bin files. Is there any way to get these working in Ubuntu, or is it strictly limited to Windows?

  9. #459
    Join Date
    Dec 2011

    Re: HOWTO: Installing Neverwinter Nights Platinum

    NWN on Ubuntu 11.10

    To begin with, I have no real experience with Ubuntu or Linux. I just happen to be part of a teacher group where we learn about different kind of computer support where Linux/Ubuntu and Edubuntu was used. I just fell in love with Ubuntu.

    I really want to be able to play NWN and didn't know how to do it in Ubuntu, or if it even was possible. NWN is really the only reason why I should continue to cling to my Windows 7 system. All my other needs are covered by Ubuntu in a nicer way than in Windows. I made an inquiry here:
    and it sounded so good so I thought I'll give it a shot and write down what's easy or hard for a Linux newbie as me to do.

    Technical stuff
    I use a 64 bit packard Bell laptop, bought this year.
    Ram: 3,9 GiB
    Proc: AMD Athlon(tm) II Dual-Core M320 × 2
    Graphic: VESA: M96 (ATI card) with proprietary drives

    Software and scripts
    Ubuntu 11.10, in my case it's 11.04 64 bit updated to 11.10 and with Swedish language installed inside Windows with the Wubi installer, if it's any difference.

    A working 3D environment. I downloaded and installed the free 3D car game “Vdrift” before so I knew that 3D games are possible to play on the computer.

    The english platinum/diamond DVD with all three Cd's on.
    (If you just want to try this out, this DVD can be found as a torrent file in a multitude of places on the Internet)

    1.69 script for Linux found here: (483 MB)

    Linux install script here: (36 kb, but you must be a member of the forum)

    You must install the “Unshield” program, do it through the Ubuntu program central (paperbag icon at the left edge of the screen)

    nwclienthotu can be found here (37.8 MB):
    download it to your home directory unpacked.

    Linux client 1.29 can be found here (5.2 MB)
    download it to your home directory unpacked.

    I Installed Gmount-iso to mount the DVD iso-file. Maybe you don't have to if you know Linux better than I.

    As I said, I don't have anyone that can help me with this, so I have used information from Internet, mainly this page:
    Here is a HOW-TO that I followed too, but gave up. I took the install script from this page though.
    For those with just different CD:s

    Begin (09.15 am)
    *I started to download the 1.69 patch for Linux, but here the first problem arose. I have only used the APT package handler before, but the script was submitted in another format called gz. I just opened it with the standard program suggested by Ubuntu. It took me 7 minutes to bring it home.
    *I got a list of files and folders, I placed myself in my home directory and extracted all. Maybe that wasn't too smart, but so it was written in the guide. Now I have a mess of files in my home directory instead.
    *It says “Enable the Universe repository; Open up Synaptic Package Manager, System -> Administration -> Synaptic Package Manager. Enter in your Password. Click on Settings, and select Repositories. Click Add. Then put check marks in the box for Community maintained (Universe) and while you're at it, may as well put one in Non-free (Multiverse)”
    But here I'm stuck. Universe or Multiverse can't be found. At all. I assume I check “Updates without official support (sourcecode)” and “Independent (sourcecode)” instead.

    Next step says: “After clicking OK on both dialogs, click Search and type in unshield. It will show three packages, just double click on unshield and it will ask you if you also want to mark libunshield, which is required. Click Mark. Click Search again and type in msttcorefonts. Double click it to queue the package and click Apply. This will download and install both Unshield and the fonts required by Nevewinter Nights. Unshield is required by the installer”, so I do as it says. I search for unshield but to no avail. So here I'm stuck for good and the time is 09.46 am.

    Step 2
    *I decide to go with just the script.
    But here is next problem, I can't get it without being member of the Ubuntu forum. How stupid isn't that? After I have filled in the membership registration, I got the script: in my home directory, unpacked it to
    *By default Ubuntu uses dash as a shell, but the script relies on bash to run properly. So to change it, you start a terminal (CTRL+ALT+T) and write:
    sudo dpkg-reconfigure dash
    And answer No if you want it to be permanent (which you don't). After installing the game, you'll probably want to switch back to using dash, as to not mess up any advantages of speed that dash may provide. Run the command again and select Yes.
    *You'll probably need Microsoft TTF fonts in the game too, so you install them with:
    sudo aptitude install -y unshield cabextract ttf-mscorefonts-installer
    But that doesn't work sighs it says that aptitude is an unknown command. Why? I don't know, it's 10.08 am and I take a coffee break to calm down.
    Tries: sudo apt-get install -y unshield cabextract ttf-mscorefonts-installer
    and it works just fine. But it turns out that I already have all fonts needed and the command does nothing.

    Mounting the DVD
    I'm not a Linux geek and I don't know how to mount stuff. So I just put the DVD in the lap top and let Ubuntu read it. It seems to work just as fine as in Windows with a DVD icon in the left task bar which I can read by just double click on it.

    Create install directory
    Use the same terminal window and write:
    mkdir -p ~/games/nwn
    It creates a new directory called games and under that a directory called nwn in your home directory.

    Install the script
    So, the old script from the ubuntu forum is downloaded and ready to run, let's try to use the terminal window and write:
    Bugger “file doesn't exist” it says. Checking again, the file is not extracted, instead it's in the download folder but it is greyed out and I don't know why. I right click on the archive, choose “Extract here” which seems to work and after that I move the file to my home directory and try again:

    Platinum or Diamond?
    The script start and I have a choice, do I have the platinum or the diamond edition? How am I supposed to know when it's not written on the outside? Diamond edition has three extra premium modules, if you don't have those three extra modules, you have a platinum edition, or De Luxe edition as it is called in Europe.
    Next error comes here; the script ends with a halt since it wants “unshield”. Unshield isn't installed, but can be found here according to the terminal window message:
    To bad, it goes to a 404 page. Sighs
    I use the Ubuntu Program Central instead (icon at left side of screen that looks like a paper bag) and types in “Unshield”. And there I got a hit.

    I try the script again after installing Unshield:
    and now it's working just fine

    CD or DVD
    I'm using a DVD so I choose that.

    Client files
    I know I have downloaded 1.69, but not the rest. Now it complains that nwclient129.tar.gz and nwclienthotu.tar.gz can't be found. I better download them now then....
    Version 1.29 can't be found where the instruction page has a link, it's dead. I have to search for nwclient129.tar.gz in some other way. Gooogle showed a lot of option and I choose this place:
    Nwclienthotu.tar.gz could be found here:

    After I have downloaded both and copied the unpacked archives to my home directory, I try to just hit yes I have the files in my hoe folder and hit enter.

    Next problem “Patch file could not be found in home folder” what the … does that mean? I hit Y for yes and try to download it. Next question, what patch do I want to use? 1.67 is the highest, but I use 1.69. Hmm. According to the guide, I can just write in “169” and then choose “english” as language. 1.67 was the highest patch number when the script was written, but with 169 it searches for the right script. Let's try it:
    169 and then ENG for English works just fine, but after that it can't find the DVD!? It looks for it in /media/dvd but as the noob I am, I have no clue about where it is to be found or how to make Ubuntu find it. When I check it graphically in the explorer window, it seems to be /media/_DVD but trying that I just get the answer that /media/_DVD is a folder. So, here I'm stuck. I have to mount that DVD anyway

    Mounting a DVD
    Open a terminal window and write:
    sudo mount _DVD.iso /media/floppy0 -t iso9660 -o loop
    Error; the file or catalog doesn't exist.
    I try:
    sudo mount _DVD.iso /media/isoimage/ -t iso9660 -o loop
    Doesn't work either

    So here I am, totally stuck and the silly thing is that I can open any file in the /media/_DVD folder where the DVD disc for NWN is to be found, I just can't start the install script for it. The problem is that I don't know if the error message say that it can't find the source DVD or if it can't find the destination folder.

    On Internet, I found a link to a small program called Gmount-iso which can be used to mount ISO files in Ubuntu. I Install it through the program central.

    It turns out that it is nigh impossible to mount the files. The programs are looking for an ISO file but can't find it, only the files on the DVD. To be able to install NWN I have to copy the DVD to an ISO file to be able to mount it. Silly? Yes, I think I'm doing something wrong but it seems to be the only way to do it. It's 2.3 GB in size. I do hope Wubi can manage such large file.

    The time is 11.20 am and I'm utterly frustrated.

    I use the terminal in the media folder and create a new folder named floppy0:
    sudo mkdir floppy0
    And after that I went to my home directory and wrote:
    sudo mount _DVD.iso /media/floppy0 -t iso9660 -o loop
    And it worked.... I copied the DVD ISO to no avail, the problem was that it had no folder named floppy0 to mount at. I get a warning that it's read only, but I assume it's ok since it's a DVD disc.

    Try 3 from the beginning:
    Run script:
    Choose 5 (= platinum edition for me)
    finds Unshield => hit enter
    Choose DVD => Enter
    Finds both client files => Enter
    Asks for patch file => Hit Y and Enter
    169 => Enter
    ENG => Enter

    And now, enter the path to the mounted DVD
    Error, invalid Device
    bash: /media/floppy0: is a folder

    (sighs heavy)....

    I try to mount the copied ISO to floppy0 by using Gmount-iso, but I just get the error message that floppy0 isn't empty (of course not since it connects to the DVD). Stuck again.

    Try 4
    I create a new folder in media and name it cdrom. Use chmod777 to make it usable by all.
    Sudo chmod777 cdrom

    After that, I use Gmount-iso to mount my copied ISO-file. Same error again:
    An error occured
    /media/cdrom seems to be mounted read-only

    But it is an ISO from a disc so that shouldn't be a problem.

    Go back to home folder and run all scripts again:
    But with the same error:
    INVALID DEVICE! Please check the device and try again

    When I try to unmount it, I get this error:
    umount: /media/cdrom is not in fstab

    So, right now its 12.38 pm and I'm giving up. Are there anyone else who can help me by telling me how to mount that ISO so the installation might go on?


  10. #460
    Join Date
    Jun 2005
    Athens, Greece
    Ubuntu 6.06

    Re: HOWTO: Installing Neverwinter Nights Platinum

    Quote Originally Posted by maria_e_andersson View Post
    NWN on Ubuntu 11.10

    When I try to unmount it, I get this error:
    umount: /media/cdrom is not in fstab

    So, right now its 12.38 pm and I'm giving up. Are there anyone else who can help me by telling me how to mount that ISO so the installation might go on?

    Maria, try this:

    sudo mkdir /mnt/iso
    sudo nano /etc/fstab
    add this to /etc/fstab (replace my_nwn_dvd.iso with the full path to your iso file):

    my_nwn_dvd.iso    /mnt/iso    iso9660    noauto,loop,ro    0 0

    mount (full path to iso)

    when the script asks for dvd path, give '/mnt/iso'

    After installation, remove that entry from your /etc/fstab, or comment it out.
    Last edited by tsagas; January 12th, 2012 at 05:55 PM.

Page 46 of 47 FirstFirst ... 3644454647 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts