Results 1 to 9 of 9

Thread: Unable to install on a G4--returning from prom_init

Hybrid View

  1. #1
    Join Date
    Aug 2005
    Location
    CA
    Beans
    254
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Unable to install on a G4--returning from prom_init

    I'm trying to install Ubuntu 8.04 on an old PPC G4 I just started messing with, and I'm not able to actually start the install. It will boot the CD just fine and I try the 'expert install video=ofonly' command (along with just install video=ofonly and install). It starts loading the kernel, then the screen changes to grey with black text, stating the following:

    Code:
    done
    copying OF device tree..
    Building DT strings...
    Building dt structure...
    device tree strings 0x022b0000 --> 0x22b0ac8
    device tree struct 0x22b1000 --> 0x022c3000
    Calling quiesce...
    returning from prom_init
    The screen will hang there for about 3 minutes, then the system reboots.

    It is worth noting that I don't know the specs on the machine itself, and that while it did run OSX at some point, today it will not boot to that, either. When I try to boot from the HDD, I simply get the Apple logo, then nothing.

    Thanks,

    jim

  2. #2
    Join Date
    Jan 2008
    Beans
    19
    Distro
    Xubuntu 9.04 Jaunty Jackalope

    Re: Unable to install on a G4--returning from prom_init

    if you are still a user of this forum, could you go back into your archives and recall how you (if you) solved this problem? I have the same one 5 years later!

  3. #3
    Join Date
    Jun 2009
    Location
    San Diego, California
    Beans
    14
    Distro
    Ubuntu Development Release

    Re: Unable to install on a G4--returning from prom_init

    I have the same problem and would love an answer if anyone has one.
    Sorry for bringing the post back from the grave

  4. #4
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,105

    Re: Unable to install on a G4--returning from prom_init

    What CD are you trying? Surely not 8.04? Also, what exact machine do you have? Can you provide a link at everymac.com please?

  5. #5
    Join Date
    Jun 2009
    Location
    San Diego, California
    Beans
    14
    Distro
    Ubuntu Development Release

    Re: Unable to install on a G4--returning from prom_init

    Sorry for not being more specific.

    Stock 450 MHz PPC G4 Cube, 320 MB RAM, Open Firmware Apple 4.1.9f1 BootROM (built 2001-09-14)

    PPC Oneiric minimal installer ISO

  6. #6
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,105

    Re: Unable to install on a G4--returning from prom_init

    A Cube! Excellent, I am jealous! I wanted to buy one of them to turn into an internet radio - but they cost like a hundred pounds over here!

    I have to confess, I've never heard of your error before. I'm a little unclear when this is happening. Is is during trying the install or when rebooting after an install?

    Have you tried the yaboot paramters video=ofonly nosplash ?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •