Results 1 to 4 of 4

Thread: Please help with Icecast2 + DarkIce + Jack Audio

  1. #1
    Join Date
    Apr 2009
    Beans
    1

    Question Please help with Icecast2 + DarkIce + Jack Audio

    My Questions:
    • How do I connect the microphone input to DarkIce using Jack Audio through the command line?
    • When I run DarkIce, I get the error: "DarkIce: LameLibEncoder.cpp:75: lame lib opening underlying sink error [0]". How do I fix this?


    My Installation Steps:
    Step 1: Install Ubuntu Server 8.10
    1. Full user name: admin
    2. User name: admin
    3. Password: somepassword
    4. leave http proxy information blank
    5. Upgrade management: Install security updates automatically
    6. Install no extra software


    Step 2: Install kubuntu-desktop Package
    1. run “sudo nano /etc/apt/sources.list”
    2. Add “deb http://archive.ubuntu.com/ubuntu intrepid universe multiverse”
    3. Add “deb-src http://archive.ubuntu.com/ubuntu intrepid universe multiverse”
    4. run “sudo aptitude update”
    5. run “sudo aptitude install kubuntu-desktop”
    6. run “startx”


    Step 3: Install Icecast2
    1. open the terminal
    2. run “sudo apt-get install icecast2” (installed 2.3.2-2)


    Step 4: Configure Icecast2
    1. run “sudo nano /etc/icecast2/icecast.xml”
      1. Edit the file to match the sample icecast configuration
    2. run “sudo nano /etc/default/icecast2”
    3. change “ENABLE=false” to “ENABLE=true”


    Step 5: Install Lame and Lame libs (for darkice lame support)
    1. run “sudo apt-get install lame” (installed 3.98-0)
    2. run “sudo apt-get install libmp3lame0” (installed 3.98-0)
    3. run “sudo apt-get install libmp3lame-dev” (installed 3.98-0)


    Step 6: Install Jack Audio and Jack Audio libs (for darkice jack support)
    1. run “sudo apt-get install jackd” (installed 0.109.2-3ubuntu1)
    2. run “sudo apt-get install libjack0” (installed 0.109.2-3ubuntu1)
    3. run “sudo apt-get install libjack-dev” (installed 0.109.2-3ubuntu1)


    Step 7: Install ALSA libs (darkice won't compile without them)
    1. run “sudo apt-get install libalsa-ocaml”
    2. run “sudo apt-get install libalsa-ocaml-dev”


    Step 8: Install g++
    1. run “sudo apt-get install g++”


    Step 9: Install DarkIce (must be built from source because the intrepid package does not come with lame support)
    1. run “cd /home/admin/Desktop”
    2. run “wget http://darkice.tyrell.hu/dist/0.19/darkice-0.19.tar.gz”
    3. run “tar -xvvzf darkice-0.19.tar.gz”
    4. run “cd darkice-0.19”
    5. run “sudo nano src/JackDspSource.cpp”
      1. insert “#include "limits.h"” after “#include "AudioSource.h"” (required to get DarkIce to compile)
    6. run “./configure --with-lame --without-vorbis --without-faac --without-twolame --with-alsa – with-jack”
    7. run “sudo make”
    8. run “sudo make install”


    Step 10: Configure DarkIce
    1. run “sudo nano /etc/darkice.cfg”
      1. Edit the file to match the sample darkice configuration


    Step 11: Start Jack server
    1. run “jackd -d alsa”


    Step 12: Start Icecast2
    1. run “sudo /etc/init.d/icecast2 start”


    Step 13: Start DarkIce
    1. run “darkice”
    Icecast2 Configuration:
    Code:
    <icecast>
        <limits>
            <clients>5</clients>
            <sources>1</sources>
            <threadpool>5</threadpool>
            <queue-size>524288</queue-size>
            <client-timeout>30</client-timeout>
            <header-timeout>15</header-timeout>
            <source-timeout>10</source-timeout>
            <burst-on-connect>1</burst-on-connect>
            <burst-size>65536</burst-size>
        </limits>
    
        <authentication>
            <source-password>apass</source-password>
            <relay-password>anotherpass</relay-password>
            <admin-user>admin</admin-user>
            <admin-password>adminpass</admin-password>
        </authentication>
    
        <hostname>localhost</hostname>
    
        <listen-socket>
            <port>8000</port>
        </listen-socket>
    
        <fileserve>1</fileserve>
    
        <paths>
            <basedir>/usr/share/icecast2</basedir>
            <logdir>/var/log/icecast2</logdir>
            <webroot>/usr/share/icecast2/web</webroot>
            <adminroot>/usr/share/icecast2/admin</adminroot>
            <alias source="/" dest="status.xsl" />
        </paths>
    
        <logging>
            <accesslog>access.log</accesslog>
            <errorlog>error.log</errorlog>
            <loglevel>3</loglevel>
            <logsize>10000</logsize>
        </logging>
    
        <security>
            <chroot>0</chroot>
        </security>
    </icecast>
    DarkIce Configuration:
    Code:
    [general]
    duration      = 0
    bufferSecs    = 5
    
    [input]
    device        = jack
    sampleRate    = 44100
    bitsPerSample = 16
    channel       = 2
    
    [icecast2-0]
    bitrateMode   = cbr
    format        = mp3
    bitrate       = 128
    server        = localhost
    port          = 8000
    password      = apass
    mountPoint    = test
    name          = A Test Stream
    description   = A test of darkice and icecast 2
    url           = http://somewebsiteorwhatever.com
    genre         = test
    public        = no

  2. #2
    Join Date
    Oct 2010
    Location
    London
    Beans
    3
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Please help with Icecast2 + DarkIce + Jack Audio

    We seem to be having a similar number of issues with Icecast2 and DarkIce with 10.10. All seems configured properly but of course there is now no /dev/dsp to hook into. We've tried using Alsamixer to set up a default input stream and thus have

    Code:
    device = default
    Alternatively I've set up and run jackd. On both, starting Darkice with

    Code:
    darkice -c darkice.cfg
    always returns with something like

    Code:
    DarkIce 0.20.1 live audio streamer, http://darkice.tyrell.hu/
    Copyright (c) 2000-2007, Tyrell Hungary, http://tyrell.hu/
    
    Using config file: /usr/share/streaming/darkice.cfg
    Using ALSA DSP input device: djack
    DarkIce: Util.cpp:263: number conversion error [0]
    I've not managed to get my "best friend" (ie Google) to tell me an answer to what is causing this number conversion error.

    Any ideas anyone? It would really help to have some consolidated instructions on how to get live audio streaming up and running but the fragmented nature of Linux and the vast range of audio hardware just seems to cause confusion.

  3. #3
    Join Date
    Jul 2005
    Beans
    51
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Please help with Icecast2 + DarkIce + Jack Audio

    .
    Last edited by JackandJohn; March 29th, 2011 at 11:19 PM. Reason: posted to the wrong thread

  4. #4
    Join Date
    Oct 2009
    Beans
    27

    Re: Please help with Icecast2 + DarkIce + Jack Audio

    I would also like to know the answer to your first question, kaprodemono.
    From what I understand, there are only 2 options for jack in the darkice config file: You can call the device 'jack' and then patch it manually in JackPilot, or you can call it 'jack_auto' to have it automatically patch the first input device. I haven't found any documentation explaining how to specify an input. But the ChangeLog says that feature was implemented way back in version 0.19. See here: http://darkice.org/ChangeLog
    Perhaps this may be of help: http://www.lecentre.net/blog/archives/112

    Regarding your second question, I think you may have configured darkice with the wrong path for lame. I noticed that it expects the lame libraries to be in /usr/lib, but the lame install puts them in /usr/local/lib by default. Try ./configure, make, make install again for darkice, but specifiy --with-lame-prefix=/usr/local.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •