Results 1 to 6 of 6

Thread: Disable GTK background fade in Jaunty Jackalope

  1. #1
    Join Date
    Dec 2007
    Location
    Toronto
    Beans
    15
    Distro
    Ubuntu 10.04 Lucid Lynx

    Exclamation Disable GTK background fade in Jaunty Jackalope

    I upgraded to the Jaunty Jackalope beta a few days ago, and I have been experiencing performance problems with the new feature. I have wallpapertray, a small panel app that changes my background periodically, and my integrated graphics [chipset] is not designed to handle that kind of animation, and it maxes out my CPU for a few seconds every minute. I really want to diasble this feature, but I cannot find a reference in gconf-editor, or Compiz. Another thread said that it was a GTK feature.

    Does anyone know how to disable this feature?

    Thanks in advance.
    Last edited by markoid8; April 15th, 2009 at 12:55 AM.

  2. #2
    Join Date
    Dec 2007
    Beans
    26

    Re: Disable GTK background fade in Jaunty Jackalope

    bump. i'd also like to.

  3. #3
    Join Date
    Apr 2006
    Location
    Dallas, TX
    Beans
    1,359
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Disable GTK background fade in Jaunty Jackalope


  4. #4
    Join Date
    Jan 2009
    Beans
    6

    Re: Disable GTK background fade in Jaunty Jackalope

    That works! Thank you

  5. #5
    Join Date
    Nov 2008
    Location
    irvine, ca, usa
    Beans
    3

    Re: Disable GTK background fade in Jaunty Jackalope

    A partial solution for metacity users is to make metacity a composing manager.

    Run the "gconf-editor" command.
    Go to apps-> metacity -> general.
    Check the "composing_manager" option.

    In my case, the result of this was that, although performance-wise I still experienced the same CPU spikes and temporary interface freezes while changing desktop images, visually there was no longer the "fade" effect during the transition between pictures. Instead, pictures changed directly from one to the other, as they did previously in Gnome (though now with a slight delay).

  6. #6
    Join Date
    Nov 2008
    Location
    irvine, ca, usa
    Beans
    3

    Talking Re: Disable GTK background fade in Jaunty Jackalope

    For those of you with Intel graphics chipset, the solution should come with the next release of Ubuntu (9.10 karmic koala). Currently the solution is listed as unstable, but I tried it and it worked for me!
    The link below provides the solution (really simple), as well as guide to what to do if something goes wrong (which seems simple as well).
    https://wiki.ubuntu.com/X/UxaTesting

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •