Results 1 to 4 of 4

Thread: Hardy Heron sending mail as "unknown sender"

  1. #1
    Join Date
    Apr 2009
    Beans
    2

    Hardy Heron sending mail as "unknown sender"

    I am running 8.04.1 (Hardy Heron) on a dedicated server (as preinstalled by my server host), so of course I can be root. Everything is going really well. This one is a minor but puzzling problem: all my outgoing mail (from the Hardy server to anyone else out in the world) arrives as "unknown sender". More specifically, all mail sent by my server shows up with a blank "From" line.

    So far this affects all outbound mail, I mean, mail originating on the server, such as messages sent by users with the mail (or mailx, etc.) command, and also from cron job output.

    The server is running Postfix. What am I doing wrong?

    Thank you.

    Regards,

    Ralph

  2. #2
    Join Date
    Jun 2006
    Location
    Switzerland
    Beans
    Hidden!
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: Hardy Heron sending mail as "unknown sender"

    you got a hostname set?

  3. #3
    Join Date
    Apr 2009
    Beans
    2

    Re: Hardy Heron sending mail as "unknown sender"

    Thank you for your reply.

    Yes, I have a nice, simple, alphanumeric hostname set.

    Note: If I run the "mail" command and add a "From:" header, then the resulting outbound message is normal -- that is, it carries the specified sender address, and it does not get marked "unknown sender."

    But email from cron should automatically have a sender name, shouldn't it?

    Ralph

  4. #4
    Join Date
    Jun 2006
    Location
    Switzerland
    Beans
    Hidden!
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: Hardy Heron sending mail as "unknown sender"

    it has on my server a sender name... I think...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •