Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

  1. #1
    Join Date
    Mar 2009
    Beans
    11

    Smile Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    I've been scouring forum postings for a week or two now and I've just about given up.

    A while back I messed up my Gnome desktop, including moving the top panel to the right side of the screen, removing a bunch of icons such as the battery status icon and the wireless icon that looks like 4 blue bars of varying heights.

    Now I can't choose which wireless network I'm connected to.

    I've tried the following already:

    killall nm-applet
    nm-applet --sm-disable

    upon running nm-applet, the terminal window hangs indefinietly until I press CTRL+C.

    Originally, after installing drivers, etc. I got this working by running "iwconfig" and "iwlist scan", but now when I run iwconfig I get the following output:

    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11 Nickname:""
    Access Point: Not-Associated

    Can someone PLEASE help me understand why I'm getting these messages and what I can do to fix them?

    Thanks in advance for your help!

  2. #2
    Join Date
    Mar 2009
    Beans
    11

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    UPDATE:

    This morning I added the Notification Area to the top panel and now I again have the battery meter and update icons, etc. But the wireless icon is still missing.

    In addition, I forgot to mention before, but the network manager icon is there (looks like 2 little monitors), but in no way does this help me control wireless. I found a screenshot which shows both this NM icon and my missing wireless icon:



    I'm connected to the internet through wireless right now, but I'm willing to bet I'm connected to my neighbor's unsecured router, rather than mine.

    Any help would be much appreciated!

  3. #3
    Join Date
    Mar 2009
    Beans
    11

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    ONE MORE UPDATE:

    I just tried prepending the "wlist scan" command with "sudo" and now I'm getting this:

    $ sudo iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    eth1 Scan completed :
    Cell 01 - Address: 00:90:4C:7E:00:6E
    ESSID:"Celtics"
    Mode:Managed
    Frequency:2.462 GHz (Channel 11)
    Quality:4/5 Signal level:-63 dBm Noise level:-92 dBm
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK
    Encryption key:on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
    12 Mb/s; 48 Mb/s



    So I guess eth1 is my wireless adapter? It continues to list all of the other networks in range, one of which is my network that I want to connect to. (for now I will figure out how to connect to it through the terminal if that's possible)

    But I still do not have the wireless "blue bars" icon in my panel.

  4. #4
    Join Date
    Jan 2007
    Location
    Location: Location:
    Beans
    1,246
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    open a terminal and type

    nm-applet

    does that resolve it?

    if so,

    Add nm-applet to Startup Programs. You can find this in:
    Panel Menu > System > Preferences > Sessions

    Find the entry for Network Manager. If it is missing, add one. The entries are:

    Name: Network Manager
    Command: nm-applet --sm-disable
    Comment: Network Manager applet
    clear && echo paste url and press enter; read paste; (youtube-dl $paste) | zenity --progress --title="" --text "Downloading, please wait" --auto-close --pulsate && ans=$(zenity --file-selection); gnome-terminal -x mplayer "$ans"

  5. #5
    Join Date
    Apr 2006
    Location
    UK
    Beans
    6,646
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    Quote Originally Posted by BBBThunda View Post
    In addition, I forgot to mention before, but the network manager icon is there (looks like 2 little monitors), but in no way does this help me control wireless. I found a screenshot which shows both this NM icon and my missing wireless icon:
    The 2 little monitors are probably NM.

    The fact that they don't help connect to wifi does not necessarily mean it is not running.

    Post a screenshot of what it looks like when you left-click it.

  6. #6
    Join Date
    Mar 2009
    Location
    California (USA)
    Beans
    1

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    All you have to do to add your wireless "blue bars" icon is :

    Right click on the panel
    Then left click "Add to Panel"
    Scroll down to "Notification Area"
    Then left click "Notification Area"
    After that then left click "Add"
    It should bring back your wireless "blue bars" icon. It worked for me and I'm new to Ubuntu. If it doesn't instantly bring it up try restarting your computer. Good Luck and please share your experiences with our new friends and family using Ubuntu Linux!
    Last edited by mattsmatrix; March 16th, 2009 at 03:33 AM.

  7. #7
    Join Date
    Mar 2009
    Beans
    11

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    UPDATE:

    Ok, after the last post I made I gave up and switched back to Windows for a few days (mainly to test some web design stuff in explorer), and when I finally made it back to Ubuntu, I noticed the icon is back! And the icon is indeed part of the Notification Area, although I had already added that before my last post (see above).

    The NM icon (with the 2 monitors) is also still there and is NOT part of the Notification Area.

    Despite restarting a number of times while working on this last week, it still wasn't resolving the issue. But of course I don't know exactly what I did, so I don't have a specific solution for this issue.

    I doubt running nm-applet by itself solved the problem, since that kept hanging, and I know I did not manually add anything to my startup scripts.

    If anyone is interested in pursuing root cause further, let me know and I will be happy to provide more info. But from my end this is resolved.

  8. #8
    Join Date
    Jun 2005
    Location
    Portland, left
    Beans
    1,136
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    Quote Originally Posted by mattsmatrix View Post
    All you have to do to add your wireless "blue bars" icon is :

    Right click on the panel
    Then left click "Add to Panel"
    Scroll down to "Notification Area"
    Then left click "Notification Area"
    After that then left click "Add"
    It should bring back your wireless "blue bars" icon. It worked for me and I'm new to Ubuntu. If it doesn't instantly bring it up try restarting your computer. Good Luck and please share your experiences with our new friends and family using Ubuntu Linux!
    This installs the notification area which, on my Jaunty computer shows a Bluetooth icon and a Tracker icon as well. I want just the network icon. I can quit the other two, but the next time I log in they are back.

    Is there a way to remove unwanted parts of the notification area permanently? Or is there a different icon that will display available networks as a drop-down list?
    Linguistics on Linux!

  9. #9
    Join Date
    Jun 2007
    Beans
    3

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    Darn. I am having this problem. I'm sad to see it isn't resolved.

  10. #10
    Join Date
    Jun 2010
    Beans
    2

    Re: Accidentally removed wireless "blue bars" icon in Gnome. Hardy

    i am hafiz from pakistan and i have read all of your posts and i like all of it.thanks for sharing such type data.now i am here unintentionally.but next time i will be here for preparation and submit something different for all of you people kindly wait for me.i ,ll miss you all of you people.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •