Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Turned my screen off

  1. #1
    Join Date
    Jan 2008
    Beans
    264

    Turned my screen off

    I'm trying to help my friend to set up a lenovo x200 up with ubuntu. His screen resolution in Ubuntu was 1024*700, I was stupied enough to follow some post on ubuntu forums that said go to preferences>screen resolution un check mirror screens and set resolution to off. Now the result is that his ubuntu after shortly (1 sec) showing the brown screen has a black monitor. I dropped into recovery mode but I'm not geek enough to figure it out from the command prompt. How do I get back to the old resolution or does anybody know the x200 model and knows how to get into the 1200*800 mode.

    Thanks
    Andreas

  2. #2
    Join Date
    Apr 2008
    Beans
    61
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Turned my screen off


  3. #3
    Join Date
    Jan 2008
    Beans
    264

    Re: Turned my screen off

    Would the easiest way be to run

    sudo dpkg-reconfigure xserver-xorg

    in the recovery mode ?

  4. #4
    Join Date
    Apr 2008
    Beans
    61
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Turned my screen off

    Quote Originally Posted by Djalmahal View Post
    Would the easiest way be to run

    sudo dpkg-reconfigure xserver-xorg

    in the recovery mode ?
    just run "sudo gedit /etc/X11/xorg.conf"

    and add the file... xorg file is really easy to figure out...it keeps the same pattern for each option.

  5. #5
    Join Date
    Jan 2008
    Beans
    264

    Re: Turned my screen off

    Ok, the reconfigure command wasn't accepted it says "need and action option"
    and the gedit xorg..conf says
    GTK warning : cannot open display

    as I'm in recovery mode

    So, what's next??

    Thanks for any help
    Andreas

  6. #6
    Join Date
    Apr 2008
    Beans
    61
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Turned my screen off

    Quote Originally Posted by Djalmahal View Post
    Ok, the reconfigure command wasn't accepted it says "need and action option"
    and the gedit xorg..conf says
    GTK warning : cannot open display

    as I'm in recovery mode

    So, what's next??

    Thanks for any help
    Andreas
    then just change gedit to edit and that should fix it.

    Otherwise if you can get as far as the login screen, you can always try logging in with a terminal, which will then also have GUI support. I onetime had to go a week without x >.< elinks and irssi became my friends.

  7. #7
    Join Date
    Jan 2008
    Beans
    264

    Re: Turned my screen off

    Alright, I actually mispelled the reconfigure command, I ran it but it didn't go through screen resolution, it just reconfigured the keyboard.

    So, the screen is still black, I'm in recovery mode, the command line is all I have and I need to tell the system to go back to 1024*700 resolution

    Thanks for all your input

    Andreas

  8. #8
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Turned my screen off

    Would the easiest way be to run

    sudo dpkg-reconfigure xserver-xorg

    in the recovery mode ?
    This is more than likely what you need to repair your problem, running the above command wil create a default /etc/X11/xorg.conf and get you back to your desktop.

    I just read your post try:

    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    Jim
    Last edited by cariboo; March 12th, 2009 at 05:17 AM. Reason: to late

  9. #9
    Join Date
    Apr 2008
    Beans
    61
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Turned my screen off

    Quote Originally Posted by cariboo907 View Post
    This is more than likely what you need to repair your problem, running the above command wil create a default /etc/X11/xorg.conf and get you back to your desktop.

    Jim
    He just stated that the above command did not work though

    sudo edit /etc/X11/xorg.conf

    Find where it shows your display and where it says "none" which is what you set it to... replace that with 800X600 or whatever you need to display at

  10. #10
    Join Date
    Feb 2008
    Location
    Hamilton, Canada
    Beans
    Hidden!

    Re: Turned my screen off

    Give this a try

    Code:
    xrandr --output VGA --auto
    Replace VGA with the proper output... sometimes it's LVDS, or VGA-0... check what it is by running "xrandr" without any switches.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •