Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: How can I do an inverse search between okular and kile?

  1. #1
    Join Date
    Feb 2007
    Location
    Sweden
    Beans
    215

    How can I do an inverse search between okular and kile?

    How can I do an inverse search between okular and kile?
    Or alternatively how can I change my dvi viewer in kile from okular to Kdvi viewer?
    I use Ubuntu 10.04

  2. #2
    Join Date
    Jan 2009
    Location
    San Francisco, CA
    Beans
    213
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: How can I do an inverse search between okular and kile?

    Quote Originally Posted by ali780 View Post
    How can I do an inverse search between okular and kile?
    Or alternatively how can I change my dvi viewer in kile from okular to Kdvi viewer?
    To do inverse search in okular:
    Go to configure okular and change the editor from the default "Kate" to Kile. Shift-click to do inverse search, as supposed to control-click in KDvi.

    To make kdvi your default viewer in kile, go to configure kile --> tool --> build
    Replace "okular" with "kdvi" for dvi viewers.
    By the way, I would change the LaTeX command option to --src-specials -interaction=nonstopmode '%source' , so that it will do forward search right.
    There are two sides to every story: my side and the wrong side.

  3. #3
    Join Date
    Dec 2009
    Beans
    13

    Re: How can I do an inverse search between okular and kile?

    I have done all this and I still cannot get either forward or inverse search to work! I have a 2-button wheel mouse so the Kile manual's instruction to press the middle mouse button does not help... is it possible to reconfigure this somehow? (Pressing left and right mouse button's together doesn't work either)

    Or Plan B: Where can I get KDVI? The KDVI website says this is part of the kdegraphics package but it (no longer?) appears to be included...

    peter
    Last edited by ub-pir; December 31st, 2009 at 04:27 PM.

  4. #4
    Join Date
    Oct 2009
    Beans
    9

    Thumbs down Re: How can I do an inverse search between okular and kile?

    Hi,
    I just upgraded to Karmic, and experimented a bit with Kile and Okular. I got it working exactly like KDVI.
    lethalfang's instructions are mostly correct, however there are two more things.
    First you have to change the LaTeX build tools from Default to Modern (go to the build tool configuration menu and select Latex, then select Modern in the drop-down menu to the right).
    Secondly, you have to set up your viewer in the ForwardDVI tool, not the ViewDVI! I suspect the view tools do not forward the necessary info to the Viewer.
    Alternatively, you could create a new tool, but then make sure you select ForwardDVI for Class in the Advanced tab.
    At the moment it does not seem to work for PDFs though. I read in the German ubuntuusers-forum that this feature is oly available in TeXlive 2008, and Karmic still comes with 2007.

    Edit: actually I find Okular a bit unstable when used with forward search through Kile, so that I would recommend KDVI for now. (But otherwise Okular seems pretty stable.)

    Hope that helps,

    Chopstick
    Last edited by Khopstick; January 10th, 2010 at 11:09 PM.

  5. #5
    Join Date
    Jan 2010
    Location
    Madrid, Spain
    Beans
    1
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How can I do an inverse search between okular and kile?

    Thanks a lot for your help, Khopstick. I already have inverse search working in Okular. However, I am still fighting with one problem. Each time I do an inverse search, a new copy of my LaTeX source file opens in Kile. Have you met this problem?
    I have tried to change this behavior, in the Okular editor configuration, adding some --unique option, or something like that. But the editor command option seems to be fixed in Okular.
    Best regards.

  6. #6
    Join Date
    Jun 2008
    Beans
    23

    Re: How can I do an inverse search between okular and kile?

    I also have the problem that any time I do inverse search from okular (pressing shift+mouse) a new instance of Kile is run.

    Does anyone now how to fix this?

    Thanks!

  7. #7
    Join Date
    Jun 2008
    Beans
    23

    Re: How can I do an inverse search between okular and kile?

    I found a solution to my problem. In Okular go to Settings->Configure Okular->Editor.
    It doesn't allow you to edit the Command for kile, so instead choose Custom Text Editor and for the command write

    Code:
    kile %f --line %l
    After doing this, no new kile windows are opened, it just searches in the open source file. The search isn't very accurate though, it is usually off by a couple of lines. I think this is an okular issue.

  8. #8
    Join Date
    Jun 2008
    Beans
    23

    Re: How can I do an inverse search between okular and kile?

    My solution above fixed the inverse search, but forward search still opens a new instance of the dvi file.

    Does anyone know how to fix that?

    Thanks.

  9. #9
    Join Date
    Oct 2009
    Beans
    9

    Re: How can I do an inverse search between okular and kile?

    I don't have this problem, but I'm using KDVI at the moment... I'm assuming you use the ForwardDVI-Tool for forward search (and not ViewPDF). The --unique flag does not help?

  10. #10
    Join Date
    Jun 2008
    Beans
    17

    Re: How can I do an inverse search between okular and kile?

    Quote Originally Posted by sansegundo View Post
    Thanks a lot for your help, Khopstick. I already have inverse search working in Okular. However, I am still fighting with one problem. Each time I do an inverse search, a new copy of my LaTeX source file opens in Kile. Have you met this problem?
    I have tried to change this behavior, in the Okular editor configuration, adding some --unique option, or something like that. But the editor command option seems to be fixed in Okular.
    Best regards.
    I've had a similar problem. My souce is on a vfat (FAT32) hard disk. Somehow, probably a subversion confusion, I managed to get the folder name in the kile project file (.kilepr) in lower case, like the actual folder (as seen by ubuntu). Inverse search and clicking a latex error opened an upper case version, while the project opened a lower case version - I had the same file in 2 tabs!. 'Save as' revealed the discrepancy, and another inverse search didn't open a third tab.

    I solved it by manually changing the case of the folder name for all the files in the .kilepr file (which, by the way, I've had to put on ubuntu's home ext3 file system due to other bugs)

    Interestingly, the 'save as' dialog lists all the folders higher in the heirarchy in lower case, as they actually are. Only the last folder (which contains the source files) is listed upper case.

    Thanks noravanq - your tip finally got inverse search from okular working (:

    Now, I wonder whats up with forward search?? A new okular window every time. Doesn't jump to the correct page in the document.
    Last edited by drevicko; May 14th, 2010 at 07:10 AM. Reason: updated info

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •