Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 41

Thread: Installation crashes on the new early 2009 White Macbooks

  1. #11
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by cyberdork33 View Post
    These both sound similar to the MacBook5,1. I would check out that documentation.
    Thank you!
    I followed all the steps in this guide: https://help.ubuntu.com/community/MacBook5-1/Intrepid
    I was able to fix the sound, keyboard multimedia keys and enable some temperature and fan sensors.

    What still doesn't work:
    - Adjust screen brightness.
    - Show battery status. I tried resetting the SMC controller btw. Apparently Ubuntu thinks there is no battery present.
    - When I try to shut down or reboot, it stays On with a blank screen.

    I am still booting with the acpi=off line, otherwise it won't boot.

    UPDATE: Apparently the shut down and reboot issue is fixed by installing version 180 of the Nvidia graphics drivers. Will try later.
    Last edited by sistoviejo; March 9th, 2009 at 06:20 AM.
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  2. #12
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by sistoviejo View Post
    Thank you!
    I followed all the steps in this guide: https://help.ubuntu.com/community/MacBook5-1/Intrepid
    I was able to fix the sound, keyboard multimedia keys and enable some temperature and fan sensors.

    What still doesn't work:
    - Adjust screen brightness.
    - Show battery status. I tried resetting the SMC controller btw. Apparently Ubuntu thinks there is no battery present.
    - When I try to shut down or reboot, it stays On with a blank screen.

    I am still booting with the acpi=off line, otherwise it won't boot.

    UPDATE: Apparently the shut down and reboot issue is fixed by installing version 180 of the Nvidia graphics drivers. Will try later.
    The battery issue may be due to the fact that you boot with acpi=off. This is something that you should not be required to do. There should be a bug. Unfortunately, I don't think it will make it into Jaunty as I am pretty sure that the kernel will need patched.

  3. #13
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by cyberdork33 View Post
    The battery issue may be due to the fact that you boot with acpi=off. This is something that you should not be required to do. There should be a bug. Unfortunately, I don't think it will make it into Jaunty as I am pretty sure that the kernel will need patched.
    Should I file it on launchpad?
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  4. #14
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by sistoviejo View Post
    Should I file it on launchpad?
    you could file it upstream with the Linux kernel as an issue, but It can be tracked in the Ubuntu bugtracker as well (launchpad)

  5. #15
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by cyberdork33 View Post
    you could file it upstream with the Linux kernel as an issue, but It can be tracked in the Ubuntu bugtracker as well (launchpad)
    Thanks for all your help and support.
    Bug reported
    https://launchpad.net/ubuntu/+bug/341230
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  6. #16
    Join Date
    Apr 2006
    Beans
    6

    Re: Installation crashes on the new early 2009 White Macbooks

    hi,
    very nice thread.
    i also have a macbook white 5,2 - early 2009 - and i have the same issues.

    i got sound working for a while following instructions for 5,1 macbooks on the ubuntu wiki.

    i also think that ubuntu does not see properly my cpu: i cannot see two cores in /proc/cpuinfo or in gnome-system-monitor... can u verify on your system please?

    thanks

  7. #17
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by sturuko View Post
    i also think that ubuntu does not see properly my cpu: i cannot see two cores in /proc/cpuinfo or in gnome-system-monitor... can u verify on your system please?
    Mine also shows only one. This is very strange.
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  8. #18
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by sistoviejo View Post
    Mine also shows only one. This is very strange.
    that might also be due to disabling acpi.

  9. #19
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by bazzwaa View Post
    I had the same issue, I corrected it by re-installing mac os(I had successfully copied ubuntu image onto drive). I ran the firmware updates, then I used boot camp and reefit and got no errors with a freshly downloaded and burned copy of ubuntu(incase there was some sort of update that helped, this step may be completely unnecessary, but it seemed to help.)


    no longer does my ubuntu boot cd crash upon loading. The problem I believe is actually corrected under the efi update.

    anyways, hope this helps you.

    I have a macbook pro 5,1 aluminum uni-body.
    Sorry, I didn't see your message before.
    Just wanted to say that I updated my firmware last week, so that might not be the issue.
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  10. #20
    Join Date
    Apr 2006
    Beans
    6

    Re: Installation crashes on the new early 2009 White Macbooks

    other issuses:
    -grub&lilo does not work
    -grub-pc (v. 1.95, from intrepid or from jaunty debs) freezes if i try to change the boot kernel in the grub boot menù or if i hit any button on the keyboard
    -instead, it works fine with the svn-compiled version

    can someone confirm these things?

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •