Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Acer Aspire 6930 Headphones not working

  1. #11
    Join Date
    Jun 2005
    Ubuntu Development Release

    Re: Acer Aspire 6930 Headphones not working

    Quote Originally Posted by ashwindatye View Post
    Hi megamania,
    Did you upgeade to Karmic?
    I got my laptop on july and I installed Karmic Alpha on it, so I never got to try 9.04 on it and can't make comparisons.

    Karmic works ok. I had to replace Network Manager with Wicd because wifi didn't work on the alpha/beta versions - maybe it would work now that it has reached the final release.

    I didn't get the internal mic to work, but didn't spend too much time on it. The headphones work ok and so does the external mic. Skype works ok, too, in case you're wondering.

    After all, I don't see good reasons NOT to upgrade. I'm using the 64-bit version, by the way.

    Slightly off-thread - Did you get the fingerprint reader to work? I'd like to try it just for the fun of it, but don't want to go crazy...

    EDIT: Just did a quick search and found that apparently the internal mic issue will be fixed with the new alsa drivers (1.0.21). There's a guide to install them here (unfortunately it's in italian):,316183.0.html
    Last edited by megamania; November 1st, 2009 at 01:59 PM.

  2. #12
    Join Date
    Aug 2007
    Pune, India
    Ubuntu 10.10 Maverick Meerkat

    Re: Acer Aspire 6930 Headphones not working

    Hello Megamania,
    Nice to know that they are going to fix the int mic prob in the new alsa release. I will check that link out.
    finger print-> my model's got no firgerprint reader.
    I will mst probably upgrade soon. Right now i am on tour and dnt want to risk my tons of photos i downloaded from my camera. first a back up t my ext harddrive a home then the upgrade.
    Thank you for your comments.

  3. #13
    Join Date
    Feb 2009
    Austin, Texas

    Re: Acer Aspire 6930 Headphones not working

    Quote Originally Posted by davidryderuk View Post

    1. Open terminal in Applications>Accessories>Terminal

    2. Edit the the file at /etc/modprobe.d/alsa-base in a text editor
    gksudo gedit /etc/modprobe.d/alsa-base
    3. Add the following line to the end of the file and save
    options snd-hda-intel model=auto
    4. Now try rebooting your machine to see if the headphones work. If this makes the sound any worse, repeat the above steps, this time removing the line you added the first time.

    Please note i have not tried this with my own machine but post number #33 in the link below says it should work.

    There is also another page in the link shown below about compatability of this laptop with linux that you might want to read.
    Worked like a charm for me...thanks!

  4. #14
    Join Date
    Feb 2011

    Re: Acer Aspire 6930 Headphones not working

    David, the solution you provided works perfectly! Thank you!
    What does this command really do?

Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts