Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: HP/AtherosWireless/Ubuntu 8.10/Can't Connect After Update

  1. #11
    Join Date
    May 2007
    Beans
    33

    Re: HP/AtherosWireless/Ubuntu 8.10/Can't Connect After Update

    Okay, this is what pops up when I type ifconfig:

    eth0 Link encap:Ethernet HWaddr 00:1e:68:89:9d:79
    inet addr:192.168.0.102 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::21e:68ff:fe89:9d79/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:890 errors:0 dropped:145771887 overruns:0 frame:0
    TX packets:596 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:635889 (635.8 KB) TX bytes:100349 (100.3 KB)
    Interrupt:252

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 B) TX bytes:100 (100.0 B)

    I did the sudo modprobe -r athXXX commands. And then sudo modprobe ath5k again. But nothing seemed to have changed in the output of ifconfig.

    This is the output of dmesg | grep ath5k:

    srestroncio@lucifer:~$ dmesg | grep ath5k
    [ 17.492619] ath5k 0000:08:00.0: enabling device (0000 -> 0002)
    [ 17.492642] ath5k 0000:08:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 17.492669] ath5k 0000:08:00.0: setting latency timer to 64
    [ 17.492741] ath5k 0000:08:00.0: registered as 'phy0'
    [ 17.504549] ath5k phy0: failed to wakeup the MAC Chip
    [ 17.504549] ath5k 0000:08:00.0: PCI INT A disabled
    [ 17.504549] ath5k: probe of 0000:08:00.0 failed with error -5
    [ 338.708083] ath5k 0000:08:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 338.708115] ath5k 0000:08:00.0: setting latency timer to 64
    [ 338.708194] ath5k 0000:08:00.0: registered as 'phy0'
    [ 338.720045] ath5k phy0: failed to wakeup the MAC Chip
    [ 338.720045] ath5k 0000:08:00.0: PCI INT A disabled
    [ 338.720045] ath5k: probe of 0000:08:00.0 failed with error -5

    Also, Life on Mars, how do I revert the the update?

  2. #12
    Join Date
    Feb 2009
    Beans
    18

    Re: HP/AtherosWireless/Ubuntu 8.10/Can't Connect After Update

    Quote Originally Posted by smani View Post
    Did you ever search whether a driver is actually loaded for your wifi card? Specifically, look at the output of
    Code:
    sudo lshw
    and look if it says UNCLAIMED in the section concerning the wifi card.
    If so, you might want to try and load the module
    Code:
    sudo modprobe ath5k
    #or
    sudo modprobe ath9k
    Look at http://madwifi-project.org/ for more informations on the drivers and supported cards.
    If you notice that the module is not automatically loaded at startup, you can add the module name to /etc/modules.
    I got with ath5k FATAL and something and as for the rest they didn´t do anything. I posted my problem here as well for more information. If you would like, I would tell it in this post too to make it more manageble but in short I can´t get it working either.
    Last edited by Simyager; March 1st, 2009 at 01:48 PM. Reason: put the ubuntuforum in here and spelling

  3. #13
    Join Date
    Feb 2009
    Beans
    18

    Re: HP/AtherosWireless/Ubuntu 8.10/Can't Connect After Update

    Quote Originally Posted by Reiger View Post
    In order to see if your device is properly recognized, you should look at the output of:
    Code:
    ifconfig
    That should list your wireless device.

    Now if it doesn't do so at the modprobe ath5k command, try ensuring that nothing interferes:
    Code:
    sudo modprobe -r ath5k
    sudo modprobe -r ath9k
    sudo modprobe -r ath_pci
    Then load it again & check output:
    Code:
    sudo modprobe ath5k
    ifconfig
    And if it still won't work it is time to collect log messages from the kernel about your driver:
    Code:
    dmesg | grep ath5k
    I did this as well and nothing happend. It was like I didn´t input anything, I could see what I entered but it didn´t do anything.

  4. #14
    Join Date
    Nov 2006
    Location
    London
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HP/AtherosWireless/Ubuntu 8.10/Can't Connect After Update

    Quote Originally Posted by SrEstroncio View Post
    ...

    Also, Life on Mars, how do I revert the the update?
    When you reboot your PC you should get the option to choose which kernel you boot into - if you don't do anything it defaults to the latest one.

    Here's an example of the screen (not mine):



    If that works for you, you can, temporarily at least, edit the grub menu so that your default start up kernel is the one that works with your wireless card.

  5. #15
    Join Date
    Feb 2009
    Beans
    18

    Angry Re: HP/AtherosWireless/Ubuntu 8.10/Can't Connect After Update

    Unfortunatly I installed oly 8.10 Ubuntu so that trick won´t work for me. But can anyone help me with my internet problem?

    I can only connect to the internet via wifi so please help me

  6. #16
    Join Date
    Nov 2006
    Location
    London
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HP/AtherosWireless/Ubuntu 8.10/Can't Connect After Update

    Now I found what it is I used to get my wife's wireless working. Have you tried these instructions?

    How To Get Atheros AR242x To Work on 8.10 Intrepid Ibex

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •