Results 1 to 3 of 3

Thread: VisualBoyAdvance tip

  1. #1
    Join Date
    Dec 2005
    Location
    United States
    Beans
    18
    Distro
    Ubuntu Breezy 5.10

    Cool VisualBoyAdvance tip

    I downloaded VisualBoyAdvance with synaptic package manager, and the emulator worked fine (I love it when that happens 8)). But there was a problem on exit 'error writing .sav file.' I tried a few things and theres was no problem with permissions of the roms folder.

    Here's how I fixed it. In the file /etc/VisualBoyAdvance.cfg where it says batteryDir= and has nothing, that is supposed to imply save the .sav files in the same directory as the rom. Since this didn't work, AND since the installation put an empty and un-used folder in my home directory /home/evan/.vba, i decided to put that in the /etc/VisualBoyAdvance.cfg config file. Note that you'll need to use sudo to write to that file.

    sudo gedit /etc/VisualBoyAdvance.cfg

    Code:
    batteryDir=/home/yourname/.vba
    where yourname is your user name.

    you might want to set the other directory variables to that directory too, like for save state and capture.

    Why isn't the ~/.vba folder in the config file by default?
    Why won't the save to rom folder default behavior work?
    Bah!! This is the kind of simple thing that windows lovers love to hate about linux! Or maybe I just installed a weird package and no one else but me had this problem.

    Hope this helps!!!
    barfos

  2. #2
    Join Date
    Mar 2005
    Beans
    38

    Re: VisualBoyAdvance tip

    Good call, I was wondering how to get this to work...

    Thanks.

  3. #3
    Join Date
    Jan 2005
    Beans
    3

    Re: VisualBoyAdvance tip

    I've been having issues with this thing - I can't open files. When I try to, I get a memory dump and it dies completely. Can anyone advise me as to what it's doing wrong, and what needs to be added or changed?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •