Results 1 to 4 of 4

Thread: 8.10 WLAN Problem solved iwl3945

  1. #1
    Join Date
    Feb 2009
    Beans
    2

    8.10 WLAN Problem solved iwl3945

    Hi,

    I was able to finally connect my thinkpad r61 iwl3945 (kernel 2.6.27-11) to my WLAN AP
    after I changed the channel on tha AP from 13 to 1.

    iwconfig does not allow setting channel 13.


    I had no problems with kernel 2.6.27-7.

  2. #2
    Join Date
    Jul 2007
    Location
    Atlanta, GA
    Beans
    660
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 8.10 WLAN Problem solved iwl3945

    Hi Dave,

    Unless you are in Europe or Asia, channels 12 and 13 are not usable.

    Glad you got it working!

    Cheers!

  3. #3
    Join Date
    Feb 2009
    Beans
    2

    Re: 8.10 WLAN Problem solved iwl3945

    But how can I set the card to Europe?

  4. #4
    Join Date
    Jul 2007
    Location
    Atlanta, GA
    Beans
    660
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 8.10 WLAN Problem solved iwl3945

    There is a bug report filed here that describes the same problem. A couple of users found a workaround.

    Same problem for me in Germany. I could not connect to a given network on channel 12.

    The solution I found:
    Add the following line :
    options cfg80211 ieee80211_regdom="EU"
    in
    /etc/modprobe.d/options
    As every file in /modprobe.d is read, it should be possible to put that line in a new file.
    Just if somebody is wondering about how to use the workaround with the backported modules: Use this line:
    modprobe lbm_cw_cfg80211 ieee80211_regdom=JP
    (or EU instead of JP)
    You can install the backports using the linux-backports-modules-intrepid package.
    Cheers!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •