Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: Ubuntu 8.10 and ZTE USB MF636

  1. #21
    Join Date
    Jun 2007
    Beans
    4

    Talking Re: Ubuntu 8.10 and ZTE USB MF636

    Quote Originally Posted by wridley View Post
    Hi, I have a Rogers USB wireless stick. I am able to connect and get an IP address but am unable to do anything after that.
    ...

    --> Modem initialized.
    --> Sending: ATDT*99***1#
    --> Waiting for carrier.
    ATDT*99***1#
    CONNECT
    --> Carrier detected. Starting PPP immediately.
    --> Starting pppd at Tue Feb 10 10:23:19 2009
    --> Pid of pppd: 6195
    --> Using interface ppp0
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> local IP address 172.28.1.186
    --> pppd: ����[10]
    --> remote IP address 10.64.64.64
    --> pppd: ����[10]
    --> primary DNS address 207.181.101.4
    --> pppd: ����[10]
    --> secondary DNS address 207.181.101.5
    --> pppd: ����[10]
    --------------------------------------------------

    Any help would be appreciated.

    Thanks

    I had same problem as yours with a MF632 Portuguese provider so i used the tip from this Brazilian guy in launchpad: https://bugs.launchpad.net/ubuntu/in...fo/+bug/305968

    pay attention to post #17 with the changes to the /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi in particular of lines 3 and 16.
    Code:
    sudo gedit /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi
    
    do the change
    
          <match <email address hidden>:usb.vendor_id" int="0x19d2">
            <!-- Qualcomm: Telstra/NextG CDMA , ZTE CDMA Tech -->
            <match <email address hidden>:usb.product_id" int="0xfffe">
              <match <email address hidden>:usb.interface.number" int="0">
                <append key="modem.command_sets" type="strlist">IS-707-A</append>
              </match>
            </match>
            <!-- ZTE MF628 HSDPA USB dongle -->
            <match <email address hidden>:usb.product_id" int="0x0015">
              <match <email address hidden>:usb.interface.number" int="3">
                <append key="modem.command_sets" type="strlist">GSM-07.07</append>
                <append key="modem.command_sets" type="strlist">GSM-07.05</append>
              </match>
            </match>
            <!-- ONDA MF632 HSDPA USB dongle -->
            <match <email address hidden>:usb.product_id" int_outof="0x0001;0x0002">
              <match <email address hidden>:usb.interface.number" int="2">
                <append key="modem.command_sets" type="strlist">GSM-07.07</append>
                <append key="modem.command_sets" type="strlist">GSM-07.05</append>
              </match>
            </match>
          </match>
    
    sudo rm /var/cache/hald/fdi-cache
    sudo reboot
    I'm now able to surf the web anywhere

    Good luck

    PS:
    If this doesn't fix your problem then read the whole thread as that guy also posts code to apply to all ONDA models

  2. #22
    Join Date
    Nov 2007
    Location
    Perth, WA, Australia
    Beans
    12
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Ubuntu 8.10 and ZTE USB MF636

    Just thought I'd add my outcome with the MF636 USB on Telstra Bigpond 3G.

    First of all if you are using 8.10 this will pretty much work out of the box. I attempted to use this forum topic but found that I actually just had to do the following;

    1. On a windows machine, install the USB 3G driver, set up a username and password, and enable the Telstra Bigpond account.
    2. Obtain the com port using the Device Manager (right click on My Computer).
    3. Using hyperterminal (on WinXP Pro Start->Programs->Accessories->Communications(?)->Hyper Terminal) connect to the modem using the following settings;
      Code:
      115200 - Bits per second
      8 - Data bits
      None - Parity
      1 - Stop bits
      None - Flow Control
      and use the com port you grabbed from the previous step.
    4. Past the following into the hyper terminal (it will not show up when you paste it in, just hit enter and you will see output);
      Code:
      AT+ZCDRUN=8
    5. Plug the USB modem into your Ubuntu machine. Network Manager will pick it up and launch a connection wizard. Run it and select the "Telstra" option.
    6. Get Ubuntu to successfully detect the 3G USB card by editing the following file;
      # sudo gedit /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi

      Search for the line <!-- ZTE MF628 HSDPA USB dongle --> and change the next line below it from;

      <match key="@info.parent:usb.product_id" int="0x0015">
      to
      <match key="@info.parent:usb.product_id" int="0x0031">

      Then restart your computer (there is probably a way to do this without restarting your computer, it's just that I don't know how to do it).
    7. Right click on the Network Manager icon and select Edit Connections. Select the Mobile Broadbands tab.
    8. Edit the "Telstra" entry and enter your username and password. Also change the APN to "telstra.bigpond".
    9. Try connecting. This worked for me.


    Good luck.
    Last edited by spauldingsmails; April 15th, 2009 at 05:09 AM.

  3. #23
    Join Date
    Apr 2009
    Beans
    6
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Ubuntu 8.10 and ZTE USB MF636

    Hello there,

    I found this thread helpful as it solved my problem similar to the discussion here. To summarize mine initially my lsusb for my modem is 19d2:2000. After adding the extra init AT+ZCDRUN=8 in windows/modem dialing properties lsusb is now 19d2:0015. I modprobe it and wvdialconf was able to detect the modem:

    [Dialer xxx]
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    Init3 = AT+CGDCONT=1,"IP","Web2"
    Modem Type = Analog Modem
    Baud = 3600000
    New PPPD = yes
    Modem = /dev/ttyUSB0
    ISDN = 0
    Phone = *99#
    Username = xxx
    Password = xxx
    Stupid Mode = 1

    Now I can go online thank you for this thread. But my speed is very slow average 5 kb/s. During wvdialconf detection it gave a baud rate of 9600 which is more or less the actual speed i get. The baud rate i used above is based on the windows settings. Is there a way to improve my modem speed? Below you said

    NOTE: If you want to restore original mode you have to send AT+ZCDRUN=9

    I presume this is in windows side because after adding the extra command i ran the modem but it cant connect (in windows) it gave an error "modem/hardware problem or something".

    My current speed is no different than dialup and i want to know how to improve this. If i reset the modem and return to linux im thinking it will reset to the old setting 19d2:2000. I appreciate your input.

    bibs



    Quote Originally Posted by GeorgeVita View Post
    Hi Cheyenne, as the lsusb command gives:



    You have to:



    The simplest is to use a PC running windows, add an extra init command (through control panel, modem & dialling properties) the AT+ZCDRUN=8, try to connect once (ignore the error message) and remove this extra command (through control panel). Then in Ubuntu command lsusb will see 19d2:0031, you have to follow steps 3-5 (Ubuntu 8.10).
    NOTE: If you want to restore original mode you have to send AT+ZCDRUN=9

    G

  4. #24
    Join Date
    Aug 2008
    Location
    Athens Greece
    Beans
    971
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 8.10 and ZTE USB MF636

    Hi bibimidi,
    Quote Originally Posted by bibimidi View Post
    ...Below you said
    NOTE: If you want to restore original mode you have to send AT+ZCDRUN=9
    This is a "restore" for windows only use, in case you cannot install this modem to another windows pc. After this you will be at the start (19d2:2000).

    The extra command makes the provider's application program to see an unexpected (error) reply and cannot connect. So we remove it as we done our job but we need the connection via the windows pc.

    About the actual connection speed the only you can do is wait for the 3G signal to stabilize (blue led) and then connect. Ask also your provider or cross check with the windows pc. Check also if you can "set" the modem to 3G only from the windows application program. till now I don't know any AT command to use for this.

    Regards,
    George

  5. #25
    Join Date
    May 2009
    Beans
    2

    Re: Ubuntu 8.10 and ZTE USB MF636

    Same problem to me too.

  6. #26
    Join Date
    Jun 2009
    Beans
    2

    Re: Ubuntu 8.10 and ZTE USB MF636

    I have been using Rogers ZTE modem on an Aspire One running Ubuntu Jaunty for about a month -- thanks to advice on this thread. Unfortunately I am still having some problems. Sometimes, when I try to connect to Rogers AT&T, I am asked for a password. Nothing I supply seems to work and I don't get connected. At other times, no password is requested and the gadget connects to the internet. A password is mentioned under "properties" for the connection, so in princinple, the ZTE should know what its password is.

    There seems to be some connection between the keyring for the wireless and this problem. We have wireless in the house. If I log on to that wireless first, disconnect, and then try the ZTE, it usually works. Trouble happens when I try the ZTE first.

    In any case, the problem appears to be sporadic. Sometimes I can connect; at other times not. I should mention that at all times I am trying to connect within an urban area that has good Rogers cellphone coverage.

    Thanks.

  7. #27
    Join Date
    Jun 2009
    Beans
    4

    Re: Ubuntu 8.10 and ZTE USB MF636

    Quote Originally Posted by CJCollins View Post
    I have been using Rogers ZTE modem on an Aspire One running Ubuntu Jaunty for about a month -- thanks to advice on this thread. Unfortunately I am still having some problems. Sometimes, when I try to connect to Rogers AT&T, I am asked for a password. Nothing I supply seems to work and I don't get connected. At other times, no password is requested and the gadget connects to the internet. A password is mentioned under "properties" for the connection, so in princinple, the ZTE should know what its password is.

    There seems to be some connection between the keyring for the wireless and this problem. We have wireless in the house. If I log on to that wireless first, disconnect, and then try the ZTE, it usually works. Trouble happens when I try the ZTE first.

    In any case, the problem appears to be sporadic. Sometimes I can connect; at other times not. I should mention that at all times I am trying to connect within an urban area that has good Rogers cellphone coverage.

    Thanks.
    I had same connection problems. I am using ubuntu 9.04 I did a couple things that may have helped.

    1. Edit connections - edit your provider shown (mine is rogers AT&T) and at the botom put check mark in - available to all users

    2. Also for the keyring I enabled - always remember for rogers

  8. #28
    Join Date
    Jun 2009
    Beans
    2

    Re: Ubuntu 8.10 and ZTE USB MF636

    Thanks. I solved my problem by removing the keyring passwords altogether. If I put the keyring back, I will try to do what you did and enable for Rogers.

  9. #29
    Join Date
    Jul 2005
    Location
    London,England
    Beans
    1,022
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Ubuntu 8.10 and ZTE USB MF636

    i googled this thread expecting problems, and it turns out the the 3 MF627 actually has linux drivers and software on the drive part, (though the software is qt3 so kindof ugly) but it works!.
    Jeremy Clarkson - "A Dazzling Hero of Political Incorrectness"
    My LastFM profile
    want to Give each GTK program its own theme? well look Here

  10. #30
    Join Date
    Jan 2008
    Beans
    5

    Re: Ubuntu 8.10 and ZTE USB MF636

    i got mine working on UK 3

Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •