Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How to disable rebuilding Xapian index?

  1. #1
    Join Date
    Sep 2007
    Location
    Riga, Latvia
    Beans
    324
    Distro
    Xubuntu 9.10 Karmic Koala

    Exclamation How to disable rebuilding Xapian index?

    Hello! My PC everyday hangs terribly, and the command "top" in terminal shows that the process "update-apt-xapi" is loading my RAM and CPU on 100%. Running "sudo update-apt-xapian-index" shows the percentage of completion of rebuilding Xapian Index, and those minutes are rather ... disturbing, especially when I am typing my BA paper Google did not help much...Since there is no such package, i can not remove it. Please, can somebody tell me what should I do? I have not experienced it in the previous *buntu versions, only in Intrepid...

  2. #2
    Join Date
    Feb 2009
    Beans
    5

    Re: How to disable rebuilding Xapian index?

    the process is update-apt-xapian-index and in low resource systems it will eat all available ram and then start swapping, leaving the system almost in a freeze state.

    do a
    PHP Code:
    sudo apt-get autoremove --purge apt-xapian-index
    sudo apt
    -get autoremove --purge 
    this will remove apt-xapian-index and then python-debian and python-xapian

    i don't know if it has secondary effects, but it will avoid this anoying process (in low resource systems) to start again

  3. #3
    Join Date
    Sep 2007
    Location
    Riga, Latvia
    Beans
    324
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: How to disable rebuilding Xapian index?

    compat, thank you very much!!!!! When I am at home, I'll do it and find out about side effects!

  4. #4
    Join Date
    Jan 2009
    Beans
    213
    Distro
    Ubuntu 12.04 Precise Pangolin

    Talking Re: How to disable rebuilding Xapian index?

    I did this on my old laptop running 8.10, no negative results so far...

    Thanks for saving me tons of resources!

  5. #5
    Join Date
    Feb 2009
    Beans
    5

    Re: How to disable rebuilding Xapian index?

    hello, i've seen that it is installed when installing other apps, at least in jaunty, i ended renaming the process,
    moved update-apt-xapian-index process to update-apt-xapian-index.disabled in /usr/sbin/ folder

  6. #6
    Join Date
    Apr 2009
    Beans
    2

    Re: How to disable rebuilding Xapian index?

    Here is what I did to disable it:
    Code:
    sudo chmod 644 /etc/cron.weekly/apt-xapian-index
    It makes the file not executable.

  7. #7
    Join Date
    Dec 2006
    Location
    N. Virginia, USA
    Beans
    505
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: How to disable rebuilding Xapian index?

    Purging apt-xapian-index caused the quick search feature in Synaptic to become inoperative in Jaunty. Changing the weekly script to non-executable proved the better approach with no side effect so far.
    Linux User #448337
    Gigabyte EP45-UD3L MB, Q9650 Core 2 Quad @ 3.3 GHz (OC), 8 GB OCZ Platinum DDR2 SDRAM, EVGA GeForce 8800 GTS w/640MB, 40 GB Intel SSD, 2.0 TB x2 SATA RAID1, Ubuntu 17.04 x86_64

  8. #8
    Join Date
    Jul 2007
    Location
    Amarillo, Texas, USA
    Beans
    149
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: How to disable rebuilding Xapian index?

    My old PIII laptop thanks you for this!

    ^____^
    I see that there is evil, and I know that there is good, and the in-betweens I've never understood...

  9. #9
    Join Date
    Jan 2008
    Location
    Between SJI & Bellevue WA
    Beans
    783
    Distro
    Ubuntu 10.04 Lucid Lynx

    Lightbulb Re: How to disable rebuilding Xapian index?

    I was bitten by this bug as well, and after some digging around, I found the thread on Launchpad discussing the official fix that will be incorporated into Ubuntu at some point. Read this post I wrote in another thread for an explanation of how to implement the official fix in your system now, and a breakdown of what it does.

    Cheers,

    --Eiríkr

  10. #10
    Join Date
    Mar 2009
    Beans
    8

    Re: How to disable rebuilding Xapian index?

    hello if you do not wish to disable it but to make it consume less cpu, you should do like me:
    edit /etc/cron.weekly/apt-xapian-index (for example with vi or gedit)
    replace the line
    nice $IONICE -c3 $CMD --quiet
    by
    nice -n 19 $IONICE -c3 $CMD --update --quiet

    what it does:
    a) run it with the lowest system priority
    b) update the db and not built it again -> faster

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •