I'm pretty new to ubuntu, just installed 8.10 a couple days ago, and had RhythmBox playing my music just fine. Today, it stopped working. I run it, double click on one of the songs in the Browser, and it updates the information as though it's trying to play the song, but it just sits there. The play button is pressed, but no sound is coming out, and the tracker is not advancing. I press the play button again and it informs me that the song has now been paused. I press again, and it goes back to not playing.
To complicate things, when I double click an ogg, it opens with Totem video player, which also seems to exhibit the same issue.
I tried running it from the terminal to see if it was outputting any errors, but it wasn't - the terminal remained blank.

On a possibly related note, flash videos in my browser have also stopped working (but they worked before). They'll play the first second, at best, and then stop in the same fashion as the music does - no indication of it being paused or anything, but the video does not advance and sound doesn't come out.

This is very discouraging. Hopefully you guys can help out.