Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: KDE4 Phonon and PulseAudio

  1. #21
    Join Date
    Sep 2008
    Beans
    7

    Re: KDE4 Phonon and PulseAudio

    Thanks for answering, Markbuntu

    I didn't have pulseaudio volume control, so I installed it and changed all multimedia devices to PulseAudio and it seems to work, although kopete is not making any sound nor gmail's chat... it seems that some aplications work but others aren't.

    What's the problem with PulseAudio? (I know, I read your post, but didn't understand what the problem is) I've found too many people having problems and the official solution seems to be to uninstall it and install alsa...

    PS: by the way, if you click in one of the images a bigger view is displayed.

    Edit: it seems that it worked now. I forgot to put pulseaudio as default for all multimedia tabs, not only "music"
    Last edited by srbaldomero; May 22nd, 2009 at 05:04 PM. Reason: adding more data

  2. #22
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: KDE4 Phonon and PulseAudio

    The problem is not so much pulseaudio but its faulty implementation in Ubuntu. I still cannot understand why in Ubuntu the pulseaudio daemon starts by default but the sound scheme is not set up for pulseaudio to actually control all the applications and the pulseaudio volume control is not installed so users can control their sound.

    It is really crazy and it has been going on since hardy and it looks like it will continue with koala. The really crazy thing is that fixing it is sooo simple, a few packages, a few minor changes in configs.

    Users of other distributions do not have anywhere near so much trouble with pulseaudio as Ubuntu users. Fedora and Mandriva adopted pulseaudio and have consolidated sound control to pulseaudio a long time ago.
    PMs will be ignored.

  3. #23
    Join Date
    Jan 2009
    Beans
    11

    Re: KDE4 Phonon and PulseAudio

    Regression since Jaunty, Phonon doesn't map PulseAudio devices to "physical" devices anymore..: https://bugs.launchpad.net/ubuntu/+s...on/+bug/382141

    Does this affect everyone or just me ?


    Besides just an update to my old posts: there's no need for autostart or .kde/env script anymore since Jaunty, Phonon automatically starts pulseaudio if installed.
    Last edited by Syniurge; June 22nd, 2009 at 07:42 AM.

  4. #24
    Join Date
    Jun 2005
    Location
    Coimbatore, India
    Beans
    182
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: KDE4 Phonon and PulseAudio

    This might be a bit off-topic, but on my system running Kubuntu Jaunty on an AMD 64 installing pulseaudio is incompatible with a functional Skype from medibuntu.

    It appears that the standard options on kmixer do not allow the input sources and microphones to be displayed. Once these are selected, and activated, Skype works without hassles.

    My thanks to everyone, especially, Markbuntu, for this thread.

  5. #25
    Join Date
    Jul 2009
    Location
    Brodnax VA.
    Beans
    26
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: KDE4 Phonon and PulseAudio

    Quote Originally Posted by markbuntu View Post
    Well thanks for that. I have not delved into KDE4.2 yet but I expect to be doing so soon. Then I will include specific instructions for KDE4.2.
    I followed the instructions, my sound flat out quit with Kubuntu Karmic. I finally removed pulseaudio completely, re-installed alsa and my sound works just fine. The degree of complexity is un-called for, when newbies are called to hand edit conf files. Anything that gets between me and my space games is under the bus!

  6. #26
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: KDE4 Phonon and PulseAudio

    Quote Originally Posted by wayward4now View Post
    I followed the instructions, my sound flat out quit with Kubuntu Karmic. I finally removed pulseaudio completely, re-installed alsa and my sound works just fine. The degree of complexity is un-called for, when newbies are called to hand edit conf files. Anything that gets between me and my space games is under the bus!
    "If you are not using KDE4 on Intrepid 8.10 or Jaunty 9.04 do not attempt this."

    That is the first sentence in the OP.

    There are a lot of changes in the sound scheme with karmic, both with KDE/phonon and with pulseaudio.

    I would be surprised if it did work.
    PMs will be ignored.

  7. #27
    Join Date
    Jul 2009
    Location
    Brodnax VA.
    Beans
    26
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: KDE4 Phonon and PulseAudio

    Quote Originally Posted by markbuntu View Post
    "If you are not using KDE4 on Intrepid 8.10 or Jaunty 9.04 do not attempt this."

    That is the first sentence in the OP.

    There are a lot of changes in the sound scheme with karmic, both with KDE/phonon and with pulseaudio.

    I would be surprised if it did work.
    I did read that, but thought you were referring to KDE3 and/or Hardy version or lower. So, what will it take to play nice with KDE4 and Gnome both installed in Karmic?? Please note I tried diligently to enable pulse. Again, it really needs to work out of the box for general acceptance. I have friends running other distros who tell me it works a charm. So, I did give it a try. Ric

  8. #28
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: KDE4 Phonon and PulseAudio

    I have not gotten into karmic yet so I cannot say but I will be doing so soon and write something up when I figure it out. Probably sometime in the next few weeks.
    PMs will be ignored.

  9. #29
    Join Date
    Apr 2008
    Beans
    5

    Re: KDE4 Phonon and PulseAudio

    I followed the instruction from http://idyllictux.wordpress.com/2009...eaudio-at-bay/

    But it did not work to get skype to listen to my mic. So, I turned off pulseaudio as mentioned at the beggining of this post (I did not read the whole thing ), and now it works.

    I know pulseaudio is the future, but I was happy with simple Alsa when using Hardy (now I moved to Jaunty). I'll probably try to migrate to pulseaudio next time I upgrade the distro, and hopefully it will be seemless by them.

    Also, digital out (spdif) was an issue with pulseaudio for my Nvidia audio card (Mobo Asus M2N-SLI Deluxe)

  10. #30
    Join Date
    Apr 2009
    Beans
    7
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: KDE4 Phonon and PulseAudio

    Quote Originally Posted by Syniurge View Post
    markbuntu's post was for KDE 4.1.
    As of KDE 4.2 (available in the backports), the only thing needed to get PulseAudio working within KDE is making "pulse-session" run before KDE launches using the following command in a terminal:
    Code:
    cp /usr/bin/pulse-session ~/.kde/env/pulse-session.sh
    Then after restarting KDE, Phonon devices(not just the "PulseAudio" device) will map to PulseAudio devices instead of ALSA devices.
    On fresh installation of kubuntu, and after updating and installing kde 4.3.1 i installed skype and it was working perfectly. Then i installed kubuntu restricted extras and pulse audio appeared at sound settings. At skype sound settings i had no option to choose sound devices cause pulseaudio was the only option. I updated pulseaudio and run tht command you give and everything is working nicely again. Thx to all.


Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •