Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Finally I installed the nVidia driver in Ubuntu

  1. #11
    Join Date
    Dec 2007
    Location
    Ontario / Canada
    Beans
    4
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Finally I installed the nVidia driver in Ubuntu

    All,

    I performed all of the steps above, but after X came up, I was stuck in low resolution mode again. And again, I was unable to access the System Menu, etc. So I looked at the xorg-conf file, noticed it was lacking in any entries for resolution, so I was puzzled. After some more fidgeting, powered down the system and gave up. Next day, I groaned as I was still faced with the specter or re-visiting this issue. But the login screen came up in higher resolution and so did my desktop! I run at 1900x1200 on a 24" Samsung, so I was happy again. I can't explain why a warm boot differs from a cold boot with respect to a seemingly static xorg.conf file.

    Apparently I have more to learn just who is it that seems to control that file.

    But, I was wrong above in respect to the Visual Effects. They remain unfixed and all along, it was my thinking that the restricted drivers were not permitting Visual Effects to run properly.

    That assumption seems to be wrong.

    I've installed all of compiz packages and other dependencies with no luck. So, I've been searching for more entries to go into the xorg.conf file that allegedly make compiz work.

  2. #12
    Join Date
    Dec 2007
    Location
    Ontario / Canada
    Beans
    4
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Finally I installed the nVidia driver in Ubuntu

    Walshy11,

    I'll send you my xorg.conf file, but will have to do that tonight as I'm at work and don't have remote access capability from here.

    Even though you're running low resolution, you still have the ability to run a terminal.

    When you received it my file, I suggest you do the following:

    1. Make a backup of your existing /etc/X11/xorg.conf file.
    2. Create a new /etc/X11/xorg.conf file from what I send you.
    3. Power down your system and restart, hopefully it will work.

    I'm guessing that you have an incompatible xorg.conf file.

  3. #13
    Join Date
    Dec 2007
    Location
    Ontario / Canada
    Beans
    4
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Finally I installed the nVidia driver in Ubuntu

    All,

    Here's my /etc/X11/xorg.conf file from a fresh nVidia driver install. This hopefully gets you out of being stuck in low resolution more. Please note however that I still don't have visual effects running.

    --------------------------
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder26) Thu Dec 13 18:55:42 PST 2007


    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    RgbPath "/usr/lib/X11/rgb"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection
    --------------------------

  4. #14
    Join Date
    Sep 2005
    Location
    California & Tokyo, Japan
    Beans
    71
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Finally I installed the nVidia driver in Ubuntu

    Weird that you would need to do all of that.

    All I did was disable the current nvidia "restricted driver," restart X to make sure it was off, then shutdown x (/etc/init.d/gdm stop) and enter "sudo sh nvidia-install-blabla.run" It compiled a kernel interface, installed the drivers - boom done. Everything works fine.

    I think the trick is to make sure you DISABLE the restricted drivers that Ubuntu uses first.

  5. #15
    Join Date
    Dec 2007
    Beans
    180

    Re: Finally I installed the nVidia driver in Ubuntu

    Ahhhhhhhggggggggggg!

    NVidia is SO frustrating. I followed the directions and now it looks like it wants to work. I just have one little itty bitty problem. My screen goes BLANK! I'm totally toast.

    The NVidia drivers are trying to load. I can tell by the font used when I put in my ID & PW when I boot. My NVidia screen also shows up. But then poof, the screen goes blank. All I can do (that I know of anyway - newbie here) is ctrl-alt-F1 and shutdown.

    Anyone have any ideas on how to help? PLEASE?

    ********************** Update *********************
    I pressed a bunch of keys (I think ctrl-alt-F7 evenutally) and switched to xserver. I had an error message (stupid me - I didn't write it down). My NVidia is now working!!!!!!!!!!!! After a second reboot, the error didn't show up and my xserver actually loaded with NVidia drivers working properly. I'm all set to go.

    DeMus, I can't tell you how happy I found your post. I have been messing with NVidia off and on for a couple of months and it is now fixed. Thank you!
    Last edited by cforput; February 10th, 2009 at 08:38 PM. Reason: Update

  6. #16
    Join Date
    May 2008
    Location
    The Netherlands
    Beans
    2,149
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Finally I installed the nVidia driver in Ubuntu

    Quote Originally Posted by cforput View Post
    DeMus, I can't tell you how happy I found your post. I have been messing with NVidia off and on for a couple of months and it is now fixed. Thank you!
    Well, all I did was write down the way I installed the driver. In fact I was only copying things I found on the web.
    As I wrote earlier, I also had some small problems with hovering the mouse over a pull-down menu. After going up and down a few times, all items in the menu list would be selected. Strange things is that after one or two re-starts this disappeared completely. Why? How? I have no idea.

    I'm happy more people benefit from the way I installed the driver. I still think it is a bit strange how we had to do it. Compared to a Windows system where you just start the .exe file you download, this is like going through hell.

    But it's working and now I keep my fingers away from it. Too scared something goes wrong again.
    DeMus

  7. #17
    Join Date
    Aug 2007
    Beans
    13

    Re: Finally I installed the nVidia driver in Ubuntu

    this is what i get when i try to install the driver
    -> No precompiled kernel interface was found to match your kernel; would you li
    ke the installer to attempt to download a kernel interface for your kernel f
    rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
    -> No matching precompiled kernel interface was found on the NVIDIA ftp site;
    this means that the installer will need to compile a kernel interface for
    your kernel.
    -> Performing CC sanity check with CC="cc".
    -> Performing CC version check with CC="cc".
    ERROR: Unable to find the kernel source tree for the currently running kernel.
    Please make sure you have installed the kernel source files for your
    kernel and that they are properly configured; on Red Hat Linux systems,
    for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM
    installed. If you know the correct kernel source files are installed,
    you may specify the kernel source path with the '--kernel-source-path'
    command line option.



    what should i do next ?

  8. #18
    Join Date
    Jan 2008
    Beans
    51

    Re: Finally I installed the nVidia driver in Ubuntu

    Try getting headers for your kernel
    Code:
    sudo apt-get install linux-headers

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •