Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

  1. #1
    Join Date
    Jan 2009
    Beans
    1

    Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    Hello, I've got a little bit of a problem here...

    Every time I start a KDE application, it starts in fullscreen mode, and well, having to manually change back every window I open into normal maximized state tends to be annoying when I'm preparing for my university exams and browsing dozens of PDFs with okular. Turning off compiz seems to work but that's not a solution since KDE desktop effects are not what I'd call a suitable replacement for compiz... The issue is, when I upgraded from Hardy to Intrepid a week ago, all seemed to work right... Then I somehow managed to corrupt the partition on which I had ubuntu and well... had to reinstall the system, which resulted in the current problem...

    Anybody managed to find the solution to this problem? Google remains silent in response to my pleads for help and none of my friends uses KDE, not even mentioning the 4.2 version.

    Thx for your replies in advance. Sorai ^^

  2. #2
    Join Date
    Jan 2009
    Beans
    1

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    Hi, I had the same problem and didn't find the answer ... until I get bored trying and unchecking some of the compiz plugin and I got the one who was giving me this error. This was the one:

    Utilities -> Entorno de trabajo (Work Enviroment... I think) ->
    Allow Legacy on FullScreen

    just uncheck that option and it's done...

    I don't know if they're the exact phrases cause I have the options in Spanish but you get the idea...

    Hope it works for you.

  3. #3
    Join Date
    Oct 2007
    Beans
    4

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    Quote Originally Posted by Holy_Knight View Post
    Hi, I had the same problem and didn't find the answer ... until I get bored trying and unchecking some of the compiz plugin and I got the one who was giving me this error. This was the one:

    Utilities -> Entorno de trabajo (Work Enviroment... I think) ->
    Allow Legacy on FullScreen

    just uncheck that option and it's done...

    I don't know if they're the exact phrases cause I have the options in Spanish but you get the idea...

    Hope it works for you.
    I can confirm this. In The english version, you uncheck the checkbox located at:

    System -> Preferences -> CompizConfig Settings Manager -> Utility -> Workarounds -> Legacy Fullscreen Support

    This was also reported as a bug https://bugs.launchpad.net/bugs/324232

  4. #4
    Join Date
    Sep 2006
    Location
    Great Britain
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    Had the same problem, thank you both for posting a solution.

  5. #5
    Join Date
    Feb 2009
    Beans
    6

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    Solved it for me too.
    (Using KDE apps in Gnome)

    Thx

  6. #6
    Join Date
    Feb 2007
    Location
    South Africa
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    Hi

    I have the same problem, but I don't find this on my Ubuntu 8.10 installation:

    Code:
    System -> Preferences -> CompizConfig Settings Manager -> Utility -> Workarounds -> Legacy Fullscreen Support
    There is no "CompizConfig Settings Manager" under Preferences.

    Any idea where I might find it?

    Thanks.

  7. #7
    Join Date
    Dec 2008
    Beans
    29

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    I also sometimes battle a bit to find the path to stuff like mentioned here, dunno why, anyway, try after clicking on the "Start" button, just typing Compiz, it should show under availible options


    Thanx, this solution also worked 100% for me
    Cheers

  8. #8
    Join Date
    Feb 2007
    Location
    South Africa
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    Thanks, it worked for me, too, after I discovered that CompizConfig Settings Manager was not installed on my system!

  9. #9
    Join Date
    Jun 2007
    Beans
    35

    Wink Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    This "Utilities -> Entorno de trabajo (Work Enviroment... I think) ->
    Allow Legacy on FullScreen" worked for me in Arch linux with kde4.2 from kdemod.

  10. #10
    Join Date
    Oct 2007
    Beans
    94

    Re: Applications start in fullscreen mode (KDE 4.2 RC with compiz on)

    thanks! few kde4 tools I use (konsole, korganizer..) open nicely now

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •