Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39

Thread: Hauppauge HVR 1600 remote control?

  1. #21
    Join Date
    Dec 2006

    Re: Hauppauge HVR 1600 remote control?

    I am having the same problem.

    I was able to use my remote control and IR blaster using this tutorial:

    Unfortunately lirc0.8.5 does not compile with the current kernel.

    I tried booting into the old jaunty kernel (2.6.29) but it does not boot up.

    LIRC 0.8.6 is out now and compiles with the new kernel for Karmic, but I have not found a patch for it.

    I tried contacting the guy who made the tutorial, but so far no response.

    I would like to get this remote working.

    Im considering getting a new remote if I can't. Any suggestions?

  2. #22
    Join Date
    Jan 2008

    Re: Hauppauge HVR 1600 remote control?

    I just built a new box with 64-bit on it and finished setting stuff up today. The remote worked for me as well using 9.04 Jaunty, but now in 9.10 Karmic with all of the updates as of today, it is not working.

    I opened a bug for this as I hope it will be fixed soon. I don't want to have to put my old PVR-150 card in just to use it for the remote - but heck, it may not even work in Karmic either!

  3. #23
    Join Date
    Sep 2008
    Fargo, ND
    Ubuntu 10.10 Maverick Meerkat

    Re: Hauppauge HVR 1600 remote control?

    Yeah, I had to throw my old PVR-250 back in there. Lucky I didn't toss it.
    the dude abides...

  4. #24
    Join Date
    Jan 2008

    Re: Hauppauge HVR 1600 remote control?

    This does suck - why all of a sudden did 9.10 break the HVR-1600 and WinTV-Go Plus IR receivers/transmitters?

    I've ordered an HVR-1250 to put in this computer so I have two digital cards since I'm Finding that I'm recording everything on the digital OTA now - and will eventually get rid of our basic cable and save $15 a month. So, now I'm going to have three TV tuner cards in the system when only two are used for capture.

    Add this on top of an add-in USB PCI card that I'm going to have to put in now because of either a hardware or software bug in Ubuntu causing the MCP78S chipset USB ports to not work after an intermittent period of time or unless they are plugged in prior to Ubuntu booting up. I just got this ECS GF8200A motherboard with a built-in GeForce 8200 video card to make use of VDPAU - and now I've got more problems to circumvent.

    Also the GeForce 8200 card with 512 MB shared memory works very well with VDPAU and the 180.x.36 nVidia drivers in Ubuntu. There is a little bit of tearing, but it isn't all that terrible on 720p and 1080p broadcasts. I have the VDPAU profiles setup accordingly:

    < (less than) W: 1080 H: 720 - Use Advanced 2x deinterlacer
    >= (greater than or equal to) W: 0 H: 720 - Use Temporal 2x deinterlacer

    Order is important with the above.

  5. #25
    Join Date
    Jul 2007

    Re: Hauppauge HVR 1600 remote control?

    Hello All,

    After about a week of reading forum posts, the Hvr-1600 model 1199 grey remote finally generates output to a terminal window using the irw command.

    No luck at all getting a working channel changing script or blaster function. The only good news is that I know for a fact that the hardware works because I configured all of it in XP before I tried to run Mythbuntu. IF its any consolation, Hauppauge's software is only marginally better than linux. I just took out the XP hard drive and installed a new drive to load Mythbuntu. BTW the IR Blaster has a red led that flashes when it is working(at least on this unit). So IF the driver EVER starts working, I'll be able to see it.

    The remote still won't change channels on my Motorola 2244 cable box, but at least it does something.

    Configuring the Blaster should not be this difficult. Isn't the Hvr-1600 a popular card?

  6. #26
    Join Date
    Aug 2006

    Re: Hauppauge HVR 1600 remote control?

    how were you able to get the remote to work in irw?

  7. #27
    Join Date
    Apr 2009

    Re: Hauppauge HVR 1600 remote control?

    The breakage of the lirc_i2c module happens at a kernel >= 2.6.28, where 0.8.4a (old default 9.04 package) is no longer usable, due to i2c changes in the kernel mainline.
    I've been following this issue for several months as I moved to a >= 2.6.30 kernel quite a while back for various other reasons. The actual IR sensor driver resides in cx18_i2c, which is part of the V4L-DVB subsystem.

    It seems that there has been a flurry of changes surrounding i2c drivers in both the kernel, in lirc, and in the v4l-dvb code, but I was surprised to find that I could avoid the nonfunctional lirc_i2c/i2c_dev issues by running ir-kbd-i2c instead.

    I have not tried 9.10, and all the shiny new (more) up to date packages, so it might be worth trying a modprobe ir-kbd-i2c and checking your dmesg etc.

    The following worked for me:

    1. Get a 2.6.31 kernel loaded (possible a 2.6.30 would work; have not tried)

    or do whatever you prefer to update your kernel.
    2. Get the latest version of v4l-dvb
    hg clone
    cd v4l-dvb
    make install

    I should note that to get a full compilation of all the v4l modules, I needed to go comment out some entries for a firedtv module (in a makefile) that was failing to build. I've not pulled any updates for a few days so perhaps that is fixed? YMMV with code pulled from live repos.
    3. Get 0.8.6 lirc source installed.
    I have 0.8.6 installed via apt, and you should too.
    If you're going to be running (yes you probably will) you're going to want to edit it to change line 338 to " echo ./configure --prefix=/usr \\" >>$START so that you don't end up with the complied version ending up in the lirc default (/usr/local).

    When you configure LIRC, you will want to choose "Linux input layer (/dev/input/
    eventX)" (indicated by driver:devinput). Complete the build process via the script, make, sudo make install etc..

    So, go ahead and load ir-kbd-i2c and check it out.

    indi@indulgent:~$sudo modprobe ir-kbd-i2c
    Nov  3 21:10:45 indulgent kernel: [ ] input: i2c IR (CX23418 Z8F0811 Hauppau as /devices/virtual/input/input7
    Nov 3 21:10:45 indulgent kernel: [ ] ir-kbd-i2c: i2c IR (CX23418 Z8F0811 Hauppau detected at i2c-0/0-0071/ir0 [cx18 i2c driver #0-0]
    indi@indulgent:/etc/lirc$ cat /proc/bus/input/devices | grep -A6 "i2c IR"
    N: Name="i2c IR (CX23418 Z8F0811 Hauppau"
    P: Phys=i2c-0/0-0071/ir0
    S: Sysfs=/devices/virtual/input/input6
    U: Uniq=
    H: Handlers=kbd event6 
    B: EV=100003
    B: KEY=10..
    Note the device node - /devices/virtual/input/input6
    Stop lircd if you've got it running (sudo /etc/init.d/lirc stop, whatever)

    indi@indulgent:sudo lircd -n --device=/dev/input/event6 --output=/var/run/lirc/lircd
    lircd-0.8.6[]: lircd(devinput) ready, using /var/run/lirc/lircd
    lircd-0.8.6[]: accepted new client on /var/run/lirc/lircd
    lircd-0.8.6[]: initializing '/dev/input/event6'
    0000000080010161 00 Go HVR-1100
    Well, that would be mostly working.

    I changed my /etc/lirc/hardware.conf a little, and by adding ir-kbd-i2c to the lirc list of modules you get it to load on restart.

    Notes: ir-kbd-i2c does not autoload (by previous design to prevent device conflicts), I seem to get incorrectly identified as a 1100, but I don't care, it works. I did end up re-tweaking my ~/.lircrc slightly and modified the /usr/share/lirc/extras/more_remotes/hauppauge/lircd.conf.hauppauge a bit too. I have not tried 9.10, but imagine that a similar process should work out, as the kernel versions/lirc/v4l stuff should all be similar.

  8. #28
    Join Date
    Jun 2008
    Cavite, Philippines

    Re: Hauppauge HVR 1600 remote control?

    When I run the command make in step 2, I get the error:

    dea@e5300:~/v4l-dvb$ make
    make -C /home/dea/v4l-dvb/v4l
    make[1]: Entering directory `/home/dea/v4l-dvb/v4l'
    creating symbolic links...
    make -C firmware prep
    make[2]: Entering directory `/home/dea/v4l-dvb/v4l/firmware'
    make[2]: Leaving directory `/home/dea/v4l-dvb/v4l/firmware'
    make -C firmware
    make[2]: Entering directory `/home/dea/v4l-dvb/v4l/firmware'
    make[2]: Nothing to be done for `default'.
    make[2]: Leaving directory `/home/dea/v4l-dvb/v4l/firmware'
    Kernel build directory is /lib/modules/2.6.28-11-generic/build
    make -C /lib/modules/2.6.28-11-generic/build SUBDIRS=/home/dea/v4l-dvb/v4l modules
    make: Entering an unknown directory
    make: *** /lib/modules/2.6.28-11-generic/build: No such file or directory. Stop.
    make: Leaving an unknown directory
    make[1]: *** [default] Error 2
    make[1]: Leaving directory `/home/dea/v4l-dvb/v4l'
    make: *** [all] Error 2

    Am I in the correct Kernel build directory and how do I configure it properly?

  9. #29
    Join Date
    Apr 2007
    San Francisco
    Ubuntu 14.04 Trusty Tahr

    Re: Hauppauge HVR 1600 remote control?

    Is the kernel problem still around? I just got an HVR-1600. I am hoping to get the remote working, but I dont want to waste time if its not possible. Thanks

  10. #30
    Join Date
    Dec 2008
    Atlanta Ga
    Ubuntu 9.04 Jaunty Jackalope

    Re: Hauppauge HVR 1600 remote control?

    I have just set up an ubuntu/myth box with 9.10 64bit and my remote doesnt work. I always seem to find out about problems after I experience them...I need be able to see the future a little better. I see that it is broken in this release but I am not clear if it is fixed in 10.04 or works in 9.04. I briefly had 9.04 working but the hardware wasnt robust I built this amd64 box and went ahead and put 9.10 on it.

    Any advice on the best way to resolve the remote issue? buy a separate remote and dump the included one? downgrade to 9.04? upgrade to 10.04? or sit tight for a bit and wait on a fix?

Page 3 of 4 FirstFirst 1234 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts