Page 28 of 29 FirstFirst ... 1826272829 LastLast
Results 271 to 280 of 281

Thread: snd_hda_intel options database

  1. #271
    Join Date
    Jun 2007
    Beans
    12,411

    Re: snd_hda_intel options database

    ^There are no specific models for Cirrus Logic CS4213 codec (which the Inspiron 3520 uses). What is wrong with it?

  2. #272
    Join Date
    Sep 2013
    Beans
    5

    Re: snd_hda_intel options database

    Headphones and speakers works at the same time, no headphones control in alsamixer thus no way to auto-mute speakers when headphones are plugged in... This is very annoying... Thanks for your help.

  3. #273
    Join Date
    Jun 2007
    Beans
    12,411

    Re: snd_hda_intel options database

    Quote Originally Posted by paranoidandroid845 View Post
    Headphones and speakers works at the same time.
    Try latest driver module: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS
    If it's not working after reboot, file a bug.

  4. #274
    Join Date
    Sep 2013
    Beans
    5

    Re: snd_hda_intel options database

    I already have DKMS... kernel, modules and alsamixer upgraded. I also must precise that Im not running Ubuntu but Debian, i posted here because this is the only forum dealing with the asla-base.conf specifications related to the hardware. No solutions for my problems on debian forums, and I think perhaps the only way is to find the right name that fit in "options snd-hda-intel model=".

  5. #275
    Join Date
    Jun 2007
    Beans
    12,411

    Re: snd_hda_intel options database

    ^Post the info: https://wiki.ubuntu.com/Audio/AlsaInfo
    The only possible model I see in the code is cdb4210 ("stumpy" is for chromebooks): https://github.com/torvalds/linux/bl..._cirrus.c#L698

  6. #276
    Join Date
    Sep 2013
    Beans
    5

    Re: snd_hda_intel options database

    Ihe name cdb4210 doesn't work.. So I posted the info here: http://www.alsa-project.org/db/?f=b5...3babdacfd3805a

  7. #277
    Join Date
    Jun 2007
    Beans
    12,411

    Re: snd_hda_intel options database

    Code:
    Kernel release:    3.2.0-4-686-pae
    Driver version:     1.0.24
    You're still running a relatively old kernel/driver. If you don't want to mess with your install, get a LiveUSB ( http://releases.ubuntu.com/13.10/ ) and test if the problem still occurs there. If so, file a bug using the LiveUSB.

  8. #278
    Join Date
    Sep 2013
    Beans
    5

    Re: snd_hda_intel options database

    Hello,

    I just compiled a new kernel (3.11) and you are right ! The problem is solved. Thank you.

  9. #279
    Join Date
    May 2007
    Beans
    2

    Re: snd_hda_intel options database

    For Toshiba Satellite C655D and Linux Mint 16, setting model=laptop fixed the problem of no audio (i.e., no speaker, no headphone; mic ok). Previous attempt of model=toshiba (as well as asus and ideapad) did NOT work.

    Prior version of Linux Mint worked fine, so Mint 16 default install picks up a regression in the alsa driver WRT this particular Satellite laptop. But happy ending with above change.

    In passing, I note that audio is: Conexant CX20585

  10. #280
    Join Date
    Mar 2014
    Beans
    2

    Re: snd_hda_intel options database

    I have try alot of things but i can still got audio with ALC662


    Quote Originally Posted by Eric06 View Post
    Addition to your database (i am so glad sound works )

    Ubuntu 8.10
    Packard bell laptop Easynote RS65-M023FR pn=PC28E01502
    windows = sound ok; ubuntu no sound +

    config:

    cat /proc/asound/cards
    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xfdcf8000 irq 22
    1 [HDMI ]: HDA-Intel - HDA ATI HDMI
    HDA ATI HDMI at 0xfddec000 irq 17

    cat /proc/asound/modules
    0 snd_hda_intel
    1 snd_hda_intel

    aplay -l
    **** Liste des PLAYBACK périphériques ****
    carte 0: Intel [HDA Intel], périphérique 0 : ALC663 Analog [ALC663 Analog]
    Sous-périphériques: 0/1
    Sous-périphérique: #0: subdevice #0
    carte 1: HDMI [HDA ATI HDMI], périphérique 3 : ATI HDMI [ATI HDMI]
    Sous-périphériques: 1/1
    Sous-périphérique: #0: subdevice #0

    Upgraded to ALSA 1.0.19 without problem using the script from the forum

    I added the following line at the end of /etc/modbase.d/alsa-base file:
    options snd-hda-intel model=m51va

    there are mutiple values that get the speakers to work but not the headset... so i tryed all the ones corresponding to my hardware device to test them (lots of 'sudo alsa force-reload' and 'alsamixer' commands during the test)

    summary of the behaviors i see on my machine:

    #ALC662/663:HP/mic/headset/ touchpad
    #3stack-dig: ok/no/no
    #3stack-6ch: ok/ no/no
    #3stack-6ch-dig: ok/no/ no
    #6stack-dig: ok / no / no
    #lenovo-101e: ok / lo / no/ no
    #eeepc-p701: bad sound
    #eeepc-ep20: ok / no / no / no
    #m51va: ok / lo / ok / part
    #g71v: ok / no / ok / part
    #h13 : ok / low/ ok / part
    #g50v: ok / no / no / part
    # auto: no sound

    I did not get good results on MIC and I did not test the HDMI ouput too

    Thanks to you forum gurus

Page 28 of 29 FirstFirst ... 1826272829 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •