Results 1 to 4 of 4

Thread: Jerky graphics with OpenGL + Nvidia 6200 - Mandriva 2009

  1. #1
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,217

    Jerky graphics with OpenGL + Nvidia 6200 - Mandriva 2009

    Hi there. I've posted this up in the Mandriva forums, but they seem to be down right now, so I'm hoping someone here can help.

    I re-installed Mandriva 2009 KDE4 yesterday after having these issues a while ago, but they even though it was fine before switching off the problems have arisen again today. How, I don't know. Basically I'm using the latest Nvidia driver available from Mandriva (180.22) and I'm getting juttery graphics when using OpenGL applications. Chiefly, I'm thinking of Mupen64Plus 1.5, and Gens/GS, both from the PLF repositories, and both use OpenGL. I had this issue on the last Nvidia driver too. I actually don't think the driver is to blame, though I can't imagine what else it could be.

    The performance is really slow and stuttery, and the sound is similarly affected too. I should mention that I have a monitor that Linux has problems with. I have to manually add an option to the xorg.conf with every distro I install. I've acquired the EDID.bin file, and I have to point xorg at it like thus -
    Code:
    Option         "CustomEDID" "DFP-0:/home/username/Nvidia/edid.bin"
    If I don't do this the monitor has no output. This is fine for almost every distro, but with Mandriva 2009 I have had issues with OpenGL as above. I also have to add the autostart option nvidia-settings -l to Mandriva too, so it remembers my vsync settings etc.

    Can anyone help me with this issue on Mandriva? I've tried all sorts of distros recently, but I still end up back on Mandriva simply because I love it so much. It's always been my no.1 dual boot option for years alongside my Ubuntu main install. I really don't want to change to something else.

    Thanks all.
    AMD Phenom X4 945, 4Gb Crucial 800Mhz DDR2 RAM, 1Tb SATA III HDD, AMD Radeon R7 250X

  2. #2
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,217

    Re: Jerky graphics with OpenGL + Nvidia 6200 - Mandriva 2009

    Bloody idiot! I've found the problem, and it's simply that the refresh rate was set to "auto" rather than the 60hz it should be at. Good grief, I'm getting worse at this! I spent ages trying to find the solution!

    All seems to be fine now. Always one thing you forget to do isn't there? Glad my Mandy's back anyway. Thrilled with it.
    AMD Phenom X4 945, 4Gb Crucial 800Mhz DDR2 RAM, 1Tb SATA III HDD, AMD Radeon R7 250X

  3. #3
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,217

    Re: Jerky graphics with OpenGL + Nvidia 6200 - Mandriva 2009

    What the...

    It's gone all juddery again. It was OK when I left it. What the hell is going on? If anyone has any ideas please let me know.

    I'm fed up with it.
    AMD Phenom X4 945, 4Gb Crucial 800Mhz DDR2 RAM, 1Tb SATA III HDD, AMD Radeon R7 250X

  4. #4
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,217

    Re: Jerky graphics with OpenGL + Nvidia 6200 - Mandriva 2009

    Sod it. Installed the Gnome edition instead today. Hopefully, that'll be better...

    /crosses fingers

    EDIT: 24 hours later, all is well with the Gnome edition. Thank gawd for that.
    Last edited by BigSilly; January 20th, 2009 at 03:31 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •