Results 1 to 10 of 20

Thread: Twinview, primary right screen and desktop icons

Hybrid View

  1. #1

    Question Twinview, primary right screen and desktop icons

    Hi,

    I've set up Twinview so that my primary monitor is right of my secondary (smaller) monitor. However it seems nautilus doesn't correctly understand this and places the desktop icons on my secondary monitor.

    Also I notice that the "flashing effect" when taking a photo in Cheese with my webcam appears on the left secondary monitor as well.

    Anyone know of any way to fix this? I guess the problem is with Twinview not exposing both monitors to the X server in a way that non-twinview aware applications can understand..?


    I'm running Ubuntu Intrepid 386
    nVidia GeForce 8800 GT and version 177.82 of the nvidia drivers

    Please see attached xorg.conf (generated by nvidia-settings)
    Attached Files Attached Files
    Best regards,
    Johannes

  2. #2
    Join Date
    Feb 2009
    Beans
    2

    Re: Twinview, primary right screen and desktop icons

    No solutions for this? I think I have the same problem. My laptop is to the left of my monitor; my menu bars appear on the regular monitor but the icons appear on the laptop monitor. Not only that but even more annoying, the icon placement on the laptop screen extends below what it should, so that I can't see a number of the icons. Any ideas?

  3. #3

    Re: Twinview, primary right screen and desktop icons

    Quote Originally Posted by takeboat View Post
    No solutions for this? I think I have the same problem. My laptop is to the left of my monitor; my menu bars appear on the regular monitor but the icons appear on the laptop monitor. Not only that but even more annoying, the icon placement on the laptop screen extends below what it should, so that I can't see a number of the icons. Any ideas?
    Yep, I still have this problem and haven't found any solutions to it yet :-/
    Best regards,
    Johannes

  4. #4
    Join Date
    Aug 2006
    Beans
    39

    Re: Twinview, primary right screen and desktop icons

    I am also having the problem with icons going off the screen.

    It seems that since my primary monitor (laptop) is smaller than my secondary that the overall desktop size expands beyond the laptop screen causing the icons to go off with it.


    Any fix?

  5. #5
    Join Date
    Jul 2007
    Location
    Connecticut USA
    Beans
    1,865
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Twinview, primary right screen and desktop icons

    Do
    Code:
    sudo nvidia-settings
    then go to X-server display configuration (on the left)

    You will see representations of your monitors. Drag them around until they are like how you have them set. Click on the one you want as primary. Make sure twinview is selected. Then click "make this the primary display for the X screen". Then "apply" and then "save to x configuration file". quit and reboot.

  6. #6
    Join Date
    Aug 2006
    Beans
    39

    Re: Twinview, primary right screen and desktop icons

    Quote Originally Posted by HappyFeet View Post
    Do
    Code:
    sudo nvidia-settings
    then go to X-server display configuration (on the left)

    You will see representations of your monitors. Drag them around until they are like how you have them set. Click on the one you want as primary. Make sure twinview is selected. Then click "make this the primary display for the X screen". Then "apply" and then "save to x configuration file". quit and reboot.
    I am vary familiar with the nvidia settings. The problem is the left over space from the monitor with the larger resolution. Below are links to others discussing the same problem, but there does not seem to be a fix yet.but please post if there is!

    https://bugs.launchpad.net/nautilus/+bug/360970
    http://www.mail-archive.com/desktop-...msg319311.html

    Thanks.

  7. #7
    Join Date
    Sep 2008
    Beans
    22

    Re: Twinview, primary right screen and desktop icons

    Quote Originally Posted by HappyFeet View Post
    Do
    Code:
    sudo nvidia-settings
    then go to X-server display configuration (on the left)

    You will see representations of your monitors. Drag them around until they are like how you have them set. Click on the one you want as primary. Make sure twinview is selected. Then click "make this the primary display for the X screen". Then "apply" and then "save to x configuration file". quit and reboot.

    "Drag them arounduntil they are like how you have them set."

    Bolded part is what I was missing. Ubuntu 10.04 64 bit, and this is the first time I've had dual screens. I got into nvidia-settings by way of the GUI menu, as well as through the CLI. It never occured to me to DRAG the screens around. As soon as I had a bit of separation between the screens, my toolbar and my icons shifted themselves to the primary (left) screen, and the secondary screen became "extra" real estate in which I can park my windows.

    If you're still around after all this time, Happy Feet, THANK YOU!!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •