Results 1 to 8 of 8

Thread: Clocksource tsc unstable

  1. #1
    Join Date
    Sep 2007
    Location
    Malaysia
    Beans
    280
    Distro
    Ubuntu 11.04 Natty Narwhal

    Question Clocksource tsc unstable

    I am trying to load ubuntu live cd and nothing happens after I hit start/install. I remove the quite splash thing and I see this message

    Clocksource tsc unstable (delta = -299251584239ns)

    what does that mean? I've been using the same cd for a while now and I know it works, plus I've installed ubuntu alot of times on my pc before using live cds.


    I'm running
    Asus M2a-VN Mobo
    AMD Athlon X2 +3600 1.9Ghz
    OCZ 2 GB RAM 800Mhz DDR2
    Plenty of disk space available

    I heard from someone that it means my bios battery is running low. Could that be it?

  2. #2
    Join Date
    Jan 2007
    Location
    Melbourne, Australia
    Beans
    5,096

    Re: Clocksource tsc unstable

    Try adding clocksource=hpet as a boot option and see what happens. At the main menu press F6 and at the end of the line add
    Code:
    clocksource=hpet
    Ubuntu Newbie Help: irc: #beginners-help on network irc.freenode.net
    Help others, mark your threads solved.

  3. #3
    Join Date
    Feb 2009
    Beans
    22

    Re: Clocksource tsc unstable

    bump,

    id like to keep this on top hoping someone can help with this. ive been researching this problem for 3 days and cant seem to find a good solution to it.

    im having random hang ups and after when the hang up is done, i check the log files and it would always come up as clocksource tsb unstable.

    please help with this problem.

  4. #4
    Join Date
    Apr 2007
    Location
    Sao Paulo
    Beans
    237
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Clocksource tsc unstable

    what about adding the option clocksource=jiffies to the kernel lines in /boot/grub/menu.lst?
    Life sux, then you die.

  5. #5
    Join Date
    Apr 2009
    Beans
    8

    Re: Clocksource tsc unstable


  6. #6
    Join Date
    May 2007
    Beans
    9

    Re: Clocksource tsc unstable

    this tread rocks the question
    I think you pasted the wrong link. It's about thunderbird.
    I have a virtualized karmic and I get lot's of

    Code:
    /var/log/kern.log:Dec 26 07:10:28 webmail kernel: [  615.503277] Clocksource tsc unstable (delta = -147977885 ns)
    /var/log/kern.log:Dec 27 07:02:00 webmail kernel: [  107.000842] Clocksource tsc unstable (delta = -139962943 ns)
    /var/log/kern.log:Dec 28 07:03:41 webmail kernel: [  208.502001] Clocksource tsc unstable (delta = -137181469 ns)
    /var/log/kern.log:Jan 12 09:17:19 webmail kernel: [    8.035751] Clocksource tsc unstable (delta = -94509445 ns)
    Did any of you tested the boot options reported above?
    Which one works?

  7. #7
    Join Date
    Feb 2013
    Beans
    1

    Re: Clocksource tsc unstable

    Hi dear community!

    #Thanks to you I'm getting with linux better and better (sry for my English).
    #INow it's my turn to contribute a little piece of solving this "Clocksource tsc #unstable".

    I've got freezes just after system has booted and there were messages like
    Marking TSC unstable due to cpu freq changes
    Clocksource tsc unstable (delta = -96979.... ns)
    in /var/log/syslog.

    Adding "notsc clocksource=acpi_pm" to kernel parameters didn't help.

    The solution for me was switching "AMD Cool'n'Quiet configuration" to "Disable" feature in BIOS.

    Linux rocks!

  8. #8
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 18.04 Bionic Beaver

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •