Results 1 to 2 of 2

Thread: Fixing slow boot on laptop with NTFS mount

  1. #1
    Join Date
    Jun 2006

    Fixing slow boot on laptop with NTFS mount

    On a dual-boot laptop (Ubuntu 8.10 and Windows XP), the Ubuntu boot time is very slow, about 2 minutes. The bootcharts attached seem to indicate that a check of the NTFS filesystem is the cause of the delay.

    The laptop is not here in front of me, but I can reply later today with the contents of /etc/fstab or other if helpful. Let me know what configuration would be indicative.

    The user really does not need the NFTS partition mounted all the time, but I don't want to uninstall the NTFS tools permanently.

    What is the best way to suppress either the slow part of the NFTS initialization, or better to prevent the NTFS mount unless/until the user performs a simple step.

    Attached Images Attached Images

  2. #2
    Join Date
    Jun 2006

    Re: Fixing slow boot on laptop with NTFS mount

    Update, I have added 'noauto' to the /etc/fstab line for the ntfs-3g mount.

    On reboot(s), it did not mount the partition, but the relatively slow check in the middle of the progress remains.

    $ cat /etc/fstab
    # /etc/fstab: static file system information.
    #  -- This file has been automaticly generated by ntfs-config -- 
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc /proc proc defaults 0 0
    # Entry for /dev/sda1 :
    UUID=8ae64560-2343-4143-9764-58ef8dcf4f93 / ext3 defaults,errors=remount-ro,relatime 0 1
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
    /dev/sda2 /media/ACER ntfs-3g noauto,defaults,locale=en_US.UTF-8 0 0
    Is there any 'nocheck' or similar option to fstab that will suppress this lengthy boot delay?


Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts