Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Sin internet móvil con modem ZTE de Claro en II

  1. #1
    Join Date
    Jul 2006
    Location
    Córdoba, Argentina
    Beans
    1,341
    Distro
    Ubuntu 11.04 Natty Narwhal

    Sin internet móvil con modem ZTE de Claro en II

    Hola a todos,
    como lo dice el título, no me aparece la opción para conectarme a internet móvil en mi máquina cuando conecto el modem. El mismo es ignorado por la máquina (como debería ser ya que no tiene que tomarlo como un disco usb) pero en las conexiones del network manager no aparece CTI/Claro como opción de conexión (pese a que está configurada).

    Algunas salidas:

    Code:
    mariano@kafka:~$ tail -f /var/log/messages
    Jan  9 20:35:40 kafka kernel: [ 9976.760085] usb 7-1: new high speed USB device using ehci_hcd and address 10
    Jan  9 20:35:40 kafka kernel: [ 9976.906240] usb 7-1: configuration #1 chosen from 1 choice
    Jan  9 20:35:40 kafka kernel: [ 9976.907831] usb-storage: device ignored
    Code:
    mariano@kafka:~$ lsusb
    Bus 007 Device 010: ID 19d2:2000
    El modem está con la luz en verde, lo que supongo indica que está ok para operar y de hecho funciona ok en la máquina de mi esposa.
    ¿Alguna idea para hacerlo arrancar?
    Mariano
    Ubuntu Linux User Group Argentina
    Let's all get up and dance to a song/ That was a hit before your mother was born/ Though she was born a long long time ago

  2. #2
    Join Date
    Nov 2008
    Location
    Córdoba, Argentina
    Beans
    907

    Re: Sin internet móvil con modem ZTE de Claro en II

    lo reconoce como puerto serial?

    Code:
    ls -l /dev/ttyUSB*
    un link si te sirve http://www.ubuntu-es.org/index.php?q=node/101170

    saludos

  3. #3
    Join Date
    Jul 2006
    Location
    Córdoba, Argentina
    Beans
    1,341
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sin internet móvil con modem ZTE de Claro en II

    Nope, no es reconocido. En 8.04 con usb_modeswitch tras mucho esfuerzo lo reconocía pero no sucede lo mismo acá (en el lsusb está ok el vendor y el product pero parece ser que eso no ayuda en mucho).
    Alguien sabe donde se guarda la configuracion sobre que modelo de modem elige cuando lo intenta montar?
    Mariano
    Ubuntu Linux User Group Argentina
    Let's all get up and dance to a song/ That was a hit before your mother was born/ Though she was born a long long time ago

  4. #4
    Join Date
    Jul 2006
    Location
    Córdoba, Argentina
    Beans
    1,341
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sin internet móvil con modem ZTE de Claro en II

    Se me ocurrió que posiblemente lo esté desmontando como disco pero no esté cargando el módulo en el kernel así que le metí toda la parafernalia necesaria para que esto ocurra:

    Code:
    mariano@kafka:~$ sudo modprobe usbserial vendor=0x19d2 product=0x0031
    Password or swipe finger:
    mariano@kafka:~$ ls -l /dev/ttyUSB*
    ls: cannot access /dev/ttyUSB*: No such file or directory
    mariano@kafka:~$ sudo mknod /dev/ttyUSB0 c 188 0
    mariano@kafka:~$ sudo mknod /dev/ttyUSB1 c 188 1
    mariano@kafka:~$ sudo mknod /dev/ttyUSB2 c 188 2
    mariano@kafka:~$ sudo chown root:dialout /dev/ttyUSB*
    mariano@kafka:~$ sudo chmod 660 /dev/ttyUSB*
    mariano@kafka:~$ ls -l /dev/ttyUSB*
    crw-rw---- 1 root dialout 188, 0 2009-01-09 23:31 /dev/ttyUSB0
    crw-rw---- 1 root dialout 188, 1 2009-01-09 23:31 /dev/ttyUSB1
    crw-rw---- 1 root dialout 188, 2 2009-01-09 23:32 /dev/ttyUSB2
    mariano@kafka:~$ sudo modprobe usbserial -r
    mariano@kafka:~$ sudo modprobe usbserial vendor=0x19d2 product=0x0031
    De todos modos, sin suerte hasta el momento. Si a alguien se le ocurre algo, que chifle.
    Mariano
    Ubuntu Linux User Group Argentina
    Let's all get up and dance to a song/ That was a hit before your mother was born/ Though she was born a long long time ago

  5. #5
    Join Date
    May 2007
    Location
    Buenos Aires - Argentina
    Beans
    3,661
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Sin internet móvil con modem ZTE de Claro en II

    Quote Originally Posted by marianom View Post
    Hola a todos,
    como lo dice el título, no me aparece la opción para conectarme a internet móvil en mi máquina cuando conecto el modem. El mismo es ignorado por la máquina (como debería ser ya que no tiene que tomarlo como un disco usb) pero en las conexiones del network manager no aparece CTI/Claro como opción de conexión (pese a que está configurada).

    Algunas salidas:

    Code:
    mariano@kafka:~$ tail -f /var/log/messages
    Jan  9 20:35:40 kafka kernel: [ 9976.760085] usb 7-1: new high speed USB device using ehci_hcd and address 10
    Jan  9 20:35:40 kafka kernel: [ 9976.906240] usb 7-1: configuration #1 chosen from 1 choice
    Jan  9 20:35:40 kafka kernel: [ 9976.907831] usb-storage: device ignored
    Code:
    mariano@kafka:~$ lsusb
    Bus 007 Device 010: ID 19d2:2000
    El modem está con la luz en verde, lo que supongo indica que está ok para operar y de hecho funciona ok en la máquina de mi esposa.
    ¿Alguna idea para hacerlo arrancar?
    Mariano

    Recientemente tuve una experiencia "reveladora", si cabe el termino, sobre estos aparatitos (bajo otro sistema operativo no-Linux).

    La luz del modem indica que se conecta con la antena, no con la PC, y su color da idea del protocolo de comunicacion establecido (rojo => sin señal; verde => GPRS; azul => Edge; celeste => 3G).

    Esos modems son a la vez pendrives (si les pones una memoria microSD) y poseen una ROM que simula una unidad CD-ROM donde esta el aplicativo para instalarlo en Windows (por ahora solo viene con eso) junto con drivers ad-hoc.

    El equipo es, en si mismo, un celular sin teclado. Tiene un numero de telefono celular asociado, una tarjeta SIMM, un IMEI, etc.

    En su documentacion se recomienda usarlo siempre con los cables, no directo (dicen que mejora su funcionamiento).

    Con todo esto se me ocurre que tal vez lo mas logico seria que lo reconozca como un dispositivo USB (algo asi como un modem ADSL via USB) porque inclusive para conectarlo a la red hay que discar *99#.

    En mi reciente experiencia, instalaba todo el software+drivers sin errores (en WinXP) y aun asi no reconocia al equipo (si a la ROM/fake CD). Tuve que deshabilitar los programas de seguridad que estaban activos (Ad-Watch y AVG8) para que la instalacion y posterior operacion fueran satisfactorias (en la documentacion nunca habla de llevar a cabo esto como prerequisito). Esto me paso con el modelo que tenes vos y con un Huawei de la misma operadora (con los Huawei de Movistar nunca tuve estos problemas).

    Tu esposa que SO usa ?
    Guillermo Lisi
    ----------------
    Minds are like parachutes. They only function when they are open.

  6. #6
    Join Date
    Jul 2006
    Location
    Córdoba, Argentina
    Beans
    1,341
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sin internet móvil con modem ZTE de Claro en II

    Guille, coincido 100% en tu analisis. Mi esposa usa XP y el modem arrancó previa instalación de un soft personalizado sin problemas.
    Antes de intentar usar el modem en II, lo intenté en HH (hice el upgrade ayer) y me pasé unas cuantas horas revisando documentación sobre como hacerlo funcionar (entre ello, el sitio de Sismo quien tiene una suerte terrible para que le anden las cosas out of the box y vive así muy campante). En mi tiempo de investigación aprendí de modem usb, usr_modeswitch y los distintos problemas que a todos se le presentan cuando quieren usar estos modems. Lamentablemente estoy medio atrapado en un callejón sin salida con este problema ya que no estoy pudiendo que el modem (modelo 626, parecido pero distinto a todos los demás) se monte en el /dev/ttyUSB como debería.
    Está visto que me voy a tener que ensuciar realmente las manos para sacar andando esta porquería por más horas que deba invertir en el proceso.
    Mariano
    Ubuntu Linux User Group Argentina
    Let's all get up and dance to a song/ That was a hit before your mother was born/ Though she was born a long long time ago

  7. #7
    Join Date
    Oct 2006
    Location
    Cap.Fed., Argentina
    Beans
    787
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Sin internet móvil con modem ZTE de Claro en II

    Marianom, justamente estoy interesado en la oferta 3G de Claro pero como antes me gustaria saber si va o no vá con una pc de escritorio y más precisamente con Ubuntu me vino al pelo tu post. Googleando encontré algo sobre modems 3G USB en Ubuntu está en Inglés.

    Espero te sirva de algo.

    http://polishlinux.org/linux/ubuntu/...-ubuntu-linux/

  8. #8
    Join Date
    Nov 2008
    Location
    Córdoba, Argentina
    Beans
    907

    Re: Sin internet móvil con modem ZTE de Claro en II

    Quote Originally Posted by atari130xe View Post
    Marianom, justamente estoy interesado en la oferta 3G de Claro pero como antes me gustaria saber si va o no vá con una pc de escritorio y más precisamente con Ubuntu me vino al pelo tu post. Googleando encontré algo sobre modems 3G USB en Ubuntu está en Inglés.

    Espero te sirva de algo.

    http://polishlinux.org/linux/ubuntu/...-ubuntu-linux/
    OJO!, no te confundas, este problema es especifico de este modelo de modem, los modems huawei, que es la otra marca que mas venden las operadoras, andan al pelo en ubuntu, solo conectarlo y seguir el asistente, yo tengo uno y lo uso como conexion principal, porque no existe otra cosa donde vivo, y anda muy bien, cero dramas, solo se calienta un poco, pero eso es otra cosa

    saludos

  9. #9
    Join Date
    Jul 2006
    Location
    Córdoba, Argentina
    Beans
    1,341
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sin internet móvil con modem ZTE de Claro en II

    Y de hecho no es que pase con todos los modems ZTE ya que está regada la web de gente que le funciona ok... a mi no me anda

    Atari, ahora voy a echarle un ojo al link que me pasaste y les cuento.
    Mariano
    Ubuntu Linux User Group Argentina
    Let's all get up and dance to a song/ That was a hit before your mother was born/ Though she was born a long long time ago

  10. #10
    Join Date
    Jul 2006
    Location
    Córdoba, Argentina
    Beans
    1,341
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sin internet móvil con modem ZTE de Claro en II

    Quote Originally Posted by marianom View Post
    Atari, ahora voy a echarle un ojo al link que me pasaste y les cuento.
    Otro post de gente exitosa a la cual le anda todo desde cero... los odio
    Mariano
    Ubuntu Linux User Group Argentina
    Let's all get up and dance to a song/ That was a hit before your mother was born/ Though she was born a long long time ago

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •