Page 2 of 50 FirstFirst 123412 ... LastLast
Results 11 to 20 of 495

Thread: [Howto] MPlayer with CoreAVC

  1. #11
    Join Date
    Jan 2009
    Location
    Coutances, France
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: [Howto] MPlayer with CoreAVC

    Hi,

    yes it sounds like a compat pb.

    With x264 from svn, it's ok (adding a line of code in libavcodec/nellymoserenc.c).

    About graphic, i don't know what went wrong. try after try i could configure with --enable-gui, and could compile ;

    the only way the alter XShape cap is from xorg.conf, and obviously i tried with native xorg nvidia driver and with the proprietary one... Just using the admin menu... a non deterministic automated process
    Without --enable-gui, everything is ok.

  2. #12
    Join Date
    Sep 2007
    Beans
    207
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: [Howto] MPlayer with CoreAVC

    Hi! thanks for this wonderful guide. I was able to follow it, compile mplayer and edit codecs.conf. But whenever I run it, it shows:

    Code:
    Forced video codec: coreserve
    Cannot find codec matching selected -vo and video format 0x33564D57.
    Read DOCS/HTML/en/codecs.html!
    So I get no video. Any help is appreciated.

    Got this resolved!
    Last edited by tech0007; January 19th, 2009 at 02:34 PM. Reason: Resolved.

  3. #13
    Join Date
    Jan 2009
    Location
    Coutances, France
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: [Howto] MPlayer with CoreAVC

    Hi,

    if i try with a movie which doesn't use CoreAVC, i obtain "no video", all ok with coreavc encoded movies. (ffmpeg -i foo.mkv --> video : h264)
    -
    it depends only on what encoding you want to read ; with -vc coreserve : only coreavc, without -vc coreserve, it reads all other kind.
    Last edited by Cybervirem; January 19th, 2009 at 07:09 PM. Reason: add note

  4. #14
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,292
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [Howto] MPlayer with CoreAVC

    Hmm, I should have made that clearer.

    With -vc coreserve, (notice the trailing comma!), it will work for everything (it will first try to use CoreAVC, and if that fails, fall back to the normal codecs).

    That means you can add

    Code:
    vc=coreserve,
    to your mplayer.conf, and it will always use CoreAVC if possible, and fall back to the default codecs if not.
    「明後日の夕方には帰ってるからね。」


  5. #15
    Join Date
    Jan 2009
    Location
    Coutances, France
    Beans
    8
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: [Howto] MPlayer with CoreAVC

    thank you !
    I will now try to configure with --enable-gui

  6. #16
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,292
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [Howto] MPlayer with CoreAVC

    Quote Originally Posted by Cybervirem View Post
    thank you !
    I will now try to configure with --enable-gui
    You can also try to use smplayer instead of the GUI that ships with MPlayer. I've been told it's much more advanced and has more features, but couldn't get the time to try it yet.
    「明後日の夕方には帰ってるからね。」


  7. #17
    Join Date
    Aug 2007
    Beans
    13

    Re: [Howto] MPlayer with CoreAVC

    Hi!

    Id really like to get this to work!

    However, my problem is that my trial serial code doesnt seem to regiser correctly, or it cant be found. I have a 64 bit CPU if that matters.

    The registration process goes fine, but when it enter the command to test the registration I get:

    No id specified, assuming test mode
    Opening device
    Called unk_IsDebuggerPresent
    MSGBOX 'Serial Number Missing!' 'CoreAVC Trial Edition' (327680)
    Win32 LoadLibrary failed to load: CoreAVCDecoder.ax
    Warning: DS_Filter() could not open DirectShow DLL. (DLL=CoreAVCDecoder.ax)
    Failed to create DirectShow filter
    Failed to open win32 codec CoreAVCDecoder.ax

    How do I fix this?

    Thanks in advance! //Mathias

  8. #18
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,292
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [Howto] MPlayer with CoreAVC

    The serial number for the Trial version is stored in a different place in registry than for the full version, so the command to register your serial number is different. Try this:

    Code:
    rm -rf ~/.mplayer/registry32
    registercodec -r ~/.mplayer/registry32 -k "HKLM\\Software\\CoreCodec\\CoreAVC Trial\\Serial" -v "55555-55555-CORE-55555-5555"
    「明後日の夕方には帰ってるからね。」


  9. #19
    Join Date
    Jun 2008
    Location
    London
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: [Howto] MPlayer with CoreAVC

    Well, I've got it working by following your instructions, so that's very good!

    Still unable to get 1080p files to play smoothly though, looks like it's a HW issue, but thanks for a great tutorial!

  10. #20
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,292
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [Howto] MPlayer with CoreAVC

    Updated for CoreAVC 1.9 (yes, it works). I'll have to look into the GPU decoding (I don't have a compatible card at the moment), but it seems unlikely that it will work.
    「明後日の夕方には帰ってるからね。」


Page 2 of 50 FirstFirst 123412 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •