Results 1 to 9 of 9

Thread: Clam AV update fails

  1. #1
    Join Date
    Sep 2007
    Beans
    104
    Distro
    Ubuntu 10.04 Lucid Lynx

    Clam AV update fails

    I run Ubuntu 8.10 Ibex

    I have tried to do sudo freshclam and sudo freshclam -v. and I receive 2 errors. I get /var/log/clamav/freshclam.log is locked by another process and Problem with internal logger (UpdateLogFile = /var/log/clamav/freshclam.log).

    I have found this link and it mirrors my situation ,except only reports the one error, but looks like no solution:
    HTML Code:
    http://ubuntuforums.org/showthread.php?t=527480&highlight=problem+internal+logger
    Also have a problem with rar code not compiled in when doing clam scans and read this bug report which hasn't been updated since june of 2008.

    HTML Code:
    https://wwws.clamav.net/bugzilla/show_bug.cgi?id=1050
    Asus M3N78 PRO Motherboard, AMD Athlon X2 Processor 2.7GHz True dual core, EVGA GeForce 9500 GT 512MB video card, 4GB ram and 3 Western Digital 1TB HDD one in a NexStar3 external USB 2.0 HDD enclosure, Sound Blaster live 24 bit sound card.

  2. #2
    Join Date
    Dec 2007
    Location
    howard, wi
    Beans
    2,419
    Distro
    Ubuntu 20.04 Focal Fossa

    Lightbulb Re: Clam AV update fails

    gre, have you tried sudo clamtk in terminal/cheesemaker

  3. #3
    Join Date
    Oct 2007
    Beans
    1

    Re: Clam AV update fails

    Had the same problem.. the daemon was running in processes.

    had to ---> sudo /etc/init.d/clamav-freshclam stop

    then sudo freshclam -v

    and it worked for me.

    then restart the daemon with

    sudo /etc/init.d/clamav-freshclam start

    after it was restarted i was able to run the freshclam -v command with no more porblems. thinking it might have been locked up..??

  4. #4
    Join Date
    Sep 2006
    Beans
    3,165
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Clam AV update fails

    stop apparmor, update, then start apparmor

  5. #5
    Join Date
    Feb 2005
    Beans
    3

    Re: Clam AV update fails

    Quote Originally Posted by Pidster View Post
    Had the same problem.. the daemon was running in processes.

    had to ---> sudo /etc/init.d/clamav-freshclam stop

    then sudo freshclam -v

    and it worked for me.

    then restart the daemon with

    sudo /etc/init.d/clamav-freshclam start

    after it was restarted i was able to run the freshclam -v command with no more porblems. thinking it might have been locked up..??
    thx for the tip, worked like a charm.

  6. #6
    Join Date
    Feb 2010
    Location
    Islamabad, Pakistan
    Beans
    3
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Clam AV update fails

    Quote Originally Posted by Pidster View Post
    Had the same problem.. the daemon was running in processes.

    had to ---> sudo /etc/init.d/clamav-freshclam stop

    then sudo freshclam -v

    and it worked for me.

    then restart the daemon with

    sudo /etc/init.d/clamav-freshclam start

    after it was restarted i was able to run the freshclam -v command with no more porblems. thinking it might have been locked up..??
    @Pidster. Thanks a lot, it works like a magic.

  7. #7
    Join Date
    Feb 2009
    Beans
    5

    Smile Re: Clam AV update fails

    Quote Originally Posted by Pidster View Post
    Had the same problem.. the daemon was running in processes.

    had to ---> sudo /etc/init.d/clamav-freshclam stop

    then sudo freshclam -v

    and it worked for me.

    then restart the daemon with

    sudo /etc/init.d/clamav-freshclam start

    after it was restarted i was able to run the freshclam -v command with no more porblems. thinking it might have been locked up..??
    This worked great! Thanks!

  8. #8
    Join Date
    Aug 2007
    Location
    Christchurch, New Zealand
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Smile Re: Clam AV update fails

    Fixed it for me as well... saved me rebooting. Thanks

    Quote Originally Posted by Pidster View Post
    Had the same problem.. the daemon was running in processes.

    had to ---> sudo /etc/init.d/clamav-freshclam stop

    then sudo freshclam -v

    and it worked for me.

    then restart the daemon with

    sudo /etc/init.d/clamav-freshclam start

    after it was restarted i was able to run the freshclam -v command with no more porblems. thinking it might have been locked up..??

  9. #9
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    29,546
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Clam AV update fails

    Hi, this is an old thread so it has been closed, thanks for sharing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •