Page 2 of 14 FirstFirst 123412 ... LastLast
Results 11 to 20 of 138

Thread: [Howto] Install the svn Mplayer under Intrepid Ibex

  1. #11
    Join Date
    Sep 2006
    Beans
    548

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Quote Originally Posted by andrew.46 View Post
    I have found some connection issues with connections to some live streams from the ABC ClassicFM website in Australia. Once connected there was no problem but I saw improvements with compiling my own libraries and compiling MPlayer against these: connecting well almost all of the time.
    Interesting. Is your problem that the RTSP stream will try to connect and then not connect unless you attempt it several times? I occasionally see this problem when mplayer plugin trys to open an embedded RTSP stream in Firefox, but I always assumed the problem was with the stream itself.

    Can I install updated live555 libs independantly without recompiling mplayer? Will they still get used? or do they have to be installed prior to compiling?
    Last edited by mocha; December 30th, 2008 at 06:37 PM.

  2. #12
    Join Date
    Dec 2006
    Beans
    7,315

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi mocha,

    Quote Originally Posted by mocha View Post
    Interesting. Is your problem that the RTSP stream will try to connect and then not connect unless you attempt it several times? I occasionally see this problem when mplayer plugin trys to open an embedded RTSP stream in Firefox, but I always assumed the problem was with the stream itself.
    Yes this is the problem, but I have not used the MPlayer plugin so I am not sure about this one.

    Can I install updated live555 libs independantly without recompiling mplayer? Will they still get used? or do they have to be installed prior to compiling?
    They will need to be installed prior to compiling MPlayer and should be picked up by the configure process:

    Code:
    Checking for LIVE555 Streaming Media libraries ... yes (using /usr/lib/live)
    Details of MPlayer and Live555 can be seen here. You will note on this page that the current advice is to use VLC .

    Andrew
    You think that's air you're breathing now?

  3. #13
    Join Date
    Sep 2006
    Beans
    548

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Quote Originally Posted by andrew.46 View Post
    Yes this is the problem, but I have not used the MPlayer plugin so I am not sure about this one.
    What do you mean? I thought that the mplayer plugin was using the mplayer that we are building here as its backend. Is the mplayer window in a web browser using its own special mplayer?

  4. #14
    Join Date
    Dec 2006
    Beans
    7,315

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi mocha,

    Quote Originally Posted by mocha View Post
    I thought that the mplayer plugin was using the mplayer that we are building here as its backend. Is the mplayer window in a web browser using its own special mplayer?
    No it is the same MPlayer that the plugin uses. I was just saying I have no experience myself in using the MPlayer plugin as I have never installed it .

    I would be interested to hear if you build the newer Live555 libraries and experience any difference in your use of streams.

    All the best,

    Andrew
    You think that's air you're breathing now?

  5. #15
    Join Date
    Sep 2008
    Location
    Bangalore,India
    Beans
    982
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    hey thanks for those commands,i got it,now i am playing mkv file,don't know how,yesterday it din't work!!!!!!!gud one

    abhilash@abhi:~$ mplayer mplayer /media/SONGS/Film/*.mkv
    MPlayer dev-SVN-r28208-4.2.4 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Pentium(R) D CPU 2.66GHz (Family: 15, Model: 4, Stepping: 7)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

    Playing mplayer.


    Playing /media/SONGS/Film/Untraceable.2008.DVDRip.x264.Adz-300MB.mkv.
    [mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
    [mkv] Track ID 2: audio (A_AAC), -aid 0, -alang und
    [mkv] Track ID 3: subtitles (S_TEXT/UTF8) "English Subs", -sid 0, -slang eng
    [mkv] Will play video track 1.
    Matroska file format detected.
    VIDEO: [avc1] 640x264 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ================================================== ========================
    ================================================== ========================
    Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
    FAAD: compressed input bitrate missing, assuming 128kbit/s!
    AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
    Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
    ================================================== ========================
    AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 640 x 264 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 2.42:1 - prescaling to correct movie aspect.
    VO: [x11] 640x264 => 640x264 Planar YV12
    [swscaler @ 0x895d0c0]using unscaled yuv420p -> rgb32 special converter
    [Mixer] No hardware mixing, inserting volume filter. 5% 1.7% 13
    ===== PAUSE =====
    Last edited by abhilashm86; December 31st, 2008 at 01:15 PM.
    Abhilash Muthuraj-views
    I always believe that Linux,
    "In a world of no walls or fences, we don't need WINDOWS or GATES"
    New to Ubuntu??

  6. #16
    Join Date
    Jan 2007
    Beans
    30
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    great guide but i get this error with exit code 1:
    mplayer -noquiet -nofs -sub-fuzziness 1 -identify -msglevel demux=6 -slave -vo xv, -zoom -nokeepaspect -framedrop -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 62914572 -monitorpixelaspect 1 -subfont-autoscale 1 -subfont-text-scale 5 -subcp ISO-8859-1 -subpos 100 -contrast 0 -brightness 0 -hue 0 -saturation 0 -nocache -osdlevel 0 -vf-add screenshot -channels 2 /home/jordan/Desktop/[gg]_Maria+Holic_-_01_[Pre-Airing]_[8AA4255B].mkv

    MPlayer dev-SVN-r28216-4.3.2 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 4, Stepping: 1)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    Unknown option on the command line: -stop-xscreensaver
    Error parsing option on the command line: -stop-xscreensaver

  7. #17
    Join Date
    Dec 2006
    Beans
    7,315

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi IronFox,

    Quote Originally Posted by IronFox View Post
    great guide but i get this error with exit code 1:
    [...]
    MPlayer dev-SVN-r28216-4.3.2 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 4, Stepping: 1)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    Unknown option on the command line: -stop-xscreensaver
    Error parsing option on the command line: -stop-xscreensaver
    Can I ask that you try to play your file from the commandline? I am running the same svn version as you and the option works fine:

    Code:
    andrew@skamandros:~/Desktop$  mplayer -stop-xscreensaver 100_0057.MOV 
    MPlayer dev-SVN-r28216-4.3.2 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Core(TM)2 CPU         T5500  @ 1.66GHz (Family: 6, Model: 15, Stepping: 2)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    
    Playing 100_0057.MOV.
    libavformat file format detected.
    [lavf] Video stream found, -vid 0
    [lavf] Audio stream found, -aid 1
    VIDEO:  [jpeg]  640x480  24bpp  14.991 fps    0.0 kbps ( 0.0 kbyte/s)
    Clip info:
     comments: EASTMAN KODAK COMPANY  KODAK M853 ZOOM DIGITAL CAMERA
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffmjpeg] vfm: ffmpeg (FFmpeg MJPEG decoder)
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [pcm] Uncompressed PCM audio decoder
    AUDIO: 11025 Hz, 1 ch, u8, 0.0 kbit/0.00% (ratio: 0->11025)
    Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
    ==========================================================================
    AO: [oss] 11025Hz 1ch u8 (1 bytes per sample)
    Starting playback...
    VDec: vo config request - 640 x 480 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 3)
    Movie-Aspect is undefined - no prescaling applied.
    VO: [xv] 640x480 => 640x480 Planar YV12 
    A:  15.0 V:  14.9 A-V:  0.018 ct: -0.027   0/  0  8%  1%  0.3% 2 0
    which I suspect means a question for RVM if he is around, this is probably a question related to smplayer? As a start perhaps you could un-check the following option in smplayer:

    SMPlayer --> Options --> Preferences --> General --> Video --> Disable Screensaver

    Andrew
    Last edited by andrew.46; January 1st, 2009 at 02:30 AM.
    You think that's air you're breathing now?

  8. #18
    Join Date
    May 2007
    Beans
    563
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    If mplayer doesn't recognize the -stop-xscreensaver option I guess it's because it hasn't been compiled correctly (missing development libraries).
    Developer of SMPlayer.

  9. #19
    Join Date
    Jan 2007
    Beans
    30
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    from the command line i get the same error:

    root@jordan-laptop:/home/jordan/Desktop# mplayer -stop-xscreensaver \[gg\]_Maria+Holic_-_01_\[Pre-Airing\]_\[8AA4255B\].mkv
    MPlayer dev-SVN-r28216-4.3.2 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 4, Stepping: 1)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    Creating config file: /root/.mplayer/config
    Unknown option on the command line: -stop-xscreensaver
    Error parsing option on the command line: -stop-xscreensaver

    BUT when I run it from the command line with no arguments its seems to work, though im not getting a video window (should I).

    and when i uncheck the disable screensaver box":

    MPlayer dev-SVN-r28216-4.3.2 (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 4, Stepping: 1)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    Unknown option on the command line: -nostop-xscreensaver
    Error parsing option on the command line: -nostop-xscreensaver

    When I compiled the libraries I didnt get any errors. But when I try the headers I get:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    gettext is already the newest version.
    gettext set to manually installed.
    html2text is already the newest version.
    html2text set to manually installed.
    intltool-debian is already the newest version.
    intltool-debian set to manually installed.
    libartsc0 is already the newest version.
    libartsc0 set to manually installed.
    libaudio2 is already the newest version.
    libaudio2 set to manually installed.
    libenca0 is already the newest version.
    libenca0 set to manually installed.
    libfaac0 is already the newest version.
    libfaac0 set to manually installed.
    libfreebob0 is already the newest version.
    libfreebob0 set to manually installed.
    libggi-target-x is already the newest version.
    libggi-target-x set to manually installed.
    libggi2 is already the newest version.
    libggi2 set to manually installed.
    libgii1 is already the newest version.
    libgii1 set to manually installed.
    libgii1-target-x is already the newest version.
    libgii1-target-x set to manually installed.
    libglide2 is already the newest version.
    libglide2 set to manually installed.
    libjack0 is already the newest version.
    libjack0 set to manually installed.
    liblzo2-2 is already the newest version.
    liblzo2-2 set to manually installed.
    libmad0 is already the newest version.
    libmad0 set to manually installed.
    libmail-sendmail-perl is already the newest version.
    libmail-sendmail-perl set to manually installed.
    libmp3lame-dev is already the newest version.
    libmp3lame0 is already the newest version.
    libmpcdec3 is already the newest version.
    libmpcdec3 set to manually installed.
    libopenal1 is already the newest version.
    libopenal1 set to manually installed.
    libsvga1 is already the newest version.
    libsvga1 set to manually installed.
    libsys-hostname-long-perl is already the newest version.
    libsys-hostname-long-perl set to manually installed.
    libxvidcore4 is already the newest version.
    libxvidcore4 set to manually installed.
    libxvmc1 is already the newest version.
    libxvmc1 set to manually installed.
    po-debconf is already the newest version.
    po-debconf set to manually installed.
    zlib1g-dev is already the newest version.
    zlib1g-dev set to manually installed.
    E: Couldn't find package libamrnb-dev

    It seems I cant find libamrnb-dev and libamrwb-dev but all others are installed
    Last edited by IronFox; January 1st, 2009 at 09:25 AM. Reason: added info

  10. #20
    Join Date
    Dec 2006
    Beans
    7,315

    Re: [Howto] Install the svn Mplayer under Intrepid Ibex

    Hi IronFox,

    I suspect that as RVM has suggested you do not have all the 'dev' libraries installed. Compounding this problem you do not have the Medibuntu Repository enabled: this is the home of the amr dev files amongst others. Can you firstly check that you have the Universe, Multiverse, Main and Restricted Repositories enabled? Details of how to go about this can be seen in the Community Docs:

    https://help.ubuntu.com/community/Repositories/Ubuntu

    Can you enable the Medibuntu Repositories as well? Details of this can be seen here:

    https://help.ubuntu.com/community/Medibuntu

    When this is all done can you run:

    Code:
    $ sudo apt-get update && sudo apt-get upgrade
    and following this load the entire list of dev files into the terminal and reinstall, as per the guide, and with this hopefully successful run 'svn update' and compile MPlayer again. I notice you have only given about a third of the dev files in your post, is this edited a little or did you miss some?

    Hopefully these steps will rectify the problem and you can start to enjoy both MPlayer and SMPlayer .

    All the best,

    Andrew

    Edit: BTW You are not running this all as root are you? Just logon as an unpriviledged user if this is the case and use sudo where required.
    Last edited by andrew.46; January 1st, 2009 at 12:53 PM.
    You think that's air you're breathing now?

Page 2 of 14 FirstFirst 123412 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •