Page 10 of 12 FirstFirst ... 89101112 LastLast
Results 91 to 100 of 115

Thread: RTL8111/RTL8168 Network Connection Fix

  1. #91
    Join Date
    Apr 2007
    Location
    Gijón, Asturias (Spain)
    Beans
    32
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: RTL8111/RTL8168 Network Connection Fix

    It's good news, thank you.

    I will try them soon.

  2. #92
    Join Date
    Nov 2009
    Beans
    5

    Re: RTL8111/RTL8168 Network Connection Fix

    OS: Ubuntu 11.10 x86_64, kernel: 3.0.0-12-generic
    Motherboard:GA-Z68A-D3-B3
    Driver version: r8168-8.026.00

    Before it, network worked but was terrifically unstable (from 5% up to 60% packet loss from time to time)

    Solution works fine for me, Thanx a lot!

    But it really strange that problem still exist after three years.
    Last edited by IOException; November 17th, 2011 at 10:44 PM.

  3. #93
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,271
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: RTL8111/RTL8168 Network Connection Fix

    Check the mtu-value of your ISP and add it to the network-manager applet instead of "Automatic"

  4. #94
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Smile Re: RTL8111/RTL8168 Network Connection Fix

    Quote Originally Posted by IOException View Post
    But it really strange that problem still exist after three years.
    It seems that the bug has finally been fixed in kernel 3.1.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  5. #95
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,271
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: RTL8111/RTL8168 Network Connection Fix

    Quote Originally Posted by ratcheer View Post
    It seems that the bug has finally been fixed in kernel 3.1.

    Tim
    I hope so.

  6. #96
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: RTL8111/RTL8168 Network Connection Fix

    Quote Originally Posted by praseodym View Post
    I hope so.
    All I can say for sure is that I am able to use r8169 in Arch with kernel 3.1.1-1. I had not been able to use it when Arch was still on a 3.0 kernel.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  7. #97
    Join Date
    Aug 2008
    Location
    @home
    Beans
    15
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: RTL8111/RTL8168 Network Connection Fix

    When will kernell 3.1 be released for ubuntu? I doubt if it will be released for 11.10... so fixing is the only option for now...

  8. #98
    Join Date
    Nov 2011
    Beans
    2

    Re: RTL8111/RTL8168 Network Connection Fix

    I got this same problem in 11.10


    ---------------------------------------------------------------

    john@GA-990FXA-UD5:~/Desktop/r8168-8.026.00$ sudo ./autorun.sh
    [sudo] password for john:

    Check old driver and unload it.
    rmmod r8169
    Build the module and install
    Backup r8169.ko
    rename r8169.ko to r8169.bak
    load module r8168
    FATAL: Module r8168 not found.
    Updating initramfs. Please wait.
    update-initramfs: Generating /boot/initrd.img-2.6.38-11-generic-pae
    Completed.
    john@GA-990FXA-UD5:~/Desktop/r8168-8.026.00$ lsmod | grep r816
    john@GA-990FXA-UD5:~/Desktop/r8168-8.026.00$
    -----------------------------------------

    Any solutions?

    many thanks

  9. #99
    Join Date
    Nov 2011
    Beans
    2

    Re: RTL8111/RTL8168 Network Connection Fix

    it always says:


    FATAL: Module r8168 not found.


    and now i dont have internet

    please i need help

  10. #100
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: RTL8111/RTL8168 Network Connection Fix

    First, the current driver is r8168-8.026.00. 24 and 25 work, but 26 is probably the one you should use. With earlier versions, the Makefile needed a slight modification for kernels higher than 2.x. This latest version seems to have accounted for any kernel version.

    1) sudo depmod -a

    2) Add "blacklist r8169" to /etc/modprobe.d/blacklist.conf

    3) Add "r8168" to /etc/initramfs-tools/modules

    4) In the driver directory, run "sudo ./autorun.sh"

    5) Run "sudo update-initramfs -v -u -k `uname -r`

    Note that uname -r is enclosed in grave accent marks, not quotation marks.

    Reboot. After you're back up, run "sudo lspci -v" to make sure that r8168 is the driver in use.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

Page 10 of 12 FirstFirst ... 89101112 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •