Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 35

Thread: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8.1

  1. #11
    Join Date
    Dec 2008
    Beans
    36
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    Quote Originally Posted by kevdog View Post
    Try this post if you need a working ath9k driver. For now just forget about madwifi. Go with ath9k.
    http://ubuntuforums.org/showpost.php...62&postcount=3
    according to that page, the ath9k was included in the stable release of 8.1 and the alpha releases before it.

    if i have the ath9k on my machine what do i have to do to now?

    also, when i go to system > admin > hardware drivers: i get a message that says "no proprietary drivers are in use on this system."

    i see the same exact thing on regular ubuntu 8.1 .

    no wireless interface upon bootup, or any extentions.
    Last edited by NoobBiscUiT; December 31st, 2008 at 07:48 PM. Reason: confusion

  2. #12
    Join Date
    May 2008
    Beans
    2,526

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    Ok, 8.10 comes with ath9k. I blacklisted ath5k so there wouldn't be a conflict between the 2 trying to control the card. I boot using the 2.6.27-7 kernel. And it works good.

    If I boot with the 2.6.27-9 kernel the wifi keeps dropping. Keep in mind that I don't have the same card as you but mine is in the same list of cards supported by ath9k so I would think that yours would work as well.

    I'll go back thru the thread and see where you're at.
    Ultimate Edition Links

  3. #13
    Join Date
    Dec 2008
    Beans
    36
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    ok cool thanks

    these ubuntu updates are taking forever..

    i will blacklist ath5k in the meantime.

    if i use the ath9k however, will it be reverse compatible?
    i will still be able to connect to b/g wireless networks right?

    assuming this works..

  4. #14
    Join Date
    May 2008
    Beans
    2,526

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    Quote Originally Posted by 2hot6ft2 View Post
    I would also try kernel 2.6.27-7 as mine is in that list and mine works with that kernel and ath9k. Mine is the AR5009 and has the AR928X chipset. But it drops the connection if I use kernel 2.6.27-9.

    Code:
    sudo apt-get install linux-backports-modules-intrepid-generic
    Replace intrepid with hardy if you're on hardy
    And you replied with
    Quote Originally Posted by NoobBiscUiT View Post
    so should i replace my kubuntu intrepid distro w/ hardy then?
    i did your "sudo apt-get install linux-backports-modules-intrepid-generic" command and nothing came up,
    likely because im on intrepid?

    afterword, i shouldn't blacklist anything then.

    i should have ath5k, ath9k, mac80211 non-blacklisted.
    No. You have intrepid so you would use the command as it is without changing anything. Changing the command to hardy would be uded IF you were on Hardy which you're not. Nothing to do with changing distros.
    Quote Originally Posted by NoobBiscUiT View Post
    also what should i do if i cannot find the wireless card at all?
    like with lspci, or will it show up after i compile these drivers.

    additionally what method should i use to build (install) the drivers since i don't have to blacklist anything.
    That would be used IF it's a pci card There should be NO building of anything it should already be in the system.

    As I said in my last post I did blacklist ath5k in the /etc/modprobe.d/madwifi file. That is the only thing I blacklisted.
    Quote Originally Posted by NoobBiscUiT View Post
    is the ath9k that i am going to compile from that link different from the one included in a fully updated version of kubuntu 8.1?

    also, when i compile drivers from somewhere i should get a wireless device to show up in ifconfig?

    i dont have one now.. even though the card is plugged into the laptop correctly w/ antennas and everything


    so confused..

    i have ath9k on my laptop right now, and ath5k because it is included in kubuntu 8.1.
    maybe something will change after i finish these 220 updates?
    You shouldn't have to compile anything. And you say the card is plugged in, and that it's a laptop. Does that mean it's a usb?

    If it's usb then you wouldn't use lspci but would use lsusb to show the usb devices.

    Hmmm, now where are we....
    Ultimate Edition Links

  5. #15
    Join Date
    May 2008
    Beans
    2,526

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    Quote Originally Posted by NoobBiscUiT View Post
    if i use the ath9k however, will it be reverse compatible?
    i will still be able to connect to b/g wireless networks right?

    assuming this works..
    First there was madwifi which became ath5k which is becoming ath9k if I've followed it right. Yes it would be backwards compatible.

    By the way you said you blacklisted ath5k.ko and ath9k.ko as I understand the way things work if it ends with .ko it is either the kernel or has something to do with the kernel so I wouldn't blacklist anything with that extension unless someone would care to correct me on that.
    Ultimate Edition Links

  6. #16
    Join Date
    May 2008
    Beans
    2,526

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    Another thing. Now I see you're using Kubuntu. In that case I think it would be.
    Code:
    sudo aptitude install linux-backports-modules-intrepid-generic
    Instead of
    Code:
    sudo apt-get install linux-backports-modules-intrepid-generic
    Just another example of why it's so important to give a lot of info about your system when asking for help, so you can get the right answers the first time.
    Ultimate Edition Links

  7. #17
    Join Date
    Dec 2008
    Beans
    36
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    ok cools thanks, i have not blacklisted anything yet and i will just do ath5k when this is done

    i will run that command also, for intrepid.

    my lsusb outpus says nothing except for linux root hubs and my microdia built in webcam..

    it's a pci minicard, like the tiny ones.

    i dont think having the antennas reversed would cause it to be invisible to the system would it? i know i have them connected right though.. although it's a n card and i only have 2 antennas on it b/c my old one just had 2.

  8. #18
    Join Date
    May 2008
    Beans
    2,526

    Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    Quote Originally Posted by NoobBiscUiT View Post
    ok cools thanks, i have not blacklisted anything yet and i will just do ath5k when this is done

    i will run that command also, for intrepid.

    my lsusb outpus says nothing except for linux root hubs and my microdia built in webcam..

    it's a pci minicard, like the tiny ones.

    i dont think having the antennas reversed would cause it to be invisible to the system would it? i know i have them connected right though.. although it's a n card and i only have 2 antennas on it b/c my old one just had 2.
    So it's a mini pci card and is internal then the lspci would be correct. It has 3 connectors making it a N-1 card. The antennas, hmmm, I don't know, but I know they're labeled to help keep you from hooking them up wrong. I've heard of problems with those. Cross your fingers.
    Ultimate Edition Links

  9. #19
    Join Date
    Dec 2008
    Beans
    36
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Thumbs down Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    ok so i followed all the steps and did that script, but my ifconfig output still shows nothing?..

    should i do a modprobe ath_pci?
    maybe that would help...?

    i know i have the antennas connected right so that should not be the problem.

    is there such thing as an incompatible wireless card, with my motherboard?




    these guys got it working w/ a different laptop but i dont really get how?..
    http://www.phoronix.com/scan.php?pag...e_ar5418&num=2

    i asked them how they did it here:
    http://www.phoronix.com/forums/showthread.php?p=57004
    Last edited by NoobBiscUiT; January 1st, 2009 at 04:08 AM.

  10. #20
    Join Date
    Dec 2008
    Beans
    36
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Thumbs down Re: Atheros AR5008/Gigabyte GN-WI06N-RH driver install problems, Dell Mini, Kubuntu 8

    i just followed the instructions here: http://bbechdol.wordpress.com/2008/0...4/#comment-353 and i get nothing after doing every step...

    and i dont get why i have a red face next to this post :/


    should i just switch to ubuntu 7.4?
    Last edited by NoobBiscUiT; January 5th, 2009 at 05:12 PM. Reason: i have no idea

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •