Page 1 of 8 123 ... LastLast
Results 1 to 10 of 79

Thread: Success! Broadcom Wireless Connection Through WPA2

  1. #1
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Success! Broadcom Wireless Connection Through WPA2

    Note: Bug reported fixed! for NM 0.8 in Karmic per Tony Espy (9-7-09): https://bugs.launchpad.net/ubuntu/+s...er/+bug/377643 They will try to make NM 0.8 available for Jaunty via the Network Manager PPA. No mention of Intrepid.

    This solution was suggested by flatline (and Geof) at:
    Code:
       http://ubuntuforums.org/showthread.php?t=1009180
    Then flatline cross-posted on this thread:
      http://ubuntuforums.org/showthread.php?t=963379&page=10
    post #97 and I answered starting post #100.
    Broadcom BCM 4328 a/b/g/draft-n Wi-Fi Adaptor connected through WPA2 TKIP to a Linksys Wireless-N Router WRT160N using Broadcom proprietary "wl" driver (in Hardware Drivers: Broadcom STA wireless driver).

    For the first time since updating to Intrepid I have wireless!

    I'm am one of those experiencing the password box filled with hex after a connection attempt through NetworkManager using WPA2-TKIP encryption. Then over and over again NetworkManager asks for a password and reconnection. I had decided this was a wpa_supplicant certificate issue (and was hoping for a network manager update that would fix it). But it is not.

    I went to gconf editor Applications>System Tools>Configuration Editor. Then I went to system>networking>connections>1>802-11-wireless-security.

    There I saw:
    Code:
    group       [wep40,wep104,tkip,ccmp]
    key-mgmt    wpa-psk
    name        802-11-wireless-security
    pairwise    [tkip,ccmp]
    proto       [wpa,rsn]
    I edited it to look like:
    Code:
    group       [tkip]
    key-mgmt    wpa-psk
    name        802-11-wireless-security
    pairwise    [tkip]
    proto       [wpa]
    And tried to connect, and it did! I rebooted and tried to connect again. And it did. I guessed at the parameters, knowing what I had set up in my router.

    I right clicked on the NetworkManager applet and went to Edit Connections. I then deleted a duplicate entry and checked the box for automatically connect, since the connection now worked again. I rebooted and the connection failed. Again the password box filled with hex. Again the asking for a password and reconnection. I went back to Gconf editor and found:
    Code:
    group       [wep40,wep104,tkip,ccmp]
    key-mgmt    wpa-psk
    name        802-11-wireless-security
    pairwise    [tkip,ccmp]
    proto       [wpa,rsn]
    I again started editing, and after correcting the second line it automatically connected and so I was left with:
    Code:
    Code:
    group       [tkip]
    key-mgmt    wpa-psk
    name        802-11-wireless-security
    pairwise    [tkip]
    proto       [wpa,rsn]
    I rebooted and it connected automatically and flawlessly.

    Think about it for a minute. Just going into Edit Connections and checking the auto-connect box was enough for NetworkManager to re-add the extraneous, and some clearly erroneous, entries.

    So as long as I don't use NetworkManager to edit connections I'm good to go? I suppose I could experiment further and find out just which of the extraneous entries are the erroneous ones.

    Inspired by the Launchpad bug #78181: https://bugs.launchpad.net/ubuntu/+s...ger/+bug/78181 (Pay particular attention to the posts by manu and Loye Young towards the bottom. Also see bug link by Loye Young: https://bugs.launchpad.net/ubuntu/+s...ta/+bug/192258 (Note: Avahi-autoipd & avahi-etc. along with ifupdown were installed on my system. But dhcdbd (available) and dhclient (not available) were not installed on my system.)) I decided to see if I could narrow down the "erroneous" entries. "Erroneous" at least in my case. Thanks to manu my prime suspect was CCMP.

    I right clicked on the NetworkManager applet and went to Edit Connections. I then selected edit of my wireless connection. I did not change anything, just clicked on OK. I turned off wireless in NM and then turned it back on and the connection failed. Again the password box filled with hex. Again the asking for a password and reconnection.

    I went to gconf editor Applications>System Tools>Configuration Editor. Then I went to system>networking>connections>1>802-11-wireless-security. There I found:
    Code:
    group       [wep40,wep104,tkip,ccmp]
    key-mgmt    wpa-psk
    name        802-11-wireless-security
    pairwise    [tkip,ccmp]
    proto       [wpa,rsn]
    Looks familiar, hmm? So I went to the first line and removed ccmp. Lo and behold the keys mutated into:
    Code:
    auth-alg    <no value>
    group       [wep40,wep104,tkip]
    key-mgmt    wpa-psk
    name        802-11-wireless-security
    pairwise    [tkip,ccmp]
    proto       [wpa,rsn]
    wep-tx-key-idx  <no value>
    and wireless connection was made! So I rebooted. Again wireless connected automatically. I went to gconf editor again and found:
    Code:
    group       [wep40,wep104,tkip]
    key-mgmt    wpa-psk
    name        802-11-wireless-security
    pairwise    [tkip,ccmp]
    proto       [wpa,rsn]
    So deleting ccmp from the group key seems to be the minimum necessary step, at least for me.

    In Gconf editor if you right click on a key there are several options. Among them are "set as default" and "set as mandatory". If one of these two options was selected for the keys that NetworkManager is messing up would this prevent it? In other words could one or the other of these settings block NetworkManager from altering the key? If so which one?

    David-emm on this thread: http://ubuntuforums.org/showthread.php?t=1018168 tried setting the keys in Gconf to "default" and "mandatory". Unfortunately it was a no go. Intrepid/NM objected to his attempts. At this point bab1 joined us and pointed to: http://www.arachnoid.com/linux/Netwo...ger/index.html At this URL Paul Lutus goes through an explanation of NM's architecture and rationale (distribution agnostic). bab1 then explains that NM is not very flexible at this point and it's algorithm (creating values "on the fly" from HAL and dBus inputs) doesn't accept all user input.

    The upshot, for us, of all this is that this workaround using Gconf editor is the best we're going to do for now. We will have to wait for another version of NM that is more flexible and accepts more user input. Maybe inputs through dBus editing? We may be waiting a while.

    Addendum 1:
    For those of you who's issues look more like timing issues, check out this bug report:
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/263963
    At the bottom, Alexander Sack points you to the latest NM PPA packages (0.7 final) that address some driver timing issues at:
    https://edge.launchpad.net/~network-manager/+archive

    Addendum 2:
    I feel compelled to report other strange behavior I have observed. This may bear on the fundamental problem of networkmanager and be related to the bug reports above. After the system is up a while I can no longer grep useful information from dmesg. Instead dmesg in a terminal yields:
    Code:
    [31195.841730] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    [31197.992106] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    [31199.937654] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    [31202.087989] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    [31204.135831] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    [31206.286186] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    [31208.231779] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    [31210.382003] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff8800a44c8840
    going on and on and filling terminal. Looking in System Log shows the same thing filling both kern.log and syslog. You get to watch the output into them real time. A treat. No idea what's causing this behavior. Wireless is working fine.

    Addendum 3:
    As juanhm correctly points out there are additional conditions I neglected to mention:
    When the password is stored in the keyring and network-manager is authorized to access it, the connection works flawlessly after rebooting.
    juanhm's bug link:
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/263963
    Bug closed with status changed to: Won't Fix. New bug report opened. The link:
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/377643

    Note: Vista says it's a Broadcom 4321AG a/b/g/draft-n Wi-Fi Adaptor.
    Last edited by Favux; October 12th, 2009 at 04:31 AM. Reason: added juanhm's caveats; added ccmp info.; dmesg behaviour;default, NM arch., NM update; new bug link-bug fix!

  2. #2
    Join Date
    May 2007
    Beans
    33

    Re: Success! Broadcom Wireless Connection Through WPA2

    I went to gconf editor Applications>System Tools>Configuration Editor. Then I went to system>networking>connections>1>802-11-wireless-security.
    this would be super to try to get this wireless networking working

    except

    when I run gconf-editor
    and scroll to >system ..
    there is no 'networking' to edit

  3. #3
    Join Date
    May 2007
    Beans
    33

    Re: Success! Broadcom Wireless Connection Through WPA2

    OK here's what I can see in the configuration editor

    System
    - dns_sd
    - gstreamer
    - http_proxy
    - pkcs11
    - proxy
    - smb
    - storage

    so unless it's because I am used to other distros that allow me to login as 'root' and I'm locked into looking at the options available as 'user' I'm at a loss to see how I can edit this file.

    I did run gconf-editor as 'sudo' but it doesn't provide any more options other than those I have above

  4. #4
    Join Date
    May 2007
    Beans
    33

    Re: Success! Broadcom Wireless Connection Through WPA2

    right, I give up !
    where does this file actually live ?

    If I can find it I can edit it

    I was hoping for a better outcome since last having a run with dapper drake, but Intrepid isn't doing me any 'straight out of the box' favours

  5. #5
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Success! Broadcom Wireless Connection Through WPA2

    Hi saywot,

    I'm sorry, I had the entry in gconf editor just like flatline did. I don't know why you don't have it. As you can see I'm no Gconf editor expert, that's why I'm asking for help on the set as default or mandatory key options.

    OK here's what I can see in the configuration editor

    System
    - dns_sd
    - gstreamer
    - http_proxy
    - pkcs11
    - proxy
    - smb
    - storage
    I have networking right between http_proxy and pkcs11.

    You are running Ubuntu 8.10? Have you installed a firewall? Do you have the Broadcom proprietary driver installed in System>Administration>Hardware Drivers? It's called Broadcom STA wireless driver. I don't know if Ndiswrapper would be different, but it's worth eliminating a variable to find out.

    In Synaptic Package Manager when you do a search on gconf-editor is the box next too it greened, ie installed? You have wireless turned on? It is detecting the signal from your wireless router? You tried to connect to the router through NetworkManager 0.7? You got the kind of message I talked about in the first post about password box filled with hex and asking for password, etc.?

    That's all I can think of off the top of my head. Good luck. I'm so happy to finally again be connected wirelessly, I hope you can join me.
    Last edited by Favux; December 14th, 2008 at 05:18 PM.

  6. #6
    Join Date
    Nov 2007
    Location
    Okieville, USA
    Beans
    3,178
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Success! Broadcom Wireless Connection Through WPA2

    Quote Originally Posted by Favux View Post
    Do you have the Broadcom proprietary driver installed in System>Administration>Hardware Drivers? It's called Broadcom STA wireless driver. I don't know if Ndiswrapper would be different, but it's worth eliminating a variable to find out.
    I only needed ndiswrapper before 8.10 on my Brodcomm 43xx card. 8.10 solved all my wireless problems. I do have the w|, however.
    MCP, A+/Linux+ Certified IT Technician
    System Specs | Dress up your "Super Button" FREE
    "If sometimes you can't be good, then be VERY good at being naughty!"

  7. #7
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Success! Broadcom Wireless Connection Through WPA2

    Hi theozzlives,

    When the Broadcom proprietary driver came out, that's when I was finally able to connect wirelessly in Hardy. I didn't bother with ndiswrapper because I saw "wl" was in pre-release and I just waited for it. It took longer than I had hoped for though.

    When I upgraded to 8.10 Intrepid, that's when I lost wireless. I spent a lot of time and effort and got nowhere, including installing Wicd etc. Like I said in my first post I finally decided it was a wpa_supplicant certificate issue and decided to wait for a NetworkManager update that would fix it.

    So I was surprised this worked. I think it shows it was a NetworkManager 0.7 problem all along. I saw in a Launchpad bug report where one of the Ubuntu developers had miscommunicated with another one and they had accidently merged two different versions of NetworkManager. I probably should have paid more attention to that report.

  8. #8
    Join Date
    May 2007
    Beans
    33

    Re: Success! Broadcom Wireless Connection Through WPA2

    You are running Ubuntu 8.10? Have you installed a firewall? Do you have the Broadcom proprietary driver installed in System>Administration>Hardware Drivers? It's called Broadcom STA wireless driver. I don't know if Ndiswrapper would be different, but it's worth eliminating a variable to find out.

    In Synaptic Package Manager when you do a search on gconf-editor is the box next too it greened, ie installed? You have wireless turned on? It is detecting the signal from your wireless router? You tried to connect to the router through NetworkManager 0.7? You got the kind of message I talked about in the first post about password box filled with hex and asking for password, etc.?
    - Yes it is Intrepid Ibex
    - No I don't run a local (software) firewall
    - Yes I have activated the Broadcom Drivers
    - Yes the 'light' on the laptop that indicates wireless is on, is on
    - I have only run gconf-edotor from a terminal as the SU so since I get it to open I am assuming that it's installed
    - I am using whatever version of NetworkManager came installed on the 8.10 disc (the installation is a day old)
    - I'm pretty sure that when you enter a 'human-readable' passkey it is translated into a 'machine-readable' hex key otherwise the passwords would be as easy to crack as lower levels of wireless security

  9. #9
    Join Date
    May 2007
    Beans
    33

    Re: Success! Broadcom Wireless Connection Through WPA2

    I might ask the network manager (the person, not the programme) if they'll accept tkip AND AES cerification

  10. #10
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Success! Broadcom Wireless Connection Through WPA2

    Hi saywot,

    - I have only run gconf-edotor from a terminal as the SU so since I get it to open I am assuming that it's installed
    Why? When it is clear from context that both flatline and I are talking about using it through the Ubuntu gui? Are you running a server install?
    - I'm pretty sure that when you enter a 'human-readable' passkey it is translated into a 'machine-readable' hex key otherwise the passwords would be as easy to crack as lower levels of wireless security
    Sure, when transmitted. Not when authorized user looking at it on gui. Then should be blanked out like standard password, and the # of blanked out digits shoould be the same as the password's. I don't think you're talking about the same bug as I am, because you should have instantly recognized the description. There are multiple posts on the forum reporting the same bug. The bug I've seen posted involves WPA2 and often WPA2-TKIP

    I'm thinking there isn't a "networking" in gconf because you haven't really established an attempt to connect to the router that's been recognized by networkmanager. Either through networkmanager's edit connections or network configuration.

Page 1 of 8 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •