Page 1 of 4 123 ... LastLast
Results 1 to 10 of 365

Thread: HOWTO: Gaim 2.0 CVS - .deb inside

Hybrid View

  1. #1
    Join Date
    Apr 2005
    Location
    Brazil
    Beans
    479
    Distro
    Ubuntu 7.04 Feisty Fawn
    Yo fellows.. i m very happy today.. i ve been waiting for the new release of gaim for a long time, tough it isnt released yet, i just compiled the cvs version, and its great, so as i m a good guy and now i m in a good mood i m writing this quick guide to help you install gaim 2.0 from cvs, or if your lazy just got my .deb.

    Screenshot:


    First of all, remove your gaim 1.5:

    Code:
    sudo apt-get remove gaim
    Dont mind about the ubuntu-desktop, kubuntu-desktop, or kubuntu-desktop, they are just meta packages.

    if you want to use MSN, do this:

    Code:
    sudo apt-get install libgnutls11-dev
    I dont know ALL the dependencies, so if you miss something, post here so we can find out what is missing, i had everything except the libgnutls above.

    If you are lazy, just grab the deb:

    http://xgn.com.br/fabio/gaim_2.0.0cvs2-1_i386.deb

    if you want to compile yourself, here we go:

    ps: Ripped from: http://gaim.sourceforge.net/downloads.php

    Step 1. Check out the source

    Run the following commands in a directory that you have write access to (such as your home directory):

    Code:
    cvs -d ':pserver:anonymous@cvs.sourceforge.net:/cvsroot/gaim' login
    (Just hit enter for the password)
    cvs -z3 -d ':pserver:anonymous@cvs.sourceforge.net:/cvsroot/gaim' checkout gaim
    You should see it listing all the source files.

    Step 2. Build again

    Once you've checked gaim out of CVS, run the follwing commands:

    Code:
    cd gaim
    sh autogen.sh
    ./configure --enable-gnutls=yes
    If you see any errors here, you haven't installed everything you need. autogen.sh will also run ./configure for you once it's created, if it's created successfully. If you see any errors related to GLib or GTK, you haven't installed the devel packages.

    Now, type:

    Code:
    make
    sudo make install
    Tip: if you want to create a deb and install it instead of the make install, dont type sudo make install, instead type this:

    Code:
    sudo apt-get install checkinstall
    The type:

    Code:
    sudo checkinstall
    it you ask you to fill some information, fill them out, and it will install the deb.

    Now some tips by bored2k:

    If you want to enable sounds in gaim, do this:

    Code:
    sudo apt-get install esound-clients
    Now in the sound preferences of you gaim, chose metod: command, and fill the command field with: esdplay %s

    Sugestions by foxy123:

    If you want sound support, you need libao:

    Code:
    sudo apt-get install libao-dev
    If you need spellchecking support, you need libgtkspell:

    Code:
    sudo apt-get install libgtkspell-dev
    Enjoy
    Last edited by sapo; December 11th, 2005 at 12:53 AM.

  2. #2
    Join Date
    Apr 2005
    Location
    Canada
    Beans
    245
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    Don't you need to do
    Code:
    ./autogen.sh
    before ./configure ?

  3. #3
    Join Date
    Jan 2005
    Location
    Signa, Florence
    Beans
    255
    Distro
    Hardy Heron (Ubuntu Development)

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    some screen or list of new features?
    iAc alias Lizardking - Ubuntu Artwork Team
    web: www.iacopomasi.net
    mail: iacopo.masi@gmail.com

  4. #4
    Join Date
    Apr 2005
    Beans
    1,395

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    libgnutls10-dev wants to remove a lot of KDE dev packages which are used to build amarok from svn

  5. #5
    Join Date
    Apr 2005
    Beans
    1,395

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    OK, several suggestions:

    1.
    if you want to use MSN, do this:
    Code:
    sudo apt-get install libgnutls10-dev
    Ubuntu official package is libgnutls11, you do not need 10. So do
    Code:
    sudo apt-get install libgnutls11-dev
    2. If you want sound support, you need libao:
    Code:
    sudo apt-get install libao-dev
    3. If you need spellchecking support, you need libgtkspell:
    Code:
    sudo apt-get install libgtkspell-dev

  6. #6
    Join Date
    Apr 2005
    Location
    Brazil
    Beans
    479
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    Thanx guys, i ll add those to the howto

    I dont know if you need to type autogen.sh first before the ./configure, do you need it?

  7. #7
    Join Date
    Dec 2005
    Beans
    49

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    Quote Originally Posted by foxy123
    OK, several suggestions:

    1.

    Ubuntu official package is libgnutls11, you do not need 10. So do
    Code:
    sudo apt-get install libgnutls11-dev
    2. If you want sound support, you need libao:
    Code:
    sudo apt-get install libao-dev
    3. If you need spellchecking support, you need libgtkspell:
    Code:
    sudo apt-get install libgtkspell-dev

    That worked for me, thanks foxy123
    ..yeah, gaim2 is pretty nice.
    But now synaptic keeps wanting to reinstall gaim1.5
    There must be some way to mask that version of gaim, but
    Im too new to ubuntu to know how yet. meh.

  8. #8
    Join Date
    Nov 2005
    Location
    Pune, India
    Beans
    838
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    you forgot a very simple command if it's a deb
    Code:
    dpkg -i gaim2.0whatever.deb
    , this needs to be part of the howto on the 1st page as well as the amsn & esounds thing which is on the 2nd page. Btw was able to install the default gaim2.0cvs*.deb without any issues. The sound & other stuff whenever u update then will do that. Thanx for that.
    Last edited by ShirishAg75; December 24th, 2005 at 10:29 PM.
    Registered Linux user #468829

    http://flossexperiences.wordpress.com

  9. #9
    Join Date
    Jun 2005
    Location
    Belgium
    Beans
    112
    Distro
    Ubuntu 10.04 Lucid Lynx

    Autoreply ?

    Just a question: is there an auto-reply (plugin) for the MSNnetwork?

  10. #10
    Join Date
    Apr 2005
    Location
    Canada
    Beans
    245
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Gaim 2.0 CVS - .deb inside

    I followed step by step your howto but
    I have the following problem when I do
    Code:
    $make
    (...)
    ../libtool: line 1654: cd: NONE: No such file or directory
    libtool: link: cannot determine absolute directory name of `NONE'
    make[3]: *** [gaim] Erreur 1
    (...)
    Do you have any idea ???

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •