Results 1 to 10 of 10

Thread: [SOLVED] Feisty and Console Emulators

  1. #1
    Join Date
    Sep 2007
    Beans
    95

    [SOLVED] Feisty and Console Emulators

    Im trying to install an emulator, zsnes151src.tar.bz2 OR ZSNES.
    Ive been going off this site for handling tar balls...

    http://www.tuxfiles.org/linuxhelp/softinstall.html

    When I get to step 3, running the make command my terminal says this..

    make: *** No targets specified and no makefile found. Stop.

    even though there are makefiles in the folder...

    Ive tried skipping to step 4 and running su...

    su: Authentication failure
    Sorry.

    and conversly running sudo make install

    Password:
    make: *** No rule to make target `install'. Stop.


    ...and thats it, I got nothing, I dont know what to do, any help at all would be great.
    Last edited by linux.convert; December 11th, 2008 at 04:41 AM. Reason: few additions
    Crunchbang 11 "Waldorf"

  2. #2
    Join Date
    May 2007
    Beans
    1,091

    Re: Feisty and Console Emulators

    when you run ./configure, does it return errors at the end?

  3. #3
    Join Date
    Sep 2007
    Beans
    95

    Re: Feisty and Console Emulators

    yes this...

    configure: error: C compiler cannot create executables
    See `config.log' for more details.
    Crunchbang 11 "Waldorf"

  4. #4
    Join Date
    May 2007
    Beans
    1,091

    Re: Feisty and Console Emulators

    have you installed the package build-essential?

  5. #5
    Join Date
    Jun 2008
    Location
    Denver, CO
    Beans
    89
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: Feisty and Console Emulators

    You might be missing some packages. Try opening a terminal, and running
    Code:
    sudo apt-get install build-essential
    post the output of this command. Also should read the README to see if there are other required packages.

  6. #6
    Join Date
    Jun 2008
    Location
    Denver, CO
    Beans
    89
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: Feisty and Console Emulators

    You will also need to install SDL, libsdl1.2-dev First, if you have it extracted in your home folder (/home/username), rename the folder and the downloaded file. Then open a terminal and run these commands:
    Code:
    sudo apt-get install libsdl1.2-dev build-essential
    cd ~
    wget http://prdownloads.sourceforge.net/zsnes/zsnes151src.tar.bz2
    tar -xvf zsnes151src.tar.bz2
    cd zsnes_1_51/src
    ./configure
    make
    sudo make install
    Post if you get an error any way along the process.
    What you are doing here is changing to your home directory, installing libsdl1.2-dev and build-essential downloading the archive, extracting it, running the configuration utility, making the installer, and then installing it.
    Last edited by cdmike2k8; December 11th, 2008 at 05:34 AM. Reason: added build-essential

  7. #7
    Join Date
    Sep 2007
    Beans
    95

    Re: Feisty and Console Emulators

    I ran everything up to ./configure

    and when I ran it I got this...

    ME@ME-laptop:~/GAMES/EMULATORSnROMS/zsnes_1_51/src$ ./configure
    checking build system type... i686-pc-linux-gnulibc1
    checking host system type... i686-pc-linux-gnulibc1
    checking target system type... i686-pc-linux-gnulibc1
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for gcc... gcc
    checking for C compiler default output file name...
    configure: error: C compiler cannot create executables
    See `config.log' for more details.
    Crunchbang 11 "Waldorf"

  8. #8
    Join Date
    Jul 2007
    Beans
    123

    Re: Feisty and Console Emulators

    Any particular reason you are installing from source rather than through apt?

    The version of zsnes in hardy appears to be the same as you are trying to install (1.510-2)

    sudo apt-get install zsnes

  9. #9
    Join Date
    Mar 2006
    Beans
    8,345

    Re: Feisty and Console Emulators

    @ linux.convert

    Title of your thread suggested that you are runuing Feisty,and that can be source of your problem.Feisty is not suported anymore.Install Hardy if you want LTS or Intrepid as last version.If you don't have separate home partition make one following this guide.If you allready have it just install newer version of Ubuntu on top of it and don't format home partition.

  10. #10
    Join Date
    Aug 2008
    Beans
    85

    Re: [SOLVED] Feisty and Console Emulators

    I believe OP says in the topic he's using Feisty, not Hardy. Feisty repos are no more as of October.

    EDIT: zvacet beat me to it.
    Last edited by jmcgovern; December 11th, 2008 at 07:08 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •