Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Age of Mythology in Virtual Box

Hybrid View

  1. #1
    Join Date
    Apr 2008
    Beans
    4

    Age of Mythology in Virtual Box

    I'm currently trying to get Age of Mythology to work in Virtual Box. I circumvented the debugger problem by using a no-cd fix, but now when I try to run the game it displays the error message:

    This graphics card is not supported by Age of Mythology.
    Please check http://microsoft.com/games/ageofmythology for a full list of supported graphics cards.
    Age of Mythology will now exit.

    Code:
    Video Card 0: VBoxDisp.dll VirtualBox Graphics Adapter Vendor(0x80EE) Device(0xBEEF)
    Is there some way I can convince Age of Mythology to run on this adapter, or change my adapter so it will register as supported?

  2. #2
    Join Date
    Mar 2008
    Beans
    1

    Re: Age of Mythology in Virtual Box

    same request.. i tried to install the game with wine, but it works badly..

    run it on virtualbox could be THE solution.. but there's this problem with the graphic card..

  3. #3
    Join Date
    Sep 2006
    Beans
    3,165
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Age of Mythology in Virtual Box

    it wont work on virtualbox, however it might work on vmware which has a little 3d support

    # 16 MB 3D video card is required; 32 MB video card is recommended.

  4. #4
    Join Date
    Apr 2008
    Beans
    4

    Re: Age of Mythology in Virtual Box

    I have the required graphics card on my main machine, the problem is changing the Adapter so that Age of Mythology recognizes it as a supported graphics card. It seems like if I just installed a different driver, it should work fine.

  5. #5
    Join Date
    Nov 2006
    Location
    Alpine, Texas
    Beans
    502
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Age of Mythology in Virtual Box

    Quote Originally Posted by binbash View Post
    it wont work on virtualbox, however it might work on vmware which has a little 3d support

    # 16 MB 3D video card is required; 32 MB video card is recommended.
    I tried it on vmware in early January 2009. No dice.

  6. #6
    Join Date
    Feb 2010
    Beans
    1

    Re: Age of Mythology in Virtual Box

    Quote Originally Posted by _Arelas_ View Post
    I'm currently trying to get Age of Mythology to work in Virtual Box. I circumvented the debugger problem by using a no-cd fix, but now when I try to run the game it displays the error message:



    Is there some way I can convince Age of Mythology to run on this adapter, or change my adapter so it will register as supported?

    To play with Age of Mythology under vmware (tested successfully under my vmware workstation 7), you must create a file named
    "C:\Program Files\Microsoft Games\Age of Mythology\gfxconfig\0x80EE_virtualbox.gfx" and it will work.

    It's a adaptation of my solution successflly tested under vmware, so you must see the display driver and replace VirutalBox by the vendor (VirtualBox or Sun) and replace month/day/year (9/21/2009 here) by the date of your virtuabox driver.


    In this this file you must put the following lines in "C:\Program Files\Microsoft Games\Age of Mythology\gfxconfig\0x80EE_virtualbox.gfx":
    \[config\]
    Vendor=VirtualBox
    defaultdevice=CyberBladeXP.gfx

    \[knownGoodDriver\]
    Month=9
    Day=21
    Year=2009
    Product=0
    Version=0
    SubVersion=0
    Build=0

    \[device\]
    0xBEEF=CyberBladeXP,CyberBladeXP.gfx

  7. #7
    Join Date
    Apr 2010
    Beans
    3

    Re: Age of Mythology in Virtual Box

    ocozette, I tried your solution but it doesn't work for me. I'm using VirtualBox 3.1.6 and I've enabled both 2D and 3D acceleration of a Windows XP virtual machine. I created a "0x80EE_virtualbox.gfx" file in the gfxconfig and gfxconfig2 folders and paste this inside them:

    \[config\]
    Vendor=VirtualBox
    defaultdevice=CyberBladeXP.gfx

    \[knownGoodDriver\]
    Month=3
    Day=25
    Year=2010
    Product=0
    Version=0
    SubVersion=0
    Build=0

    \[device\]
    0xBEEF=CyberBladeXP,CyberBladeXP.gfx


    However, I still get the "unsupported graphics card" window, with the graphics card being quoted as " 3/25/2010 3.1.6.0". If I replace the "vendor" property to "Sun" or "Sun Microsystems, Inc.", nothing changes. Any ideas?

  8. #8
    Join Date
    Jun 2008
    Beans
    1

    Re: Age of Mythology in Virtual Box

    Quote Originally Posted by DragonQ View Post
    ocozette, I tried your solution but it doesn't work for me. I'm using VirtualBox 3.1.6 and I've enabled both 2D and 3D acceleration of a Windows XP virtual machine. I created a "0x80EE_virtualbox.gfx" file in the gfxconfig and gfxconfig2 folders and paste this inside them:

    \[config\]
    Vendor=VirtualBox
    defaultdevice=CyberBladeXP.gfx

    \[knownGoodDriver\]
    Month=3
    Day=25
    Year=2010
    Product=0
    Version=0
    SubVersion=0
    Build=0

    \[device\]
    0xBEEF=CyberBladeXP,CyberBladeXP.gfx


    However, I still get the "unsupported graphics card" window, with the graphics card being quoted as " 3/25/2010 3.1.6.0". If I replace the "vendor" property to "Sun" or "Sun Microsystems, Inc.", nothing changes. Any ideas?

    In the created file, delete the "\" x that still does not recognize drivers
    In my case I also need to Install the MSXML 4.0
    Everything works ok
    Regards
    Last edited by XNess01; April 13th, 2010 at 08:00 PM. Reason: Convert to English

  9. #9
    Join Date
    Apr 2010
    Beans
    3

    Re: Age of Mythology in Virtual Box

    Thanks, that gets rid of the error message. However, after the game loads I just get a blank screen (same as with Microsoft Virtual PC). Did you do anything else to get it to work?

    EDIT: Never mind, I fixed it using some D3D8 and D3D9 workaround instructions that I found for Windows 2000.
    Last edited by DragonQ; April 18th, 2010 at 08:03 PM.

  10. #10
    Join Date
    Apr 2010
    Location
    Seattle, WA
    Beans
    21
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Age of Mythology in Virtual Box

    This advice may sounds really stupid, but I might try downloading Microsoft VPC 2007, and running that under WINE, and installing AOM on VPC... but idk if that will work

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •