Results 1 to 6 of 6

Thread: Asus F5RL

  1. #1
    Join Date
    Nov 2008

    Asus F5RL


    I, like many F5RL users, have been struggling to get wifi working. Getting to the point of installing the packages but never actually getting the LED to turn on nor actually find any wireless networks to connect to.

    The solution, however, is REALLY SIMPLE.

    You simply need to UNLOAD the asus laptop module!!!!

    sudo modprobe -r asus-laptop

    in terminal. This will enable you to flip the wireless switch on AND connect to networks.

    I do not know whether this will work on a fresh install. I did this after installing fresh 8.10, updating it and then following this guide:

    It should be known that I am not to credit for this. I am simply passing on information found here on the forum and on this website:

    I am new to the Ubuntu community and I dont know how to pass this on to people in charge of the ubuntu wikis and FAQs. It is imperative however that this is published in all appropriate forums and wikis so that Asus owners can enjoy Ubuntu, and so that this bug is fixed, enabling out of the box or at least easier use of Ubuntu on Asus computers.
    Last edited by rock_fredde; December 9th, 2008 at 01:00 PM. Reason: found solution

  2. #2
    Join Date
    Jun 2006
    Ubuntu 6.06

    Exclamation Re: Asus F5RL

    Just a note from my own experience with the asus F5RL.

    Removing this module has not changed anything for me.
    I have the wifi working following the same post and with or without the asus-laptop module, I need to switch off/on the wifi at login screen so it works.

    Still trying to understand the link between the acpid daemon and maybe the stopping of the wifi led.

    Merry christmas.

  3. #3
    Join Date
    Nov 2008
    Ubuntu 9.10 Karmic Koala

    Talking Re: Asus F5RL

    Hey. Thanks loads. I dont know how it happened. But it worked.

    sudo modprobe -r asus-laptop
    FYI I'm using an updated version of Ubuntu Intrepid with ndiswrapper installed with XP32 bit drivers for Atheros 5007EG!!!

  4. #4
    Join Date
    Dec 2007
    Mildura, Australia

    Re: Asus F5RL

    I can't believe it was really that simple!

    This has plagued me for so long, now it's working like a charm. Wireless working flawlessly, LED light going good, switch works properly. Using 9.04. Thank you very much for passing this along, OP!
    Last edited by Sand & Mercury; April 26th, 2009 at 04:38 PM.
    La Dânse Macabre.

    ~ | deviantART profile ~

  5. #5
    Join Date
    Oct 2008

    Re: Asus F5RL

    still nothing on my end, I'm running an Asus F5RL, and have been trying to get my wireless working, i have followed the instruction to the word, amending the source file wget -c
    to its latest version, wget -c, that didn't help.

    i waited until ubuntu 9.04, HUH!! it recognized my wireless cards Atheros as a restricted device but still no dice..
    i did all the previous instruction in 9.04, NOTHING...

    either i'm doing something wrong or i'm missing a command.

    i did the sudo modprobe -r asus-laptop, that only helped turning my wireless LED light on... i love ubuntu, but WTF. just once i'd like to buy system install ubuntu and have it work without me messing with it...

    in desperate need of help, vista really really sucks in comparison, but i have no other solution.....

    Also, i'm facing the same problem with an Acer Inspire One Netbook, Guess what wireless card it has... F***ing Atheros.. same model too...
    Someone Please contact this ****** company and ask them to develop a driver for ubuntu..

  6. #6
    Join Date
    May 2007
    Ukraine, Kyiv
    Kubuntu 11.04 Natty Narwhal

    Re: Asus F5RL

    it worked for me with LED. Thanks for the tip.

    as to wifi on intrepid:
    i did these steps:
    removed ath5k module
    enabled madwifi module
    added 1 to /proc/sys/dev/wifi0/softled
    unloaded madwifi
    loaded ath5k

    bingo! it worked.

    ANOTHER QUESTION from me is Sound.
    I've upgraded to latest ALSA but still my notebook is silent. any ideas?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts