Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Disable touchpad when mouse plugged in

  1. #1
    Join Date
    Dec 2008
    Location
    UK
    Beans
    152
    Distro
    Ubuntu

    Disable touchpad when mouse plugged in

    So, brushing against the touchpad is obviously very annoying and can lead to the cursor jumping around whilst typing, and I nearly always use a usb mouse. So is it possible to have it automatically turn off when mouse is active, and automatically on when mouse not plugged in? The difficulty with disabling touchpad in the system -> preferences -> mouse menu is that if I boot up without a usb mouse, I can't click into the menus!!

    Any ideas appreciated.
    Linux Mint 18/Ubuntu 16.04

  2. #2
    Join Date
    Feb 2009
    Beans
    164

    Re: Disable touchpad when mouse plugged in

    I am very interested in this too. I'm sorry if this is considered o be thread necromancy but the question is very relevant to me.

  3. #3
    Join Date
    Jun 2006
    Beans
    37
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Disable touchpad when mouse plugged in

    Bump this one for me too. I'm new to laptops, and am always touching the derned touchpad with my thumb as I type. I can manually turn it off, but having it automatically shut off when there is a usb mouse is a beautiful idea!

  4. #4
    Join Date
    Mar 2009
    Beans
    1

    Re: Disable touchpad when mouse plugged in

    Bump this one for me too.
    Such an option would be very nice in the mouse control section.

  5. #5
    Join Date
    Mar 2009
    Location
    Right here
    Beans
    14
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable touchpad when mouse plugged in

    This script works in Ubuntu 8.04, 8.10, and 9.04. Just make it executable, add it to your startup applications, and don't look back.

    Basically it detects when a mouse is plugged in (you need to modify the script in one spot to do this - it's documented in the file) and disables the touchpad. Unplugging the mouse then re-enables the touchpad. I've also included a touchpad delay when it's active and you begin typing.

    Hope it helps!
    Attached Files Attached Files

  6. #6
    Join Date
    Dec 2008
    Location
    Buford, GA
    Beans
    20
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Disable touchpad when mouse plugged in

    I know my noob is showing, but how do you make it executable?

    EDIT: Nevermind, I saw that you right-click and in the properties there is a checkbox for making it executable. But I do have another question. I'm assuming that in the line where it says

    if xinput list 'Microsoft Microsoft? 2.4GHz Transceiver v5.0';

    I need to put my mouse's device name, is this correct? If it is, where can I find that?
    Last edited by cmmckoy; June 6th, 2009 at 08:43 AM.

  7. #7
    Join Date
    Dec 2008
    Location
    Buford, GA
    Beans
    20
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Disable touchpad when mouse plugged in

    I read the script all the way this time, saw the thing about xinput list. When I type xinput list, I get this:

    ghost@ghost-laptop:~$ xinput list
    "Virtual core pointer" id=0 [XPointer]
    Num_buttons is 32
    Num_axes is 2
    Mode is Relative
    Motion_buffer is 256
    Axis 0 :
    Min_value is -1
    Max_value is -1
    Resolution is 0
    Axis 1 :
    Min_value is -1
    Max_value is -1
    Resolution is 0
    "Virtual core keyboard" id=1 [XKeyboard]
    Num_keys is 248
    Min_keycode is 8
    Max_keycode is 255
    "AT Translated Set 2 keyboard" id=2 [XExtensionKeyboard]
    Num_keys is 248
    Min_keycode is 8
    Max_keycode is 255
    "Video Bus" id=3 [XExtensionKeyboard]
    Num_keys is 248
    Min_keycode is 8
    Max_keycode is 255
    "Macintosh mouse button emulation" id=4 [XExtensionPointer]
    Num_buttons is 32
    Num_axes is 2
    Mode is Relative
    Motion_buffer is 256
    Axis 0 :
    Min_value is -1
    Max_value is -1
    Resolution is 1
    Axis 1 :
    Min_value is -1
    Max_value is -1
    Resolution is 1
    "HID 04b4:0033" id=5 [XExtensionPointer]
    Num_buttons is 32
    Num_axes is 2
    Mode is Relative
    Motion_buffer is 256
    Axis 0 :
    Min_value is -1
    Max_value is -1
    Resolution is 1
    Axis 1 :
    Min_value is -1
    Max_value is -1
    Resolution is 1
    "SynPS/2 Synaptics TouchPad" id=6 [XExtensionPointer]
    Num_buttons is 12
    Num_axes is 2
    Mode is Relative
    Motion_buffer is 256
    Axis 0 :
    Min_value is 1472
    Max_value is 5472
    Resolution is 1
    Axis 1 :
    Min_value is 1408
    Max_value is 4448
    Resolution is 1


    When I unplugged my USB mouse, the HID 04b4:0033 wasn't there when I ran the xinput list again, so I'm assuming this is my mouse? If so, do I replace 'Microsoft Microsoft? 2.4GHz Transceiver v5.0' with 'HID 04b4:0033'? This is what I have done, and I get this when I run it in the terminal:

    X loaded
    "HID 04b4:0033" id=5 [XExtensionPointer]
    Num_buttons is 32
    Num_axes is 2
    Mode is Relative
    Motion_buffer is 256
    Axis 0 :
    Min_value is -1
    Max_value is -1
    Resolution is 1
    Axis 1 :
    Min_value is -1
    Max_value is -1
    Resolution is 1
    Can't access shared memory area. SHMConfig disabled?
    syndaemon: no process killed


    Can someone help me? I don't know what SHMConfig is, and I don't want to go messing with something unless I know what I'm doing.

  8. #8
    Join Date
    Mar 2009
    Location
    Right here
    Beans
    14
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable touchpad when mouse plugged in

    The HID is the one I would use, yep.

  9. #9
    Join Date
    Mar 2009
    Location
    Right here
    Beans
    14
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Disable touchpad when mouse plugged in

    SHMConfig information can be found on this page a little ways down. It should tell you everything you need to know and how to get it running.

  10. #10
    Join Date
    Jul 2009
    Beans
    2

    Re: Disable touchpad when mouse plugged in

    I followed all the steps but there seems to be a problem with the script. I get this error when I run it.

    Code:
    X loaded
    "Logitech USB RECEIVER"    id=7    [XExtensionPointer]
        Num_buttons is 32
        Num_axes is 2
        Mode is Relative
        Motion_buffer is 256
        Axis 0 :
            Min_value is -1
            Max_value is -1
            Resolution is 1
        Axis 1 :
            Min_value is -1
            Max_value is -1
            Resolution is 1
    Can't access shared memory area. SHMConfig disabled?
    syndaemon: no process killed
    I would LOVE to be able to disable the touchpad. Note: I'm running Linux Mint 7 if that makes a difference.
    Last edited by TheSundering; August 1st, 2009 at 06:01 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •