Results 1 to 3 of 3

Thread: Invalid Raid Superblock Magic

  1. #1
    Join Date
    Nov 2008
    Location
    in the desert
    Beans
    15

    Question Invalid Raid Superblock Magic

    Hello Ubuntu Gurus!

    I get an "Invalid Raid Superblock Magic on sda1" error when I boot up.

    I have...

    ASUS P5Q-EM motherboard (Intel G45 Chipset)
    Two identical sata drives on Software Raid 1
    Bios setting is AHCI for the sata drives
    Ubuntu Intrepid Ibex, Samba fileserver
    Headless fileserver setup

    I get the error message and it drops out of the shell. Sometimes when I wait awhile and reboot from the initramfs prompt it still gives me the "invalid raid superblock magic" error, but it still boots. When it does boots, I check the /proc/mdstat and it says every thing is good with the raid.

    I made edits to the /boot/grub/menu.lst to include the rootdelay=90 on the kernel line, but I still run into the error.

    I did apt-get update and upgrade and still the problem persists. How can I resolve this issue? Please help.

    Thanks.

  2. #2
    Join Date
    Mar 2007
    Beans
    21

    Re: Invalid Raid Superblock Magic

    Quote Originally Posted by sam702 View Post
    Hello Ubuntu Gurus!

    I get an "Invalid Raid Superblock Magic on sda1" error when I boot up.

    I have...

    ASUS P5Q-EM motherboard (Intel G45 Chipset)
    Two identical sata drives on Software Raid 1
    Bios setting is AHCI for the sata drives
    Ubuntu Intrepid Ibex, Samba fileserver
    Headless fileserver setup

    I get the error message and it drops out of the shell. Sometimes when I wait awhile and reboot from the initramfs prompt it still gives me the "invalid raid superblock magic" error, but it still boots. When it does boots, I check the /proc/mdstat and it says every thing is good with the raid.

    I made edits to the /boot/grub/menu.lst to include the rootdelay=90 on the kernel line, but I still run into the error.

    I did apt-get update and upgrade and still the problem persists. How can I resolve this issue? Please help.

    Thanks.
    Did you ever find a way to fix this? I am having the same problem.

  3. #3
    Join Date
    Feb 2007
    Location
    Cameron Park CA USA
    Beans
    4,562
    Distro
    Ubuntu Development Release

    Re: Invalid Raid Superblock Magic

    Hard to say what is causing this. I'd try adding a delay here:

    Edit this file, adding the sleep line after the mount: /usr/share/initramfs-tools/init # to stop a race condition with md. The line numbers may not be the same for your system.

    Code:
       187 maybe_break mount
       188 sleep 10
       189 log_begin_msg "Mounting root file system..."
    Then run this to rebuild the image

    Code:
    sudo /usr/sbin/update-initramfs -uk all
    Let us know if this works.
    Regards, frank, at http://yantrayoga.typepad.com/noname/
    Homebuilt Lian-Li PC-Q33WB, Intel i7-4790K 4.6GHz, SSDs,16G RAM | Dell Laptop 11.6" N3050.
    Oracle VBox w/ WinXP/Win8 running Xara Designer, PaintShopPro, and InDesign CS.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •