Results 1 to 2 of 2

Thread: Furius ISO not working

  1. #1
    Join Date
    Dec 2007
    Ontario, Canada
    Ubuntu 10.04 Lucid Lynx

    Angry Furius ISO not working

    Hey all! Just wondering if anyone else has had this issue. I've been using Furius for WEEKS and it's been flawless. Browse for the CD/DVD image file, click mount. Furius has always mounted the image, loaded it just as if it were an actual CD/DVD placing an icon for it in Nautilus and on the Desktop. Today it does nothing but make an empty folder in my home folder with the name of the iso as the folder label. I have a laptop and a desktop, one using 10.04 and one using 9.10, they both worked perfectly until today.

    What happened??? I'm lost. I wasn't uninstalling or installing anything else, I wasn't messing with settings, and I certainly didn't clone the issue on both computers. Can anyone help get Furius working again? I've removed and reinstalled it on both PC's, no help. AcetoneISO is what I'm using now, it basically does the same thing, only Furius was simpler and worked better....until today. The only thing I did was Ubuntu updates. I love Ubuntu but it's a real kick in the head when stuff like this happens because I have NO CLUE how to fix it (I usually end up formatting and reinstalling everything, I'm not in the mood, everything else is working fine).

    Anyhue, thanks in advance for any help provided.

  2. #2
    Join Date
    May 2007

    Re: Furius ISO not working

    You could try getting the latest version from the developers website: The latest version is which is later than the versions in the Ubuntu repositories.
    Just download the deb installer from there and try that.

    Marcus Furius

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts