Results 1 to 6 of 6

Thread: WLAN on Amilo L1310G in Ubuntu 10.04

Threaded View

  1. #1
    Join Date
    Jul 2010

    WLAN on Amilo L1310G in Ubuntu 10.04

    Untill recently I've been using Ubuntu 8.04 Hardy Heron on my Fujitsu Siemens Amilo L1310G because anything beyond that release failed to work with my wireless adapter, which is an Atheros AR2413 802.11bg NIC. Despite endless googling and trying out supposed fixes, nothing ever seemed to work, untill I tried the very thing that worked on 8.04. Be it with a minor change.

    If the fsaa1655g-fix in this old article worked for you in Ubuntu 8.04 Hardy Heron, the following should work for you in Ubuntu 10.04 Lucid Lynx.

    1. Create a new folder: ~/Downloads/fsaa1655g

    2. Download the tarball and untar in the said folder

    3. Navigate to said folder via terminal:
    cd ~/Downloads/fsaa1655g

    4. Now install the modules via terminal:
    make && sudo make install

    5. Open (what I think is) your former "options"-file:
    sudo gedit /etc/modprobe.d/alsa-base.conf

    6. Scroll down untill you find the following line: "# Prevent abnormal drivers from grabbing index 0". You should find some lines that start with "options". Now add the following:
    options fsaa1655g radio=1
    options ath_pci rfkill=0

    ... and close the window.

    7. Now we'll add the module so it will load at startup, again using a terminal:
    sudo gedit /etc/modules

    8. At the end of the file, add the following:
    ... and close the window.

    Restart your machine and you should be able to use your laptop perfectly.
    Last edited by dmvanloon; July 14th, 2010 at 05:02 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts