Dear all,

I'm starting a new thread after that of which
concerned ubuntu 9.10 on the dell precision M6500.

I have recently fresh-installed ubuntu 10.04 32-bit on my laptop, so I would like to share some impression and report some problems, hoping other people will be able to solve.

First, installation was easily done. The only regret is that the mounting options were not automatically optimized for SSD drive. After googleing, I found that the best for SSD is to mount with option 'relatime', which seems to be like 'noatime' but without the problems it involves for mails.

After first boot, I am proposed to use proprietary drivers for wireless broadcom and NVIDIA card. There i not much help here and for each device, I have two options. I choose the most up-to-date. (STA for broadcom and "version current" for NVIDIA (instead of version 173).

Now, let's see what is NOT working:

- internal microphone: searched in different posts, bugs reports, etc. But I' still unable to make it work.
The strange thing is that sometimes I have no sound at all. Then, I reinstall alsa-backport modules and output works back.
Also, it seems it worked on 9.10 after some updates (see but I heard about nobody having the internal microphone working on ubuntu 10.04. This is a very important bug since we cannot use widely-used softwares like skype, for example.

- logout/restart: sometimes (seems that after reinstalling alsa), the logout/restart does not work properly. Instead, I am just logged out. However, 'sudo shutdown -r now' in a terminal works.

- I had also some experience with freezing at boot / shutdown. I solved this by removing the ubuntu-provided graphic card driver, and keeping only the proprietary one.
Have a look at
What I actually did, was to use synaptics (when hard re-booting), searched for nouveau, and removed it.

- fingerprint reader: ok, this is not that useful, but since my laptop came with this, why not using it.
It seems there are two drivers: thinkfinger and fprint. fprint is the most recent one. Anyway, none of them works and simply do not find device (swipe fingerprint broadcom USH).

- touchpad: under windows 7 (removed completely one hour after I got the laptop), I had lots of possibilities, including pinch zoom, etc. I even had some light in the touchpad when touching a particular zone. None of this is working under ubuntu. Touchpad is a very simple mouse without any "two fingers" options. I also experienced some problems with the touchpad getting crazy and the mouse always going to the left of my screen. It seems synaptics has developped something for this ( it is not implemented on ubuntu 10.04 and I found no way to download/install these drivers.

All the rest seems working fine. Please report is you experienced similar problems and/or found a SOLUTION!