Results 1 to 7 of 7

Thread: 10.04 wma lossless playback problem

  1. #1
    Join Date
    Aug 2006
    Beans
    7

    10.04 wma lossless playback problem

    I have a vast music collection stored as wma lossless files and have just installed Ubuntu 10.04 64bit.
    Nothing seems to play my huge music collection, not Rhythmbox, Amarok (my preferred player) or even VLC.
    Please is there any way I can play these files without having to convert them to a different format?
    I have installed w64 codecs, but this does not work. I am sure that in previous Ubuntu installations I have made these have played, but that may have been under 32 bit.
    Thanks
    James

  2. #2

    Re: 10.04 wma lossless playback problem

    A small number of choices... (other than conversion

    Build and install a 32 bit mplayer that will be able to use w32codecs.
    Takes a little work, had one on my 64 bit karmic and worked quite well.
    Biggest advantage is it will serve as a complete mplayer, either from cli or with various frontends. (the frontends can be 64 bit

    Install wine and a win player that can decode wmal.

    Two examples -

    The smplayer for windows will install and run thru wine and will work with w32codecs (actually it will download the codecs from mplayer if you wish.

    Only takes a few minutes to set up.

    On the downside...
    Doesn't accept drag and drop, nor opening dir.'s of music, though it's simple to set up a desktop or panel drag&drop launcher.

    Not really a music player as far as library.

    Though it does work well with playlist files, (at least I tested .m3u's) so that's a positive. (just drop a .m3u into launcher, it will load all the tracks), easy to create .m3u's for your music.

    Foobar2000

    This works quite well and can manage a library, the current version supports wma with 1 small caveat - you need to have 'windows media runtime files' installed.
    This is easily taken care of - a google search for 'Windows Media Codecs' will prove fruitful - basically you're half-installing wmp 11 for the codecs that will end up in 'system32'

    I wouldn't expect wmp to work, nor would I try - the .exe pictured below installs the runtime files and a set up .exe for wmp
    screen shows file you are after...
    Attached Images Attached Images
    Last edited by mc4man; May 20th, 2010 at 03:06 AM.

  3. #3
    Join Date
    Aug 2006
    Beans
    7

    Re: 10.04 wma lossless playback problem

    The first one sounds best, i.e.,

    Build and install a 32 bit mplayer that will be able to use w32codecs.
    Takes a little work, had one on my 64 bit karmic and worked quite well.
    Biggest advantage is it will serve as a complete mplayer, either from cli or with various frontends. (the frontends can be 64 bit

    How do I go about that please?

    As an aside, why is it not possible to make the w64 codecs as comprehensive as the w32 codecs?

    Thanks

    James

  4. #4

    Re: 10.04 wma lossless playback problem

    How do I go about that please?
    Here's a fairly simple way - don't consider this an exact how to - I don't use 64 bit atm so did quickly on a live lucid cd.

    Some steps may be unnecessary and or redundant - don't have time to test
    (same idea for earlier than lucid - but some packages are named differently.

    This will build a fairly well configured mplayer - other support can be added as well as mencoder, libx264 - didn't seem needed

    You will need this .deb installed (getlibs-all.deb) - thread with link to .deb
    http://ubuntuforums.org/showthread.php?t=474790

    You will need the codecs folder from w32codes - easy way - download w32codecs.deb - r. click - open with archive manager - click on the 'data.tar.gz and extract to desktop - you'll find the codecs folder in usr/lib -

    Tested on all types of wma inc. lossless, many other A/V formats - with -ao's of oss, alsa, pulse, openal, sdl, -vo's of xv, x11, gl, gl2, sdl - all worked fine

    from the top
    Code:
    sudo apt-get install build-essential subversion checkinstall
    Code:
    sudo apt-get install ia32-libs libc6-dev-i386 g++-multilib lib32asound2-dev
    You'll need mplayer deps - the 64 bit libs - maybe not all but don't have time or inclination to willow out

    Code:
    sudo apt-get install ladspa-sdk libaa1-dev libasound2-dev libatk1.0-dev \
    libaudio-dev libaudiofile-dev libavahi-client-dev libavahi-common-dev \
    libcaca-dev libcairo2-dev libcdparanoia-dev libdbus-1-dev libdc1394-22 \
    libdca-dev libdirectfb-dev libdirectfb-extra libdts-dev libesd0-dev \
    libexpat1-dev libfontconfig1-dev libfreebob0 libfreetype6-dev \
    libfribidi-dev libgif-dev libgl1-mesa-dev libglib2.0-dev libglu1-mesa-dev \
    libgsm1 libgtk2.0-dev libice-dev libjack-dev libjack0 libjpeg62-dev liblzo2-2 \
    liblzo2-dev libmail-sendmail-perl libncurses5-dev libogg-dev liboil0.3-dev \
    libopencore-amrwb-dev libopencore-amrnb-dev libopenjpeg-dev libopenal-dev \
    libpango1.0-dev libpixman-1-dev libpng12-dev libpthread-stubs0-dev libpulse-dev libruby1.8 \
    libschroedinger-dev libsdl1.2-dev libslang2-dev libsm-dev libsmbclient-dev \
    libspeex-dev libsvga1-dev libsys-hostname-long-perl libsysfs-dev \
    libtheora-dev libvorbis-dev libvorbisidec-dev libx11-dev libxau-dev \
    libxcb-render-util0-dev libxcb-render0-dev libxcb1-dev libxcomposite-dev \
    libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxft-dev \
    libxi-dev libxinerama-dev libxml++2.6-2 libxrandr-dev libxrender-dev libxt-dev \
    libxv-dev libxvmc-dev libxxf86dga-dev libxxf86vm-dev \
    mesa-common-dev vstream-client-dev x11proto-composite-dev x11proto-core-dev \
    x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev \
    x11proto-randr-dev x11proto-render-dev x11proto-video-dev x11proto-xext-dev \
    x11proto-xf86dga-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev xtrans-dev \
    yasm zlib1g-dev libxvidcore-dev libffado-dev libcelt-dev liba52-0.7.4-dev
    Code:
    gksu nautilus
    copy the above mentioned codecs folder from the extracted w32codecs deb into /usr/lib32/
    Then close window and terminal.


    In a new terminal
    Code:
    getlibs -p  libxvidcore-dev libxvidcore4 libopencore-amrwb-dev libopencore-amrnb-dev libopencore-amrwb0 libopencore-amrnb0 libschroedinger-1.0-0  libschroedinger-dev libspeex-dev libspeex1 libtheora-dev libtheora0 libvorbis-dev libvorbisidec-dev libvorbis0a libvorbisidec1 liba52-0.7.4-dev libdts-dev libcdparanoia-dev libcdparanoia0 liba52-0.7.4 libdca0 libmp3lame0 libdca-dev libmp3lame-dev libdirac-dev libdirac-decoder0 libfaad-dev libfaad2 libsdl1.2-dev
    Code:
    sudo ldconfig
    Code:
    svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer
    Code:
    cd mplayer
    Code:
    CC="gcc -m32" ./configure --target=i686-linux --libdir=/usr/lib32 --prefix=/usr/local --codecsdir=/usr/lib32/codecs --disable-mencoder --disable-x264
    Check your configure - particularly this at the end (a note on live555 at end of post, what I highlighted in red shows w32codecs support is enabled
    Ex.

    Enabled optional drivers:
    Input: dvdnav(internal) ftp pvr tv-v4l2 tv-v4l tv live555 cddb cdda libdvdcss(internal) dvdread(internal) vcd dvb network
    Codecs: libschroedinger xvid libopencore_amrwb libopencore_amrnb libavcodec(internal) qtx real xanim win32 faad2(internal) libdca libmpeg2(internal) liba52 mp3lib(internal) libtheora speex tremor(internal) liblzo
    Audio output: alsa openal jack pulse nas oss v4l2 sdl mpegpes(dvb)
    Video output: v4l2 matrixview opengl sdl pnm jpeg mpegpes(dvb) fbdev svga xvidix cvidix xv x11 xover yuv4mpeg md5sum tga

    Disabled optional drivers:
    Input: vstream radio tv-dshow nemesi smb
    Codecs: libdirac x264 libdv faac musepack toolame twolame libmad gif OpenJPEG
    Audio output: sun esd arts ivtv dxr2
    Video output: zr zr2 ivtv dxr3 dxr2 vesa gif89a caca aa ggi xmga mga winvidix 3dfx dga vdpau xvmc dfbmga directfb bl xvr100 tdfx_vid wii s3fb tdfxfb
    If all is well then go
    Code:
    make
    (if some libs are not found you could try a linker script - copy to text file in home folder named link, make executable, and from terminal (use a terminal at default (home) prompt
    sudo ./link
    (I didn't need it - post, script here

    If the make succeeds (should), then this to install

    Code:
    sudo checkinstall --fstrans=no --pakdir "$HOME/Desktop"  --pkgname mplayer  --pkgversion "3:1.0~svn-$(grep "#define VERSION" version.h | cut -d"-" -f2)"  --backup=no --deldoc=yes --deldesc=yes --delspec=yes --default
    If you need live555 then you need the 32 bit live555 - not hard, ask if so..

    As far as vdpau support - adding libvdpau1 w/ getlibs does work (also probably libvdpau-dev),

    If ffmpeg gets wmal support at some point then you can go back to 64 bit build
    Attachment is full mplayer config to compare if needed and expanded commands if needed, some sample cli outputs showing support
    Attached Files Attached Files
    Last edited by mc4man; September 18th, 2010 at 01:48 AM. Reason: cleaned up a line

  5. #5
    Join Date
    Aug 2006
    Beans
    7

    Re: 10.04 wma lossless playback problem

    Brilliant!
    I'll let you know how I get on.
    That's fantastic; many thanks!
    James

  6. #6
    Join Date
    Dec 2006
    Beans
    7,312

    Re: 10.04 wma lossless playback problem

    Quote Originally Posted by mc4man View Post
    If you need live555 then you need the 32 bit live555 - not hard, ask if so..
    Hmmm.... I have tried and failed to build a 32bit MPlayer on a 64bit system with Live555. What is the trick??? Otherwise I have a reasonable MPlayer running .
    You think that's air you're breathing now?

  7. #7
    Join Date
    Jul 2009
    Location
    Hippiesoldierstan
    Beans
    2,050
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 10.04 wma lossless playback problem

    best of luck installing


    in the meantime if you want a few files quickly converted you can use dBpoweramp Music Converter R14.2 6.7 MB under wine and convert to say flac
    add flac plugin off course it is very fast and converts a file of say 6.3Mb to exactly the same in flac
    sample wma file here if other guys want to try it (thanx to Mc4man for pointing out location)


    i do realize you have many files so clearly the other route is way better
    Last edited by shantiq; September 10th, 2011 at 10:14 AM.
    Linux is Latin for off-the-beaten-track
    what I like MOST about our Ubuntu community ... exchanging tips to make things better .... The World should take heed :]
    ShanArt

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •