Results 1 to 9 of 9

Thread: libfaac/AAC encoding gone!

  1. #1
    Join Date
    May 2010
    Beans
    15
    Distro
    Xubuntu 10.04 Lucid Lynx

    Smile libfaac/AAC encoding gone!

    I used mencoder to convert videos to psp/mp4 with x264 and aac encoder. Since aac encoders were removed, are there any other audio encoders that will play in psp/mp4(newer versions of PSPs)? I'm trying libmp3lame from libavcodec's audio codecs with no luck.
    Last edited by LanternInc; May 6th, 2010 at 08:40 PM.

  2. #2
    Join Date
    Dec 2006
    Location
    Chicago
    Beans
    3,839

    Re: libfaac/AAC encoding gone!

    Code:
    echo "deb http://packages.medibuntu.org/ lucid free non-free" | sudo tee -a /etc/apt/sources.list
    wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update
    sudo apt-get install mencoder
    https://bugs.launchpad.net/ubuntu/+s...ac/+bug/374900

  3. #3
    Join Date
    May 2010
    Beans
    15
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: libfaac/AAC encoding gone!

    echo "deb http://packages.medibuntu.org/ lucid free non-free" | sudo tee -a /etc/apt/sources.list
    wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update
    sudo apt-get install mencoder

    I was able to encode a video with aac, but there were no video codec in the properties in the psp. I still can't play it in the psp.

    I'm using this:

    mencoder -mc 0 -af volume=5:0 -subfont-text-scale 3 -vf pullup,softskip,dsize=480:272,\
    scale=0:0,harddup,unsharp=l3x3:0.5 \
    -ofps 24000/1001 -oac faac -faacopts br=128:mpeg=4: object=2:raw \
    -channels 2 -srate 48000 -ovc x264 -x264encopts \
    bitrate=500:global_header: partitions=all:trellis=1:level_idc=30:threads=2 \
    -of lavf -lavfopts format=psp input.video -o output.video

  4. #4
    Join Date
    Dec 2006
    Location
    Chicago
    Beans
    3,839

  5. #5
    Join Date
    May 2010
    Beans
    15
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: libfaac/AAC encoding gone!

    http://www.mplayerhq.hu/DOCS/HTML/en...dheld-psp.html

    I searched this one already. It doesn't work.

    I tried PSPVC just now and it works. But mencoder with x264 + faac gives better video quality, less video file size and significantly faster than pspvc in encoding. I would still like to use mencoder.

    --
    Sorry. I didn't know that the thread icon above is angry. I thought it was crying sad.
    Last edited by LanternInc; May 6th, 2010 at 07:58 PM.

  6. #6
    Join Date
    Dec 2006
    Location
    Chicago
    Beans
    3,839

    Re: libfaac/AAC encoding gone!

    Quote Originally Posted by LanternInc View Post
    http://www.mplayerhq.hu/DOCS/HTML/en...dheld-psp.html

    I searched this one already. It doesn't work.

    I tried PSPVC just now and it works. But mencoder with x264 + faac gives better video quality, less video file size and significantly faster than pspvc in encoding. I would still like to use mencoder.

    --
    Sorry. I didn't know that the thread icon above is angry. I thought it was crying sad.
    Well if the command suggested by the official documentation doesn't work for you, I certainly won't be able to give you a better one.

  7. #7
    Join Date
    May 2010
    Beans
    15
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: libfaac/AAC encoding gone!

    I tried a couple of videos with different containers: avi and mkv, they all work fine even with aac. But still not working with the psp. For now I guess.

    I'm gonna mark this as solved. The second post already answered the libfaac/aac question.
    ----
    Thanks for the replies.

  8. #8
    Join Date
    Oct 2005
    Location
    France
    Beans
    8
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: libfaac/AAC encoding gone!

    Did you find a solution for mencoder and x264 lib ?

  9. #9
    Join Date
    Feb 2007
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: libfaac/AAC encoding gone!

    Quote Originally Posted by cdenley View Post
    Code:
    echo "deb http://packages.medibuntu.org/ lucid free non-free" | sudo tee -a /etc/apt/sources.list
    wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update
    sudo apt-get install mencoder
    https://bugs.launchpad.net/ubuntu/+s...ac/+bug/374900
    Thanks. I was wondering where my AAC support went, but that fixed it.
    📻 Amp.lol. No bloat, just radio. 🤘

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •