I've been backing up some of my older DVDs to my hard drive, as they were starting to get a bit scratched. Using 9.10, I had no problems. After updating to 10.04 yesterday, however, every method I try to use fails after copying about 80 to 120 MB.

I'm running the amd64 version of 10.04, my optical drive is a TSSTcorp DVD+-RW TS-L632H, and I have installed libdvdcss2 from the Medibuntu repository. I can play the DVDs just fine, but I can't copy them.

Brasero craps out with "Error while burning. Data could not be written (Input/output error)", which based on some things I've read also pops up if data can't be read. I've tried the "Save Log" button, but the log is always empty.

dd exits with "dd: reading `/dev/cdrom': Input/output error".

dd_rescue starts showing nothing but bad blocks roughly at the same point where dd throws the I/O error, and if I run it in reverse, it starts showing bad blocks immediately.

k3b seems to work... but it took nearly half an hour (which is a bit longer than it should have taken), it threw a "Problem while reading. Retrying from sector n" error three times, and VLC won't play the resulting ISO, either directly or mounted.

I would say that it seems like a problem with copy protection, except that I have libdvdcss2 installed and I can play the DVDs just fine. I just can't copy them to an ISO. And it's not a matter of the discs being too scratched or a problem with the drive, since as I said I can play them just fine, and I can copy them in Windows using MagicISO.

Some of the DVDs I'm trying to copy aren't available anymore, but I'd hate to have to boot into Windows just to copy some discs since I do pretty much everything else in Linux. So any help would be greatly appreciated.