Results 1 to 5 of 5

Thread: How to silence Software Center for an unwanted upgrade?

  1. #1
    Join Date
    Mar 2010
    Location
    Zipangu
    Beans
    27
    Distro
    Ubuntu 16.04 Xenial Xerus

    How to silence Software Center for an unwanted upgrade?

    These days, every morning I boot my PC up, Ubuntu Software Center 1.0.3 says "upgrade your Firefox browser to the version 3.5." However, the current version of my Firefox is 3.6.3 which has been upgraded via the software's automatic self-update.

    I'd like to silence the Ubuntu Software Center for the Firefox upgrade. How to do that?

    Thanks in advance.

  2. #2
    Join Date
    Oct 2006
    Beans
    56,254

    Re: How to silence Software Center for an unwanted upgrade?

    Have you tried locking the package version that you don't want to upgrade via Synaptic Package Manager (Synaptic Package Manager > Package menu > Lock Version).

  3. #3
    Join Date
    Mar 2006
    Location
    European Union
    Beans
    321
    Distro
    Ubuntu

    Re: How to silence Software Center for an unwanted upgrade?

    You maybe have 2 versions of Firefox installed in parallel. You're using the 3.6 by default, but there is an update for the 3.5 as well. It won't harm your installation to make the upgrade. But if I were you and if you do not use the other version, then I would go to the System->Adminstration menu, choose Synpatic, look for firefox-3.5 and uninstall it.

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: How to silence Software Center for an unwanted upgrade?

    Quote Originally Posted by HiSiskin View Post
    However, the current version of my Firefox is 3.6.3 which has been upgraded via the software's automatic self-update.
    I don't like that method of upgrading, unless you are using a version downloaded directly from Mozilla and running in parallel with the default Firefox version.

    It seems, to me, although this is the first I read about such problem, that the package manager is trying to downgrade because you have enable Firefox self-updates. So it checks the version and determine that it is always different, so it keeps prompting for a downgrade.

    I would recommend reverting back to Firefox 3.5, disabling Firefox self-update and upgrading it using Ubuntuzilla (32bit) or downloading it from Mozilla. You could also use a PPA to upgrade. See the Installing Other Versions section of Firefox optimization and troubleshooting thread.

  5. #5
    Join Date
    Mar 2010
    Location
    Zipangu
    Beans
    27
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: How to silence Software Center for an unwanted upgrade?

    Thank you all for all of your kind and rapid replies. I'll lock the Ubuntu-controlled version of Firefox by using the Synaptic software. Thanks again.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •