I had installed Ubuntu 9.10 inside windows 7. I was using it for the last 6 months or so.. Just when i was thinking I can live without windows I screwed up my Ubuntu.. and it refuses to boot..
with the error No wubildr

I know there have been many threads with the same error.. but i think my situation is a little different.. ( Also, i tried many solutions suggested in other threads and blogs .. unfortunately none of them are working for me) Please help.. as i have all my data on it.. and lots of projects whose deadlines are fast approaching.. ..


I was using ubuntu 9.10 within windows 7.. even though i had more than 60 GB free space in my windows partition where ubuntu was installed .. i was getting low disk space warning in ubuntu... then i figured out it is because i had opted the default 17GB option which i had used completely..

Now i searched online and found that i can resize /home using lvpm 96... it started behaving unexpectedly.. and refuse to quit..so i had to remove it completely and then install lvpm 60 ( as this was the one which was used in the blog which i was referring .. ) but even this refused to work.. suddenly it said .. formating.. for some strange reason which i dont know.. i tried to cancel it.. but couldnt... and it continued.. i was left with no option but to power down my laptop..

Later when i tried to boot again... ubuntu fails with error.. no wubildr.. but i see wubildr file in c:\ .. also in c:\ubuntu\winboot... also i downloaded and old files with new wubildr just in case if the old ones were corrupted.. but that also didnt help..

And to add to my sorrows.. i dont have a back up of my data

I used ubuntu live cd and booted .. there i can see earlier folders.. no files... all folders are empty..

kindly help me .. I need my data.. and need to get back on ubuntu asap..

Any help will be much appreciated..

thanks in advance,