Results 1 to 2 of 2

Thread: APTonCD doesn't restore..

  1. #1
    Join Date
    Oct 2007

    [SOLVED] APTonCD doesn't restore..

    Ubuntu Desktop (Karmic) 9.10

    1. I install/run the latest version of aptoncd
    2. I click RESTORE > LOAD and choose the iso and it loads just fine
    3. I click the RESTORE button and it says "Preparing to copy files"
    4. It says "please wait files are restored" for a few seconds and then nothing happens. It doesn't freeze or anything.. It just still shows the files that are to be restored

    Output from terminal:

    mobile@mobile-flashdrive:~$ aptoncd
    /usr/lib/python2.6/dist-packages/APTonCD/restore/ GtkWarning: gtk_tree_model_get_iter: assertion `path != NULL' failed
      result =
    /usr/lib/python2.6/dist-packages/APTonCD/restore/ GtkWarning: gtk_list_store_set_valist: assertion `VALID_ITER (iter, list_store)' failed
      result =
    mount point =  /tmp/aptoncd-mnt-image/
    iso image =  /media/ACTIVE BOOT/aptoncd-20100228-CD1.iso
    [Errno 30] Read-only file system: '/tmp/aptoncd-mnt-image/.disk/info'
    /usr/lib/python2.6/dist-packages/APTonCD/widgets/ DeprecationWarning: Accessed deprecated property Package.installedVersion, please see the Version class for alternatives.
      self.installed[] = pkgi.installedVersion
    [Errno 1] Operation not permitted: '/tmp/aptoncd-mnt-image/'
    mount point =  /tmp/aptoncd-mnt-image/
    iso image =  /media/ACTIVE BOOT/aptoncd-20100228-CD1.iso
    [Errno 1] Operation not permitted: '/tmp/aptoncd-mnt-image/'
    umount: /media/ACTIVE BOOT/aptoncd-20100228-CD1.iso: not mounted[Errno 30] Read-only file system: '/tmp/aptoncd-mnt-image/.disk/info'

    Instead of restoring through the aptoncd program, i mounted the iso myself and navigated to the "packages" directory where I ran:

    sudo dpkg --install *deb
    and everything installed fine
    Last edited by mishathegoat; March 1st, 2010 at 11:04 AM. Reason: Solved

  2. #2
    Join Date
    Mar 2008
    Las Vegas

    Re: APTonCD doesn't restore..

    Perhaps mark the thread solved for the next user! 8)
    Debian Stable
    Mark Your Thread Solved

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts