My Panp5 has been running Karmic just fine for some time. I recently created a separate partition for Jaunty, so that I could use Nvidia's CUDA development tools (which don't yet work with Karmic). All went well until this morning, when the Update Manager wanted to update the linux kernel. I let it do that, but lost access to my Jaunty partition from the GRUB boot menu. I tried update-grub, among many other things, but still could not see the Jaunty partition from GRUB.

Hoping that GRUB2 would do better, I installed it, but still no access to the Jaunty partition. GPARTED showed the Jaunty partition (/dev/sda7) still there. I also had trouble with GRUB2, so I uninstalled it and reinstalled legacy GRUB.

I still couldn't see the Jaunty installation at on /dev/sda7 in the GRUB menu.

At some point, I must have damaged something. Now my Panp5 just displays "GRUB" when I boot it, but won't go further.

I used a LiveCD and GParted to look at the disk. /dev/sda7 was listed as bootable, but /dev/sda1 was not. So I used GParted to make /dev/sda1 bootable. But booting still hangs at "GRUB"

Help! (and Thanks!)