Results 1 to 9 of 9

Thread: 9.10 sound issues, running in VMWare

  1. #1
    Join Date
    Apr 2009
    Location
    Vancouver Canada
    Beans
    50
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question 9.10 sound issues, running in VMWare

    I'm running 9.10, even though I'm a newbie with Ubuntu, because it gives me better support for my monitor. However, I'm having sound problems.

    I'm running 9.10 virtualized with VMware on a Mac running Snow Leopard. I used the Comprehensive Sound Problems Solutions Guide sticky and have gotten to Part 3 of the 'General Help' section.

    Step 3, LSPCI -v ID'd my sound card correctly as:

    02:02.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)
    Subsystem: Ensoniq ES1371 [AudioPCI-97]
    Flags: bus master, medium devsel, latency 64, IRQ 16
    I/O ports at 2080 [size=64]
    Kernel driver in use: ENS1371
    Kernel modules: snd-ens1371

    I've installed PulseAudio Volume Meter and can see the signal to my card. When there is signal & sound it is really choppy and unlistenable. At other times it is non existent (no signal showing, no sound at all). Typically the choppy sound will give way to silence / no signal.

    My 9.10 install was a fresh one so I don't believe the issue is an older kernel, which I've seen suggested in other threads. I am using VMWare Tools, which were installed under Vmware 2. Upgrading to VMWare 3 trial has not helped as far as I can tell. Sadly I'm not sure if they are loaded automatically.

    I'm stumped for how to proceed. I think the card is ID'd correctly and the drivers are running.

    Suggestions?

  2. #2
    Join Date
    Apr 2005
    Beans
    47

    Re: 9.10 sound issues, running in VMWare

    I have a similar setup. It seems that a new feature of pulseaudio, GlichFreeAudio is incompatible with the VMWare virtualized sound card driver (and other drivers as well... see http://n2.nabble.com/pulseaudio-brea...td3312334.html ) . Disabling it seems to work for me. To do so change

    Code:
    load-module module-udev-detect
    to

    Code:
    load-module module-udev-detect tsched=0
    in /etc/pulse/default.pa

    and then execute
    Code:
    killall pulseaudio && pulseaudio

  3. #3
    Join Date
    Nov 2006
    Location
    USA
    Beans
    272
    Distro
    Ubuntu

    Talking Re: 9.10 sound issues, running in VMWare

    Klin'Targ, it was very helpful. Now I can hear musics in Ubuntu on vmware fusion 3.
    Last edited by jeyaganesh; December 1st, 2009 at 08:59 PM. Reason: spelling mistake
    See my photos on Flickr

  4. #4
    Join Date
    Jul 2007
    Beans
    6

    Question Re: 9.10 sound issues, running in VMWare

    Thank you for the fix. Unfortunately it didn't work for me.

    I did modified /etc/pulse/default.pa as instructed, then, my interpretation of the next step of "and then execute" was to open up an Terminal window and type:

    killall pulseaudio && pulseaudio

    and

    Enter/Return, righ?

    So I did, but I am getting back this:

    E: pid.c: Daemon already running.
    E: main.c: pa_pid_file_create() failed.

    What I do wrong? Please help! Thank you!

    My system & setup:

    Mac Pro OS X Version 10.6.2
    VMWare Fusion Version 2.0.6 (196839)
    Ubuntu Server 9.10 (karmic)
    Kernel Linux 2.6.31-15-server
    GNOME 2,28.1

  5. #5
    Join Date
    Aug 2007
    Location
    Nine Towers
    Beans
    336
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 9.10 sound issues, running in VMWare

    I did the same - I did modify /etc/pulse/default.pa - and
    Code:
    stoneface@ubuntu:/etc/pulse$ killall pulseaudio && pulseaudio
    Then I got
    Code:
    E: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
    E: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_ens1371'. Please report this issue to the ALSA developers.
    E: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
    E: alsa-source.c: ALSA woke us up to read new data from the device, but there was actually nothing to read!
    E: alsa-source.c: Most likely this is a bug in the ALSA driver 'snd_ens1371'. Please report this issue to the ALSA developers.
    E: alsa-source.c: We were woken up with POLLIN set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
    But it did work after that

    P.S. Did this on a Macbook Pro OS X 10.6.2 using VMWare Fusion 3 to run Ubuntu
    Last edited by Stoneface; December 7th, 2009 at 06:08 PM.
    process `skype' is using obsolete setsockopt SO_BSDCOMPAT

  6. #6
    Join Date
    Aug 2007
    Location
    Nine Towers
    Beans
    336
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 9.10 sound issues, running in VMWare

    After an update to the latest kernel sound is gone again. default.pa was not altered. When I exceuted killall pulseaudio && pulseaudio the sound did not return..

    Sound was turned off after restarting.. Just had to raise the volume ...
    Last edited by Stoneface; December 15th, 2009 at 06:54 PM.
    process `skype' is using obsolete setsockopt SO_BSDCOMPAT

  7. #7
    Join Date
    Oct 2008
    Location
    Ottawa Canada
    Beans
    1,208
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: 9.10 sound issues, running in VMWare

    Quote Originally Posted by Klin'Targ View Post
    I have a similar setup. It seems that a new feature of pulseaudio, GlichFreeAudio is incompatible with the VMWare virtualized sound card driver (and other drivers as well... see http://n2.nabble.com/pulseaudio-brea...td3312334.html ) . Disabling it seems to work for me. To do so change

    Code:
    load-module module-udev-detect
    to

    Code:
    load-module module-udev-detect tsched=0
    in /etc/pulse/default.pa

    and then execute
    Code:
    killall pulseaudio && pulseaudio
    Can you let me know how exactly in Terminal I can make these changes? I'm new to all this and need some guidance. Thanks!!!

  8. #8
    Join Date
    Jan 2010
    Beans
    1

    Re: 9.10 sound issues, running in VMWare

    Quote Originally Posted by rmcellig View Post
    Can you let me know how exactly in Terminal I can make these changes? I'm new to all this and need some guidance. Thanks!!!
    No problem.

    Open the terminal in any way you like...personally, I like to do alt+f2 and type in gnome-terminal. Once you're in the terminal, run

    Code:
    sudo gedit /etc/pulse/default.pa
    ( Note: I used gedit....use whatever text editor you prefer )

    This should load the file. I found the line
    Code:
    load-module module-udev-detect
    and replaced it with

    Code:
    load-module module-udev-detect tsched=0
    Save and close out of it. Now, my process for ending pulse audio is different ( and cleaner ) than Klin suggested. Try this:

    Code:
    pulseaudio --kill
    then

    Code:
    pulseaudio --start
    Good luck


    Also, thanks to Klin'Targ for the fix.
    Last edited by pengudeus; January 8th, 2010 at 05:11 PM.

  9. #9
    Join Date
    Apr 2008
    Location
    Syracuse,NY
    Beans
    1
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Smile Re: 9.10 sound issues, running in VMWare

    Thanks for the fix....it worked great I have finally sound, it was driving me crazy!!!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •